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1.1 About Creo Expert Moldbase Extension
Use Creo Expert Moldbase Extension (EMX) to create a mold base as a regular assembly.

1.2 About the EMX Ribbon

1.2.1 Commands
The Creo Expert Moldbase Extension commands are accessible through a the EMX ribbon.
The content of the Creo Expert Moldbase Extension ribbon is different depending on the type
of the current model and it’s related modes in Creo Parametric.

1.2.2 Assembly Mode
An Creo Expert Moldbase Extension mold base project always starts with an assembly.
Therefore, the Assembly Mode is the most present mode.

The EMX Assembly tab contains the following groups.

• Preparation:

The Classify dialog box for setting up the different model types for assembly
components.

The Identify trim faces dialog box for selecting and designating quilts as trim
surfaces for ejector pins and lifters.

The Duplicate Cavity dialog box to create duplicated cavity insert assemblies
• Project:

The user can Create New, Modify and finish projects.
• Structure:

Subassemblies can be added with Add Subassemblies to the project.

Existing subassemblies can be deleted with Delete Subassemblies.
• Mold Base:

The Cavity Layout can be managed.

In the Assembly Definition dialog box the general design of the mold base can be
defined.
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In the Cavity Cutouts dialog box pockets can be created within the cavity paltes.

The Component Status allows the user to decide which type of components
models should be are assembled or just predefined.

In the Group overflow you will the Define Main Axis Offset feature for off-centered
mold bases.

• View:

The predefined simplified representations Injection Side (IS) or Ejector
Side (ES) can be toggled in this section.

Components can be added to one of these predefined views via Add Components
To.

• Documentation:

The Bill of Materials can be managed in this group.

You can Edit BOM Parameters of selected parts.

You can Open drawing of current model or Open drawing of selected
model

• EMX Tools:

This is the group for a variety of handy tools.

○ Calculating Model Size

○ Set Technology Colors
○ Set Accuracy
○ Export Csys Position
○ Calculate Clamping Force

• Administrator Tools:

Administrators and users can configure Creo Expert Moldbase Extension with the
EMX Options dialog box.

The Component Editor and the Mold Base Editor can be found in this
group.
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Add Drawing Formats, Verify unused Models and Replace Parameters in existing
Creo Expert Moldbase Extension assemblies can be started from here.

• Help:

Start the Creo Expert Moldbase Extension Help Center with Help and check your current
release version with the Info About dialog.

The EMX Components tab contains:

• Mold Base:

Additional access to the Assembly Definition and the Component Status .
• Cooling Components:

Create Cooling Components.

Start the Waterline Designers.

An extracted model of all cooling circuits can be created with ShowWaterline.

Cooling diameters can be changed either by Change diameter of all cooling holes or
Change diameter of selected cooling holes.

With Delete entire waterline all cooling components will be deleted from the project
assembly.

• Ejector Pin:

Create Ejector Pins.

Start the Ejector Pin Designer.
• Components

Create Creo Expert Moldbase Extension Components like:

○ Screw

○ Guide Component

○ Equipment

○ Stop System

○ Dowel Pins

○ Support Pillar

○ Slider

○ Latch Lock

○ Lifter
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• Library:

Create Library Components.
• Component Handling:

Modify, Remove, Assemble Again and Assemble as Copy of all kinds
of Creo Expert Moldbase Extension components.

Additionally Assemble predefined components from this group

1.2.3 Manufacturing Mode
The cavity insert assembly is commonly a Manufacturing model. Therefore some
Creo Expert Moldbase Extension commands are available in the ribbon for the Manufacturing
Mode. During the preparation of the cavity insert assembly the Classify Dialog and the
Duplicate Cavity Dialog will be needed. It is recommended to select trim surfaces with
Identify trim faces in manufacturing model.

The EMX Manufacturing Mode contains:

• Preparation:

The Classify dialog box.

The Identify trim faces dialog box.

The Duplicate Cavity dialog box.
• Project:

Create New projects.

1.2.4 Drawing Mode
The Drawing Mode in Creo Expert Moldbase Extension contains a couple of handy features
for editing of the mold base drawing.

The EMX Drawing Mode contains:

• Documentation:

The Bill of Materials can be used to place balloons to the drawing.
• Ejector Pin:

Add Drawing Symbols for ejector pins to the drawing.
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1.2.5 Part Mode
In Part Mode it is possible to predefine all different types of
Creo Expert Moldbase Extensioncomponents.

The EMX Part Mode tab contains:

• Preparation:

The Identify trim faces dialog box.
• Components:

All kinds of components are available.
• Library:

Library Components are available.
• Component Handling:

Modify, Remove, Assemble Again and Assemble as Copy of all kinds
of Creo Expert Moldbase Extension components.

• EMX Tools:

Function like Calculating Model Size can be found.
• Administrator Tools:

EMX Options and the Component Editor are accessible in part mode.
• Help:

Start the Creo Expert Moldbase Extension Help Center with Help and check your current
release version with the Info About dialog.

1.3 About the Principal Workflow
Starting from an existing cavity insert assembly the principal
Creo Expert Moldbase Extension workflow contains the following steps:

1. Prepare the cavity insert assembly in Creo Parametric manufacturing:

a. To define the functions of the components for the cavity insert assembly, click EMX

Manufacturing Mode ▶ Classify. The Classify dialog box opens.
b. If multiple cavity copies are required for a mold base project click EMX

Manufacturing Mode ▶ Duplicate Cavity. The Create Insert Copies dialog
box opens from which you can create dependent copies of the assembly.
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c. If ejector pins and lifters need to be trimmed against quilt surfaces, identify trim faces

within the reference model by clicking EMX Manufacturing Mode ▶ Identify
trim faces.
NOTE:
If no cut quilt is selected as a trim surface, ejector pins are trimmed against the solid
of the reference model. Lifters cannot be trimmed.

2. Create the new project:

a. Click EMX Manufacturing Mode ▶ Create New. The Project dialog box
opens.

b. Add project information as required and click OK to close the dialog box and create
the new project.

3. Set up the assembly structure: Click EMX Assembly ▶ Add Subassemblies. The
Subassembly dialog box opens.

4. Define the layout of the cavity insert assembly pattern and assemble the cavity insert

assemblies: Click EMX Assembly ▶ Cavity Layout. The Cavity Layout dialog
box opens.

5. Create plates, guide components, and major equipment: Click EMX Assembly ▶
Assembly Definition to open the Mold Base Definition dialog box. Set various options
in this dialog box and then click OK after creating the required components.

6. Load an existing mold base assembly, add, modify or delete plates, locate rings, sprue
bushings, guide components, and standard screws: In the Mold Base Definition dialog

box, click . You can also define machine data. Click OK after defining the required
components.

7. Define the layout of the cavity insert assembly pattern and to assemble the cavity insert

assemblies: Click EMX Assembly ▶ Cavity Cutouts. The Cavity Cutouts dialog
box opens.

8. See the status of the component: Click EMX ▶ Component Status to open the
Component Status dialog box.

9. Add screws, ejector pins, cooling system, sliders, and so on: Click EMX Components and
then in the Components group, select a component. Click Preview to check
component properties before assembly.

10. Use an editable library component: Click EMX Components ▶ Library ▶
Assemble. The Library Component dialog box opens.
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11. Analyze the model and finish the design: Click EMX Assembly and then in the EMX
Tools group, select a tool to use for the analysis.

12. Generate a Bill of Materials: Click EMX Assembly ▶ Bill of Materials. The Bill of
Materials dialog box opens.
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2.1 Introduction
This Expert Moldbase Extension 12 [EMX] tutorial contains step by step explanations for all
major features. It is recommended to go through this tutorial chapter by chapter. Many EMX
dialog boxes and functions are very similar for different mold base components. So they are
explained only once (the first time this dialog box is used during the mold base design). In
later chapters the author assumes you have this background information already. If you
"jump" within the chapters you might not understand everything.

2.1.1 The releases used in this tutorial are:
• PTC Creo Paramteric 6.0.1.0
• Expert Moldbase Extension 12.0.0.2

2.2 Conventions

2.2.1 Conventions
MEASURE_DISTANCE The courier font indicates a configuration option, parameter

or a path-/filename

Bold letters Indicate elements of the EMX GUI and Ribbon
An icon image represents a button in the Creo Parametric
Ribbon or in an EMX dialog

LMB Press the left mouse button
MMB Press the middle mouse button
RMB Press the right mouse button

2.2.2 Before you start
Required settings in the config.pro

Please check if your config.pro file contains the following entries that are necessary for the
correct use of EMX.

default_ext_ref_scope ALL

(to allow external references)

set_trail_single_step NO

(to make sure macros/mapkeys used within EMX
can be executed without interaction of the user)

native_kbd_macros NO

(EMX macros run independent from any LANG
setting)



Tutorial Introduction

Page 21/448

open_simplified_rep_by_default NO

(To avoid the SimpRep-dialog box opening when
retrieving a drawing)

show_dim_sign NO

(EMX will handle positive and negative
dimensions like offsets internally)

2.2.3 EMX Options
To make sure that your EMX 12.0 installation will work according to this tutorial you have to
set EMX configuration options.

Open the EMX Configuration options with EMX Assembly ▶ EMX Options .

Set the following options while working through the examples of this tutorial

NR_DIGITS_COMMON 5

(sets the digits for all dimensions within EMX
models and components)

When working with inch catalogs, value must be 5
minimum. Otherwise the inch-dimensions cannot
be set properly.

NR_DIGITS_BOM 5

(Used for digits in parameter values (i.e. SIZE) in
the EMX BOM only)

SAVE_DRAWINGS YES

(Creates drawings during component definition
process automatically)

COMPANY_ID -

(Changing this setting will make EMX behave
customer specific)
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3.1 About the Cavity Insert Assembly as requirement for Moldbase
Projects
To start working with Creo Expert Moldbase Extension an finished cavity insert assembly is
required.

To create this cavity assembly a Creo Mold Design and Cast option is required.

3.2 Before Starting Your Design
Download 00_start to start from with this chapter.

3.2.1 Initial work on the cavity insert assembly
Before starting a new mold base project, some initial work on the needs to be done as
described below:

• Understand the received data

If the cavity insert assembly is resulting from Creo Mold Design Extension, make sure all
required files are in the working directory. If it is an IGES or STEP file, import it into
Creo and convert it into a solid model(s).

• Cavity layout planning

You should have an idea on how many cavities are going to be used? How will the cavity
layout look like? What is the overall size of the cavity?

• Type of mold base

You should have an idea on what type of mold base is going to be used, two-plate mold or
three-plate mold? Is it a hot runner mold? What is mold opening distance is required?

• Runner planning

Start planning your runner system in advance.
• Ejector Pin planning

Plan the ejector pin location, use Datum Points to indicate the ejector pin position in the
mold reference part. You should also take down the ejection distance required for this
design part.

• Slider planning

Is one or multiple slider(s) required for this project? In what locations? What is the slider
opening distance? Place a Datum Coordinate System on to the slider in Creo Mold Design
Extension.

• Lifter planning

Is a lifter required for this project? In what location? Place a Datum Coordinate System on
to the reference part where the lifter must be placed.

• Waterline/Cooling system planning

What kind of cooling system is required for this article?

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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3.2.2 Set Working Directory
The usage of Creo Expert Moldbase Extensionbegins once you have finished the design of the
cavity insert assembly. For this tutorial the assembly MFG.ASM is used. This can be found in
the folder models/tutorial_start of the tutorial directory.

1. Copy all models from the directory %TUTORIAL_PATH%/models/tutorial_
start to your working directory or Workspace.

2. Open MFG.ASM.

3.2.3 Prepare datum points for ejector pins
1. Retrieve the master design model ARTICLE_REF.PRT

2. Make sure that Datum Points and Coordinate Systems are generally visible.

The required Datum Points for ejector pin design have been prepared for this tutorial.

a. PNTS_COREPIN_1: Used for trimmed core-pins at the screw bosses
b. PNTS_SLEEVE_1: Used for according ejector sleeves at the screw bosses
c. PNT_COREPIN_2: Used for a trimmed core-pins at the screw boss with a through

hole. Additionally used for a trimmed core pin inside the cavity insert on the fixed half
d. PNT_SLEEVE_2: Used for according ejector sleeves at the screw boss with a through

hole
e. PNTS_EPIN_ROUND_4MM: Pattern points, used to create round ejector pins with a

diameter of 4 mm.
f. PNTS_FLAT_EPIN_5-5X1MM_0-DEG: Used for flat blade ejector pins 5.5 x 1 mm

and not rotated
g. PNTS_FLAT_EPIN_5-5X1MM_90-DEG: Used for flat blade ejector pins 5.5 x 1 mm

and 90° rotated
h. PNTS_FLAT_EPIN_5-5X1MM_113-DEG: Used for flat blade ejector pins 5.5 x 1

mm and about 113° rotated
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i. PNTS_FLAT_EPIN_5-5X1MM_0-DEG: Used for flat blade ejector pins 3,2 x 1 mm
and not rotated

j. PNTS_SHOULDERED_EPINS_2MM: Used for shouldered trimmed ejector pins
with a diameter of 2 mm and rotation fixture.

NOTE:
Usually the designer must add these datum points and consider where and how ejector
pins need to be placed.

3.2.4 Prepare trim surfaces for ejector pins in case it is required
By default ejector are trimmed against the reference part itself. This can not be achieved in
case is defined on a hole itself or in case the ejector cross section is not inside the reference
part. In this tutorial two ejector trim surfaces are defined.

• TRIM_SURFACE_COREPIN_1: Used to trim the core-pin at the screw bosses with hole
• TRIM_SURFACE_COREPIN_2: Used to trim the core-pin at the screw bosses with hole

on the fixed half side
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3.2.5 Prepare coordinate systems for lifters and sliders
It is required to think about the position of lifters and sliders.

• CSYS_LIFTER: Used for lifter definition.

NOTE:
The x-axis of this coordinate system must point towards the planned opening movement
of the lifter, the z-axis is in mold opening-direction

• CSYS_SLIDER: Used for slider definition.

NOTE:
The x-axis of this coordinate system must point towards the planned opening movement
of the slider, the z-axis is in mold opening-direction

• CSYS_RUNNER: Used for runner definition.

NOTE:
The x-axis of this coordinate system must point towards the planned demolding direction
of the runner, the z-axis is in mold opening-direction

3.2.6 Prepare additional trim surfaces for sliders
1. Open the base model ARTICLE.PRT.

The base model contains a quilt surface Trim 5. This surface will be used to trim the cam
of the slider.
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3.3 About Classifying Cavity Insert Assembly Components

The Classify dialog box can be open with Classify command.
Creo Expert Moldbase Extension must know the meaning of certain components in the cavity
insert assembly. This is necessary for hand full of reasons:

• The outline of the cavity insert assembly can be calculated. These dimensions can later be
user in the mold base definition to select the required size of the moldbase, to create a
cavity layout or to create the cutouts in the cavity plates. Therefore it is required classify
the cavity insert assembly.

• The software should avoid any geometric modification on the workpiece or on the
reference part of the cavity insert assembly as this will cause regeneration failures.

• The software needs to know the reference part as this part islater used for several
operations, e.g. trimming ejector pins.

1. Component can be classified by selecting a model type in the Model list in the Model
Type column. The following types of models are available:

• Model—General model.

• Workpiece—Creo Parametric workpiece.

• Insert MH—Extracts a moving half. When you select this type of model, the part
ID and the part name are automatically added.

• Insert FH—Extracts a fixed half. When you select this type of model, the part ID
and the part name are automatically added.
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• Reference Model—Used when performing interference checks. Important for the
ejector pin designer.

• Insert Assembly—Used when measuring the outline of the included insert MH
and insert FH models.

2. The outline calculation of the cavity insert assembly can be forced by the check box Use
the selected insert assembly size. This is available only if an insert assembly is
selected.

3. Select the Rename Extracts check box to rename all insert MH and insert FH
components with the specific part name, and to save part ID parameters.

4. Click OK to recalculate the insert assembly outline, rename the insert models, and to save
component settings, or click Cancel to close the dialog box without saving changes.

NOTE:
If EMX Option ADD_TRIM_FACE_IN_CORE is set, EMX will create a ‘Solid surface Copy’
to all models classified as Reference Model automatically.

3.4 To Classify the Cavity Insert Assembly
Download 01_To Classify the Cavity Insert Assembly to start from with this chapter

1. Open the Manufacturing model MFG.ASM

2. Select EMX Manufacturing Mode ▶ Classify

The Classify dialog box opens showing a list of all models from the assembly including
the assigned model type.

3. In the Classify dialog box Double-Click the Model Type of a component to change its
type.

For this tutorial the types as shown in the image above:

• ARTICLE_REF: Reference Model
• WORKPIECE: Workpiece
• MOLD_VOL_ES: Insert MH
• MOLD_VOL_IS: Insert FH
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• MOLD_VOL_CORE_1: Insert FH
• MOLD_VOL_SLIDER_1: Insert MH

4. Make sure the Use the selected insert assembly size check box is enabled.

The Outline of the components classified as Insert MH and Insert FH will be determined
and the result to saved to parameters in the assembly.

5. Close the dialog box with OK.

3.5 About Creating Duplicated Cavity Insert Assemblies
Most mold bases are used to manufacture more than one copy of the article. For multiple
cavity mold bases it can be necessary to have independent model geometry for the individual
inserts, i.e. in case different cooling channels should be applied to the cavity inserts.

Within the Duplicate Cavity feature of Creo Expert Moldbase Extension external merge
features are used to create the copies. Even if you want to create a single cavity mold we
recommend to create a copy of the insert assembly as i.e. the work piece can be removed so it
will not appear in the design at all.

NOTE:
Cavity insert assemblies based on family tables should not be used with Duplicate Cavity .
In case you prefer creating the insert assembly copies manually this step can be skipped.

1. With the original manufacturing model active the Create Insert Copies dialog box can be

opened by clicking EMX Manufacturing Mode ▶ Duplicate Cavity .
2. Double-click the Type column to set copy options:

• Copy—Creates a new copy of this component using a external merge feature

• Ignore—Does not include the component in the copy.

• Keep—Retains the original models in the copied assemblies.
3. In the Quantity box, enter a value for the number of copies to generate.
4. TheWildcard entry defines how the renaming of the copied assemblies and parts will take

place. When you make copies of an assembly or insert, the wildcard character is added as
a suffix along with a numerical increment. The placeholer %i represents a counter starting
with 1. For instance: modelname_copy_1.abc, modelname_copy_2.abc, etc.

5. Click OK to create the copies of the active assembly and then close the dialog box or click
Cancel to close the dialog box.

3.6 To Create Duplicated Cavity Insert Assemblies
Download 02_To Create Duplicated Cavity Insert Assemblies to start from with this chapter.

1. Click EMX Manufacturing ▶ Duplicate Cavity .
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The Multi Cavity dialog box opens.
2. Double-click the Type operation within the table to set the type for each component in the

cavity assembly.

3. Set the Type to for:

• MFG.ASM (The assembly always needs to be copied)
• MOLD_VOL_ES.PRT

• MOLD_VOL_IS.PRT

4. Set the Type to for:

• ARTICLE_REF.PRT

• MOLD_VOL_CORE_1.PRT

• MOLD_VOL_SLIDER_1.PRT

5. Set the Type to for:

• WORKPIECE.PRT

6. Select 2 from the Quantity pull down to determine how many copies will be created.

7. Close the dialog box with OK .

With the current settings two new assemblies are created in session.

Parts defined with keep will be assembled directly (ARTICLE_REF, MOLD_VOL_
CORE_1 and MOLD_VOL_SLIDER_1).
Ignored parts like the WORKPIECE are not assembled at all.
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Copied parts have an external merge feature:

8. Check the two copied cavity assemblies MFG_1.ASM and MFG_2.ASM .

3.7 About Identifying Trim Quilts in Cavity Insert Assembly
In Creo Expert Moldbase Extension Ejector Pins can be trimmed. To create a trim feature two
different ways exists:

• Trim against the reference model: In case the ejector pin or lifter intersects with a part

which was classified as Reference model in Classify, a Trim to geometry
feature will be created during the trim operation.

This default behavior is easy to use and does not require any additonal feature creation
inside the reference model. Still, in certain design situation this feature is limited.

○ The feature can fail for certain free form shapes.
○ The feature does not completely trim the ejector pin in case the ejector pin cross-

section is not fully covered by the reference model
○ In case the ejector pin is defined on a hole, the reference model can not be found and

no feature can be created.
To overcome these problems in can be necessary to use the alternative trim solution

• Trim against a trim quilt surface: In case the ejector pin intersects with a quilts surface

which is identified in Identify trim faces a Solidify feature will be created
during the trim operation.

The disadvantage of this solution is the required additional step of creating these quilt
surfaces within the reference model. On the other side the solidify feature covers all
mentioned problems described above.

○ It is stable for free form shapes
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○ Quilt surfaces can go beyond the reference model geometry and therefore easily cover
the full ejector pin cross section.

○ Quilt surfaces can be used to fill holes in the reference model geometry.
To identify trim surfaces enter the Trim Faces dialog box. Trim surfaces can be identified in
part, assembly and manufacturing mode

NOTE:
When there are no quilts in the list, you cannot trim lifters.

1. To open the Trim Faces dialog box opens click Preparation ▶ Identify trim faces.

2. To remove a quilt, select it from the Existing trim faces list, and then click to
remove the quilt from the list.

3. To add a quilt, click , select a quilt in the graphics window, and then click Close to
close the dialog box.

3.8 To Identify the Trim Quilts in the Cavity Assembly
Download 03_To Identify the Trim Quilts in the Cavity Assembly to start from with this
chapter.

3.8.1 Create the Trim Surface
1. Open the model ARTICLE_REF.PRT.
2. For this tutorial two trim quilt surfaces are already created: TRIM_SURFACE_

COREPIN_1 and TRIM_SURFACE_COREPIN2. In additional mold base design these
surfaces need the be created manually.
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3.8.2 Select the trim surface
1. Stay in the part mode of the ASM_PALM_REF.PRT and open EMX Part Mode ▶

Preparation ▶ Identify trim surfaces

The Ejector Trim Faces dialog box opens.

2. Add a new surface to the list of trim surfaces with .
3. Select the quilt surface TRIM_SURFACE_COREPIN_1 in the graphics window.

4. Select the quilt surface TRIM_SURFACE_COREPIN_2 in the graphics window.

5. Close the Select dialog box with Cancel.
6. Close the Ejector Trim Faces dialog box with Close.
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4.1 About Projects
The top mold base assembly is referred to as a project. When you create a mold base design
you must define general parameters and data for the mold base components.

• Click EMX ▶ Create New to create a new Creo Expert Moldbase Extension
assembly, drawing, and report.

• After creating a project, you can perform the following actions:

○ Click EMX Assembly ▶ Project ▶ Finish to delete all suppressed plate
features. Use only when the mold base is ready for production.

○ Click EMX Assembly ▶ Project ▶ Archive to save bitmap images of the
current assembly and all reference models in an archive folder.

4.2 About Creating a Mold Base Project

1. The Project dialog box can be opened by clicking EMX ▶ Create New or in

manufacturing mode click EMX Manufacturing Mode ▶ Create New.
2. Under Data project specific information can be provided:

• Project Name—Name of the project assembly, associated drawings, and reports.
• Prefix—Awildcard character, used as prefix for all parts assembled to this project
• Postfix—Awildcard character, used as postfix for all parts assembled to this project
• User Name—Name of the user that created this project.
• Date—Date when project is created.
• Note—Add notes about the project

The default settings for almost all values and check buttons can be defined with this
EMX Options .

Project GUI Entry Corresponding EMX Option

Project Name DEFAULT_EMXNAME

Prefix DEFAULT_PREFIX

Postfix DEFAULT_POSTFIX

Unit ASSEMBLY_UNIT

Copy Drawings CREATE_ASM_DRAWING
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Copy Reports CREATE_ASM_REPORT

Date DATE_FORMAT

3. Under Options set the unit of measurement to mm or inch.

4. Under Templates, click to browse to the template directory. Select a previously
designed EMX assembly or accept the EMX default template. If you do not use the EMX
default template, then the files for the previously designed EMX assembly, are copied to
the current working directory and are then renamed with the new project name, prefix, and
suffix. If you use an EMX default template, select the Copy Drawings check box to
create a drawing and select the Copy Reports check box to create a report.

5. In the Project Parameter area, select Add local project parameters to create a set of
project-specific parameters for the new project. These parameters and their values will be
inherited to all components of the mold base assembly. To enter or change a parameter
value, double-click in the Default Value column for the parameter and type the value.
NOTE:
When you set the Creo Expert Moldbase Extension configuration option SAVE_LOCAL_
PARAM_IN_ASM to YES, the project parameters are stored with the assembly. If you do
not set the option to YES, they are written to an ASCII file in the current working
directory.

Project Parameters are defined in the EMX Options ▶ Project Parameters tab.
6. Click OK to create the new assembly and report or drawing in the working directory or

click Cancel.

NOTE:
If the configuration option NAME_SUBASM_COMP is enabled during the creation of a new
project and its value is different from “-”, a set of subassemblies for all different types of the
components will be created.

As an example the name of the automatic subassembly for cooling components is defined
with the configuration option NAME_SUBASM_COOL.

All cooling components are always assembled to this subassembly automatically

4.3 To Create the Mold Base Project
Download 04_To Create the Mold Base Project to start from with this chapter.

1. Erase all objects from session.

2. Select EMX ▶ Project ▶ Create New .
3. Enter Project Name TUTORIAL
4. Enter Prefix TUTOR
5. Enter an empty value as Postfix
6. Enter the User name and Date
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As a default the current date and current user is set.
7. Choose mm as the Unit system
8. The Template Directory is already predefined. Use the default empty_template

assembly.
9. Enable the Copy Drawingscheck button .In the background a drawing of the current

assembly is created. This drawing needs to be opened and initially saved.
10. Enter ABC as Default Value for Project Parameter CUSTOMER.
11. Enter ARTICLE123 as Default Value for Project Parameter ARTICLE.
12. Start the creation process with OK.

EMX copies the chosen assembly template from the Template Directory and renames
both the assembly and the according drawing to the new name TUTORIAL . At this point
there are two models in the assembly:

a. TUTOR_MACHINE represents the machine plates and holmets.
b. TUTOR_SKELETON provides all Datum Elements (Coordinate systems, Datum

planes, Axes and Datum Points) that will be used for placing the Moldbase
Components.
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5.1 About Subassemblies
You can use Creo Expert Moldbase Extension to create and delete subassemblies. Each
subassembly consists of a skeleton model with all the major datum features of the main
assembly. To modify the skeleton, the EMX main assembly must be the active assembly.

Separating the entire mold base assembly into smaller subassemblies has two advantages :

1. Two or more designers can work parallel on one design job.
2. Performance of Creo is much better when working with smaller subassemblies.

Good practice is saving a start assembly which already contains the desired set of
subassemblies.

When you place a new component in an existing subassembly, make sure to set up the
subassembly structure first. You cannot move a component to another subassembly when you
modify it. First delete the component, and then recreate it.

5.2 About Creating a New Subassembly
You can create a new subassembly in any existing assembly. A subassembly uses the same
unit of measure as the top assembly.

1. The Subassembly dialog box can be opened by clicking EMX Assembly ▶ Add
Subassemblies.

2. Select a subassembly from the list of EMX subassemblies, as the target assembly for the
new subassembly.

3. In the Name box, enter a name for the new subassembly, drawing, and report.
4. In the Project Prefix box, enter the project prefix.

NOTE:
If the EMX Option ENABLE_SUBASM_PREFIX is set to NO, the Project Prefix box is
unavailable.

5. In the Project Postfix box, enter the suffix for the project.
6. Assign any of the following functions to the subassembly:

• Assembly—Default, standard assembly
• Moving Half—Defines the subassembly as moving half.
• Fixed Half—Defines the subassembly as fixed half.

NOTE:
The correct subassembly is preselected for all components assembled from the Mold
Base Definition dialog box, depending on the selected side. Both subassemblies,
moving half and fixed half, must exist for the correct subassembly to be preselected.

• Ejector Pins—Defines the subassembly as the target assembly for all ejector pins.
• Split FH MH—Splits cavity assemblies which are assembled to this kind of

subassembly into moving half and fixed half.
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NOTE:
You can only split cavity assemblies with cavity assemblies created using the
Duplicate Cavity command. All three types of subassemblies Split FH MH, Cavity
Moving Half, and Cavity Fixed Half are required for the availability of the Split the
cavity assemblies into FH and MH check box, in the Cavity Layout dialog box.

• Cavity Moving Half—Target assembly for moving half parts from the split cavity
assembly. All parts classified as Insert MH in the Classify Dialog are added to this
subassembly.

• Cavity Fixed Half—Target assembly for fixed half parts from the split cavity
assembly. All parts classified as Insert FH in the Classify dialog box, are added to this
subassembly.

7. Select the Copy Drawings check box to create a drawing from the selected template.
8. Select the Copy Reports check box to create a report from the selected template.

9. Under Parameter, in the Parameter Name column notice the and symbols:

• —Indicates that the current parameter value is linked to the default value.

• —Indicates that the current parameter value is not linked to the default value.

To toggle the lock status, click or . You can change or enter a value in the Value

column only if Parameter Name is set to .
10. In the Value column, double click a value to make changes.
11. Click OK to create the subassembly and close the dialog box or click Cancel to exit

without saving changes.

5.3 About Deleting a Subassembly
Before you can delete a subassembly, you must delete its assembled components.

1. The Delete Subassembly dialog box can be opened by clicking EMX Assembly ▶

Structure ▶ Remove Subassemblies.
2. Select the subassembly to delete from the list on the left. The subassembly components

appear in the list on the right.

3. Click to delete the subassembly.

5.4 To Set up the Assembly Structure
Download 05_To Set up the Assembly Structure to start from with this chapter.

1. Click EMX Assembly ▶ Structure ▶ Add Subassemblies .
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The Subassembly dialog box appears.
2. In the Subassembly dialog box enter Name TUTOR_MH to create a subassembly that

represents the Moving Half.
3. In the Function pull-down selectMoving Half to indicate that this subassembly represents

the moving half.
4. Click OK to close the dialog.

EMX creates a new subassembly that has the same skeleton model included as the main
assembly.

5. Repeat the steps to create a subassembly TUTOR_FH (for fix half). Make sure to select
Fixed Half in Function pull-down

6. Repeat the steps to create a subassembly TUTOR_SHARED for the shared subassembly.
Make sure to select Assembly in Function pull-down. This indicates that this is a regular
EMX subassembly without specific function.
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6.1 About the Cavity Insert Assembly Layout
Use the Cavity Layout dialog box to load cavity insert assemblies into memory and to define
cavity insert assembly pattern.

1. The Cavity Layout dialog box can be opened by clicking EMX Assembly ▶
Cavity Layout

2. Select the Subassembly from the list of EMX subassemblies as the target assembly
for the cavity insert assemblies.
NOTE:
You can assemble a different cavity insert assembly to two or more different
subassemblies.

3. Click to load the cavity insert assembly. The loaded insert assembly is listed under
Insert Assemblies. The current name and the placement coordinate system appear.
NOTE:
The first insert assembly that is loaded into memory will be automatically assigned to the
first cavity pattern member.

4. By default the PLACEMENT coordinate system is listed as the assembly reference of the
loaded cavity insert assembly..

NOTE:
In case no PLACEMENT coordinate system is found, the first coordinate system in the
model tree is used as placement reference.
Double click on the CSYS entry of an insert assembly opens a new graphic window and
allows the manual selection of any other coordinate system in the model tree.

5. Select a Cavity Pattern type:

• Single Cavity Pattern

• Rectangle Cavity Pattern

• Round Cavity Pattern

• Star Cavity Pattern

Specify the pattern data as follows:

• Z angle and offset along x-axis and y-axis from the mold base origin
• Quantity along the X axis and Y axis from the mold base origin.
• Pattern size along the X axis and Y axis from the mold base origin.

NOTE:
The Pattern Size does not appear for Single type of cavity pattern.
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• Pattern diameter for circular pattern shapes.
6. Select the Automatically Recalculate check box to automatically recalculate the pattern

after changing parameters, or click to manually recalculate the pattern.

7. Double-click a cell to change a value in the pattern table. or indicates visibility
status.

8. To assemble the previously loaded cavity insert assembly models to the cavity pattern
coordinate system, double-click the cell in column Assembly from the table of all cavity
pattern members.

Select the cavity insert assembly from the option-menu by name.
9. Check the currently defined pattern type, size, and the assembled cavity Insert assembly

using Preview.

The Cavity Pattern and the assembled cavity insert assemblies appear in a 3D preview.

10. If the cavity insert assembly is assembled, you can click Pattern first Insert
Assembly to create a pattern of the first insert assembly on all pattern members.

11. Click Split the cavity assemblies into FH and MH to move parts classified as Insert MH
and Insert FH into the target assemblies. The target assembly must have Cavity Fixed
Half and Cavity Moving Half assigned.

12. Click OK to close the dialog box. All changes to the cavity pattern layout are applied
13. Click Cancel to discard the previewed changes. The previous cavity layout is restored.

6.2 To Set up the Cavity Insert Assembly Layout
Download 06_To Set up the Cavity Insert Assembly Layout to start from with this chapter.

1. Open the TUTORIAL.ASM assembly.

2. Click EMX Assembly ▶ Mold Base ▶ Cavity Layout . The Cavity Layout dialog
box opens.

3. Select TUTOR_SHARED from the Subassembly pull-down list.

4. Select the push button Load Insert Assemblies .

The Open File dialog box opens.

Select mfg_1.asm from the current working directory and leave dialog with Open.

The assembly is loaded to memory and listed in the table of insert assemblies.

The assembly is automatically assigned to the first pattern member
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5. Click Preview to update the insert assemblies in the graphic window.

6. Repeat Load Insert Assemblies for the second insert assembly mfg_2.asm and
load it to memory. mfg_2.asm will be listed in the table of insert assemblies as well.

7. Select the Rectangular Cavity Pattern Type .
8. Enter 2 for the Quantity in Y-direction.
9. Enter 50 for the Pattern Size in Y-direction.

10. Click to recalculate the pattern.

The cavity pattern table now shows both cavity instances.
11. Double-click the Assembly column in the second row of the pattern table. An Option

menu appears which lists all insert assemblies in memory.

Assign MFG_2 to the second pattern member.
12. Change the value of the A_Z -column to 180 in the first row.

13. Click Preview again to update the insert assemblies in the graphic window.
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14. Leave the dialog box with OK.
15. The Cavity pattern is now adjusted in the TUTOR_SKELETON.PRT model and contains

two coordinate systems CAVITY_1 and CAVITY_2.
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7.1 About the Moving and Fixed Half Views
By default two simplified representations for the fixed and the moving half of the mold base
are created. The names of these simplified representation can be defined with the EMX
Options NAME_MOVING_HALF and NAME_FIX_HALF.

Set the CREATE_LAYER_PER_PART and CREATE_GROUP_LAYER configuration options
to YES, to automatically create a layer for each model and a group layer for component
groups.

Most EMX components are automatically added to the correct simplified representation. Still
it can be necessaray to add components to a certain side manually.

1. To add a component to the moving half click EMX Assembly ▶ Views ▶ Add

component to ▶ Moving Half and select the desired component in the graphic
window.

2. To add a component to the fixed half click EMX Assembly ▶ Views ▶ Add component

to ▶ Fixed Half and select the desired component in the graphic window.
3. The simplified representation of the moving half can be activated with EMX Assembly ▶

Views ▶ Show ▶ Moving Half View
4. The simplified representation of the fixed half can be activated with EMX Assembly ▶

Views ▶ Show ▶ Fixed Half View

5. To switch back to the master view clickEMX Assembly ▶ Views ▶ Show ▶
Master View

6. Click EMX Assembly ▶ Views ▶ Toggle Wireframe Style to toggle componenty
like plates and insert parts to wire frame style.

In case it is prefered to work with layers instead of simplified reprenetations the EMX
Options USE_LAYER_FOR_SIDE_VIEWS can be activated.

NOTE:
Not do not change this option in the middle of on going projects There can either be
simplified representations or layers, but a mixture is not recommended.

7.2 To Assign Components to Moving and Fixed Half Views
Download 07_To Assign Components to Moving and Fixed Half Views to start from with this
chapter.

1. Open the TUTORIAL.ASM assembly.

2. Click EMX Assembly ▶ View ▶ Show ▶ Moving Half View
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Note that still all components are displayed. Components must be assigned to moving and
fixed half assembly manually.

3. Click EMX Assembly ▶ Views ▶ Add component to ▶ Moving Half and select
the components MOLD_VOL_ES_1, MOLD_VOL_ES_2 and two times MOLD_VOL_
SLIDER_1.

4. Click EMX Assembly ▶ Views ▶ Add component to ▶ Fixed Half and select the
components MOLD_VOL_IS_1 , MOLD_VOL_ES_2and MOLD_VOL_CORE_1 in both
cavity insert assemblies.

5. Click EMX Assembly ▶ Views ▶ Show ▶ Moving Half View
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6. Click EMX Assembly ▶ Views ▶ Show ▶ Fixed Half View

7. Click EMX Assembly ▶ Views ▶ Show ▶ Master View and select EMX

Assembly ▶ Views ▶ Toggle Wireframe Style
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Note that components like plates and insert parts are set to wire frame style.



Notes:
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To Assemble Side Interlocks
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8.1 About Defining a Main Axis Offset

1. Click EMX Assembly ▶ Mold Base ▶ Define Main Axis Offset to open the MAIN_
AXIS Position dialog box.

2. Enter values for Offset X and Offset Y.
3. Click OK to close the dialog box. The main axis in the skeleton and existing cutouts in

plates are be moved to the new position.

8.2 About Defining the Mold Base Assembly
A mold base is the set of plates and major components that hold the core/cavity insert.

1. The Mold Base Definition dialog box can be opened by clicking EMX Assembly ▶

Assembly Definition.
2. Define the following variables in the Mold Base Definition dialog box:

• The Unit of measurement is the same as the project assembly.
• Select a Supplier from the list of available mold base suppliers.
• Select the Size from the list of mold base sizes. Existing size-dependent component

dimensions are automatically updated when the size is changed.
3. Select or clear the Show Cavity check box to show or hide the cavity insert assembly

outline in the top and side view.

NOTE:
The outline of the cavity insert assembly, represented by a blue box, was calculated while

Classifying the Insert assembly and is displayed in the Side View. The
representation enables the user to set up the cavity layout and select the best fitting mold
base size.

4. Click an icon at the top of the dialog box to access other dialog boxes in which you can
define the component:

• —Opens the Load EMX Assembly dialog box.

• —Opens the Save EMX Assembly dialog box.

• —Clears all the components in the mold base
5. A dynamic view of the current mold base definition appears in the preview window.



8.2 About Defining the Mold Base Assembly

Page 58/448

6. Use the mouse wheel for zooming and middle-mouse button for panning in the view.
7. From the preview window you can view or position new components, and identify

components to modify or delete.
8. Right-click a component in the preview window to add guides and plates or to modify and

delete the component.

Double-click a component to open the Component dialog box.
9. A summary tree appears under the dynamic view. This summary tree contains all defined

components inside of the mold base definition.

The tree is divided into four nodes:

• Plates—All plates, including the type, the major dimensions and the material value
• Guides—All guides, including the ordering number and the number of assembled

instances. Additionally the color of the selected guide pattern appears
• Screws and Pins—All screws and pins, including the ordering number and the

number of assembled instances
• Equipment—All other equipment components, including the ordering number and the

number of assembled instances
10. Right-click a node to add guides or plates or to modify and delete the component. Double-

click a component to open the Component dialog box.
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11. Click to reset the zoom for side and top views.

12. Click and select a component to delete. The component is highlighted in red. Click
Yes at the prompt to delete it.

13. Select MH (moving half) or FH (fixed half) to toggle the view for the bottom
preview window.

14. To add a new plate, right-click an existing plate and select either Add Plate Above or
Add Plate Below. The new plate is placed either above or underneath between the
selected plate. You can also select the new plate and right-click outside the stack to place
the new plate on top of the Moving Half or Fixed Half stack. The Plate dialog box opens.

15. Alternatively, add a new plate, by selecting a plate type from the list under the summary
tree, and then select an existing plate. The new plate is placed between the selected plate
and the splitting plane. You can also select the new plate and click outside the stack to
place the new plate on top of the Moving Half or Fixed Half stack. The Plate dialog box
opens.

16. To add guide components right-click a plate and click Add Guide.
17. Add any of the following types of components to the assembly:

• Locating Ring MH

• Locating Ring FH

• Thermal Insulation Plate MH

• Thermal Insulation Plate FH

• Sprue Bushing

• Support Bushing

• Knockout

• Side Interlock

• Top Interlock

a. When you select a component, a dialog box opens for the selected component in
which you can define the component. Equipment components are automatically placed
in the correct location. Before you add a guide component, select the active main
guide pattern on the left side of the dialog box.
NOTE:
You can define up to three different patterns for the main guides.

b. Choose a guide component:

• Centering Sleeve

• Centered Guide Bush

• Guide Bush
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• Centered Leader Pin

• Leader Pin

• Ejector Guide Bush

• Ejector Leader Pin

• Puller Pin

• Puller Bolt
c. Choose additional components such as screws, stop system components, and so on to

add from the default component list under the top preview window:

• Clamp Screw MH

• Clamp Screw FH

• Ejector Screw MH

• Ejector Screw FH

• Rail Screw

• Rail Dowel Pin

• Return Pin/Back Pin

• Stop Disc MH

• Stop Disc FH

• Stop Pin MH

• Stop Pin MH

• Tubular Dowel

• Compression Spring
d. Define the new components in the dialog box. The components are automatically

placed.

18. Select Front or Top to toggle view type. The view changes from side to top view.
In the top view all major patterns are displayed as circles and rectangles.

19. The summary tree is updated and the list of patterns inside the mold base appears. The
major nodes are listed below:

• Guide Patterns—A list of all guides related patterns, including the number of active
pattern members, the visibility status, the width and length, and the number in the
width and length direction.

• Other Patterns—A list of all other patterns, including the number of active pattern
members, the visibility status, the width and length, and the number in the width and
length direction.
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20. To change pattern settings, either double-click a pattern inside the view or the summary
tree or right-click a pattern. The Pattern dialog box opens.

21. Select a guide pattern from the summary tree under the bottom preview window. There

are four main guide patterns and two ejector guide patterns ( or ) in the list. A
dialog box for the selected guide in which you can set pattern data, opens.

22. Select a screw or stop system pattern from the list under the bottom preview window. A
dialog box for the selected item opens. Define the pattern before placing a new
component:

• Clamp Screw MH

• Clamp Screw FH

• Ejector Screw MH

• Ejector Screw FH

• Rail Dowel Pin

• Rail Screw

• Return Pin/Back Pin

• Stop System MH

• Stop System FH

• Side Interlock

• Top Interlock
23. Click the list box next to the zoom tool to select the active main guide pattern. A new

guide component is added to the active pattern that appears in the bottom preview
window. Set the correct pattern before adding a new guide component.

24. Click to access the Machine dialog box.
25. Click Close to close the dialog box.

8.3 To Set up the Mold Base Size and Assemble Plates
Download 08_To Set up the Mold Base Size and Assemble Plates to start from with this
chapter.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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8.3.1 Recalculate Outline of Cavity Insert Assemblies considering new Cavity Layout
In case the cavity layout was modified. The Outline of the cavity insert assemblies need to be
recalculated in the mold base assembly context.

1. Click EMX Assembly ▶ Preparation ▶ Classifying to open the Classify dialog
box.

2. Make sure the check button Use the selected insert assembly size is enabled.
3. Click OK to leave the dialog box.

8.3.2 Select Supplier and Set Size

1. Click EMX Assembly ▶ Mold Base ▶ Assembly Definition .The Mold Base
Definition dialog box opens.

2. Choose meusburger as mold base Supplier.

3. Select Top to switch to the top view. The current mold base size is displayed as
rectangle to ensure that the selected mold base fits the cavity insert assemblies.

4. From the Size pull down select 446x396.

A message dialog box appears. As you have not defined any plates at this point you can
close the dialog wit YES. Generally, changing the mold base size is possible, but be aware
that this will influence your complete design.

8.4 About Defining a Plate
To add a new plate, right-click a plate and select Add Plate Above or Add Plate Below.
Alternatively, in the Mold Base Definition dialog box, add a new plate by selecting a plate
type from the plate list and then clicking a plate. The Plate dialog box opens.

1. Set the unit of measurement as mm or inch. The list of available suppliers is updated.
2. Select a supplier from the list. All available plates appear in the plate list. The selected

plate also appears in the preview window.
3. Select the assembly to add the plate from the list on the top right of the dialog box.
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4. Plate dimensions appear in the table next to the preview. Double-click the Value column
to perform the actions listed below:

• Edit the dimension value.

• Select a valid value from a list.

• Select a valid value from a list or enter a value.

• You cannot change disabled values.
NOTE:
If a Length,Width or Thickness value is entered that is not listed in the catalog, be
aware that the ordering number might change. Manual changes are indicated in the

summary tree with a warning icon .

Use the Stock Allowance dimension to reduce the thickness of a standard plate. This
results in the correct Order Number but allows machining of the ordered plate.

5. Enter a plate name in the Part Name box. To enter an alternate name, select the check
box. Both default names are defined in Part Names on the EMX Options dialog box.

6. Click a tab to preview all available features of the chosen plate type.
7. To set plate property options, select the BOM Data, Parameter, and Relation tabs.
8. Select the Copy Drawings check box on the Options tab to create a drawing from a

template.

NOTE:
To save the plate drawings automatically when the plate is assembled to the mold base, set
the Configuration Option SAVE_DRAWINGS to YES.

9. The dimensions of the active feature are displayed in the table. Double-click the Value or
Tolerances column to change the dimension value. You cannot change the dimension
name.

10. Select the Add to BOM check box to include the component in the Bill of Materials.
11. Click OK to close the dialog box and update the assembly with the new plate, or click

Cancel to close the dialog box, and return to the Mold Base Definition dialog box.
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8.4.1 Background Information
• The plate colors can be defined in EMX Options ▶ Technology.

• The plate-templates are located in components/%UNIT%/plates. The length, width
and thickness of plates can be added as parameter to the models when setting the
according configuration options:

○ PARAM_PLATE_LENGTH

○ PARAM_PLATE_WIDTH

○ PARAM_PLATE_THICKNESS

• If the configuration option RECALC_MASS_PROPS is set to YES, the center of gravity
will be calculated for the entire mold base assembly when the Mold Base Definition
dialog box is closed.

The position of the point CENTER_OF_GRAVITY in the skeleton model is then moved to
the correct position, so it can be used to drive the position for eyebolts. The default for
this option is set to NO as the calculation might take some time for large mold base
assemblies.

• For each component type extra layer names can be defined in EMX Options ▶ Part
Names. In case a component is assembled, layers or summarize layers will are created
and the new component will be put on the layer. Activate the configuration option
CREATE_GROUP_LAYER and CREATE_LAYERS_PER_PART if extended layer
functionality is required.

• Usually the tolerance mode for all dimensions of the template models is not modified
when assembling such a model. Most customers want to see all dimensions being
NOMINAL. In this case set the configuration option EMX_TOL_MODE.

8.5 To Assemble Plates
Download 09_To Assemble Plates to start from with this chapter.
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8.5.1 Add Plates

1. Select Front to switch to the side view.
2. Click below the splitting plane with right-mouse-button (RMB) and selected Add plate

below ▶ Cavity Plate.

The Plate dialog box opens.
3. Select TUTOR_MH from the Subassembly pull down in the top right corner to define the

target subassembly.
4. Set the Thickness (T) to 76.

While defining plate properties, this plate is displayed in the Mold Base Definition side
view in preview (using white color). This indicates that the model has not yet been
assembled in the Creo assembly.

5. Click OK in the Plate dialog box to assemble the plate.

EMX copies the template of the chosen plate, renames it to the given Part Name and
assembles it to the Creo assembly TUTOR_MH.

The plate color in the Mold Base Definition is set to the model color. This indicates the
plate exist as a real Creo model now.

6. Close the Mold Base Definition dialog box with Close.
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8.5.2 Save Plate Drawing
1. As the Copy Drawings check button in the Plate dialog box was activated, EMX has not

only created the plate part model, but also a drawing with the same name.

2. Open this drawing with EMX Assembly ▶ Documentation ▶ Open drawing of
selected model and click the plate TUTOR_CAV_PLATE_MH001.PRT in the graphics
window. The drawing opens.

3. Save the drawing and close this window

8.6 To Edit Plate Properties
Download 10_To Edit Plate Properties to start from with this chapter.

1. To modify the properties of a plate, double-click on the plate in the side view of Mold
Base Definition. The current targeted plate is highlighted in the side view and the
graphics windows

The Plate dialog box opens.
2. Switch the Plate Type to F055.
3. Change the Thickness to 66 .
4. Click the BOM Data sheet to check the BOM Information for this plate.
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The ordering number is updated immediately when you modify plate information

5. Apply the modifications to the plate with OK.
6. Repeat the above steps and reset the plate properties back to F050 with a thickness of 76

mm.
NOTE:
Alternatively, you can click on the plate with the right-mouse button and select Modify to edit
the plate properties. Additionally, all plates can be selected in the summary tree.

8.7 About Plate Features
In the Creo Expert Moldbase Extension plate templates a set of suppressed features is
predefined. By suppressing and resuming these features the software can build most of the
basic plate shapes. Relevant features are listed in the bottom area of the Plate dialog box.

The features and the according visibility status is defined for all plate-types in
components/%UNIT%/plates/%SUPPLIER%/udf/feature_data.txt.
Additionally, all dimension rules to drive these feature are defined in the feature data file
based on the supplier and the unit.

The visibility status can be:

• Visible: The feature is visible. In case the mold base size is changed and the default
value is defined as suppressed in the feature data, the feature will be suppressed

• Visible Locked: The feature is always visible. In case the mold base size is changed
the feature will still be visible even if the default value is defined as suppressed.

• Suppressed: The feature is suppressed. In case the mold base size is changed and
the default value is defined as visible in the feature data, the feature will be visible.

NOTE:
The visibility status can be modified manually. This is advanced functionality and not
recommended for standard plates from suppliers. Manual changes can result in models that
are different from the shipped supplier plates.
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NOTE:
Manual changes on the visibility status and the feature dimension are set back to default
values from the feature data.txt when changing the plate type or the mold base size.

For the pryslot feature Creo Expert Moldbase Extension offers a special configuration option
to suppress or resume them by default with SHOW_PRYSLOT set to NO or YES.

8.8 To Understand whether Cutouts in Plates are driven by Component
or Plate
Download 00_to_cut_or_not_to_cut to start from with this chapter.

8.8.1 Hide Clamping Screws Plate Feature in Plate
1. Load the assembly to_cut_or_not_to_cut.asm.
2. Enter theMold Base Definition dialog box with EMX Assembly ▶ Assembly Definition

.
3. RMB on the F10 plate in the side view.

4. Select the CLP_BORE_CB feature in the Plate dialog box to toggle its visibility from

to .

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial


The Mold Base Defintion

Page 69/448

5. Close the Plate dialog box with OK.Now the default cutout for the clamping screw is
gone from the clamping plate.
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8.8.2 Add Clamping Screws
1. Select Clamp Screw MH from the screw list.

The Diameter and Length in the Screw dialog box are set by the mold base data from the
size_346x346 plate file.
NOTE:
The Reference Distance is not set properly when adding default components in Mold
Base Definition.

2. Leave the Screw dialog box with OKAs NO counter bore in the F10 plate exist, an
additional bore is added to the clamping plate CUT_CLP_PLATE_MH000.PRT. This bore
is now driven by the screw cut out UDF, NOT by the plate size file.

On the other side the counter bores in the plate F50 and F60 already existed. This features
are driven by the plate size file.

Therefore NO additional cut outs are added to the F50 and F60 plates.
NOTE:
Be aware that this can cause different cut out results.
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The additional UDFs counter bore in the F10 plate is driven by the UDF’s dimensions from
the Screw dialog box.

The bores in F50 and F60 are driven by the feature dimensions in the Plate dialog box.

If you use P-Plates without any predefined cutouts and bores you can realized this by setting
the EMX Option USE_P_PLATE_STACK to YES. Then all cutouts are generated by screws,
leader pins individually.

8.8.3 Reset the Normal State
1. RMB on the F10 plate in the side view.

2. Select the CLP_BORE feature in the Plate dialog box to toggle its visibility from to

.
3. Close the Plate dialog box with OK.
4. RMB on the clamping screw MH in the Side View.
5. Assemble the screw again WITHOUT ...Counter Bore.
6. ... and the assemble the screw again WITH Counter Bore.Now all cutouts in all plates are

driven by the Plate size data only.

NOTE:
When adding components that create their cutout with cut quilts, you can avoid this cuts
to be added into standard parts like screws, leader pins with EMX Option CUT_PLATES_
ONLY set to YES.

8.9 Interlude: To Edit Plate Features
Download 11_Interlude: To Edit Plate Features to start from with this chapter.
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NOTE:
The visibility status can be modified manually. This is advanced functionality and not
recommended for standard plates from suppliers. Manual changes can result in models that
are different from the shipped supplier plates.

1. Click on the cavity plate in Summary Tree of the Mold Base Definition with right-mouse
button and click Modify to open the Plate dialog box.

2. Click the Options and select Speacial Shape and confirm the EMX Question dialog box
with Yes.

3. Select PRYSLOT from the feature list.

4. Select Suppress from the radio group. Special Shape is displayed in the summary
tree. This means that the plate does not conform to the standard.

5. Click OK.
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The feature will be suppressed in the plate model.

6. Double-click the cavity plate in Side View to open the Plate dialog box again.
7. Select PRYSLOT2 from the feature list.

8. Select Visible from the radio group and modify theW value to 20.
9. Close the dialog with OK.

The width is set to 20 mm.

8.10 To Assemble Rail Plates
Download 12_To Assemble Rail Plates to start from with this chapter.

1. Select Cavity Plate with right-mouse button in the list of plates in the Summary Tree.

2. Click Add plate below ▶ Rail from the right-mouse menu.

The Plate dialog box opens. The subassembly TUTOR_MH is already preselected as it is
designated as the moving half subassembly.

3. Select Thickness to 116.
4. Close the Plate dialog box with OK.

The model will be created.
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NOTE:
The rail width is set in the template, but some suppliers offer rails in two different sizes.
You will get the wider size, if you have selected the "s" type during mold base size
definition.

5. Select 396x396s from the Size pull down menu.

The mold base assembly will be regenerated with the new size and wide rails.
6. Answer the question Use this size and update all existing components” with YES.

The mold base assembly will be regenerated with the new size and wide rails.

8.11 Interlude: To Assemble Non-Standard Rails
Download 13_Interlude To Assemble Non-Standard Rails to start from with this chapter.

1. Select Cavity Plate with right-mouse button in the list of plates in the Summary Tree.

2. Click Add plate below ▶ Rail from the right-mouse menu.
3. Select P plate from the Type pull-down list.

NOTE:
Non-Standard plates should always be a P plate.

4. Activate the Special Shape check button in case you are working with non-standard
plates
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5. Set the Length to 390.
6. Set theWidth to 420.
7. Set the Thickness to 120.
8. Select the MAIN_CUT from the plate features pull-down list an setW1 andW2 to 100.

9. Close the Plate dialog box with OK.

The models will be regenerated.

The Special Shape is displayed in the summary tree.

8.12 Interlude: To Assemble Rail in One Model
Download 14_Interlude To Assemble Rail in One Models to start from with this chapter.

1. Select Cavity Plate with right-mouse button in the list of plates in the Summary Tree.

2. Click Add plate below ▶ Rail from the right-mouse menu.
3. Select P plate from the Type pull-down list.
4. Select a Thickness of 116.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial


8.13 About Mold Base Patterns

Page 76/448

5. Activate the Special Shape check button in case you are working with non-standard
plates

6. Activate the Both rails in one model check button.

NOTE:
Both rails in one model is only enabled for P—Plates to avoid invalid order numbers

7. Select the MAIN_CUT from the plate features pull-down list.

SetW1 andW2 to 130.

Set L1 and L2 to 160.

8. Close the Plate dialog box with OK.

The model will be regenerated.

8.13 About Mold Base Patterns
The Creo Expert Moldbase Extension mold base assembly is controlled by patterns which are
defined inside the skeleton model.
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These patterns are manipulated by the Mold Base Definition dialog box. Usually the number
and dimensions of the patterns are defined based on the supplier mold base data. Still it can be
useful to manipulate these values, e.g. in case additional guide or screw instances are
necessary.

NOTE:
Be aware that modifying the standard patterns value can lead to geometry which does not fit
the supplier standard.

The skeleton patterns define the position of the cut outs, but also the position of components
assembled by the Mold Base Definition dialog box.

NOTE:
Even if components are NOT created from the Mold Base Definition dialog box it makes
sense to use the datums of these patterns as placement reference.

In the skeleton model the following guide patterns exists:

• MAIN_GUIDE1 : Position of all main guide components and related cut outs on the first
pattern scheme. Displayed in the top view and summary tree with this icon or color .

• MAIN_GUIDE2 : Position of all main guide components and related cut outs on the
second pattern scheme. Displayed in the top view and summary tree with this icon or
color .

• MAIN_GUIDE3 : Position of all main guide components and related cut outs on the third
pattern scheme. Displayed in the top view and summary tree with this icon or color .

• MAIN_GUIDE4 : Position of all main guide components and related cut outs on the 4th
pattern scheme. Displayed in the top view and summary tree with this icon or color .

• EJP_GUIDE : Position of guide components on the ejector package and related cut outs
on the moving half.

• EJP_GUIDE_IS: Position of guide components on the ejector package and related cut
outs on the fixed half.

Additionally, these other patterns exists:

• CLP_BORE_ES : Position of main clamping screws and related cut outs on the moving
half.

• CLP_BORE_IS : Position of main clamping screws and related cut outs on the fixed half.
• EJP_BORE : Position of ejector package clamping screws and related cut outs on the

moving half.
• EJP_BORE_IS : Position of ejector package clamping screws and related cut outs on the

fixed half.
• STOP_BORE_IS : Position of stop system and the related cut outs on the fixed half.
• RAIL_SCREW : Position of rail screw and the related cut outs.
• RAIL_PIN : Position of rail dowel pin and the related cut outs.
• RETURN_PIN : Position of return pins and the related cut outs on the moving half.
• STOP_BORE : Position of stop system and the related cut outs on the moving half
• STOP_BORE_IS : Position of stop system and the related cut outs on the fixed half.
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• INTERLOCK : Coordinate system pattern for the position of the side interlock assemblies.
• TOPLOCK : Coordinate system pattern for the position of the top interlock assemblies.

Patterns are displayed and modified using the top view of the assembly in the Mold Base
Definitiondialog box

1. Click Top to switch to the assembly top view.

The summary tree changes its content. All patterns and their numbers and major
dimension are listed within the tree

2. Use MH and FH to view the mold base assembly patterns either from the bottom
or from top.

3. Double-click the pattern either in the top view or from the pattern list. The relevant
pattern dialog box opens.

4. Enter new values for Quantity and Pattern Size along the X-axis and Y-axis from the
mold base origin.

5. To manually recalculate the pattern, click

NOTE:
Select the Automatically Recalculate check box to automatically recalculate the pattern
after the parameters are edited. .

6. Double-click a cell to change a value in the pattern table. or indicates visibility
status.

7. For Main Guide 1 pattern only: Use the Option to automatically create a guide
component setup which has 1 instance on the first main guide component pattern and 3
instance on the second main guide component. This setup is used to assemble guide
components with different inner diameters to avoid incorrectly rotated assembly of the
mold base.

8. Click OK to close the dialog box, to update the assembly and to return to the Mold Base
Definition dialog box, or click Cancel to close the dialog box, and to return to the Mold
Base Definition dialog box.
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8.14 To Edit Mold Base Patterns
Download 15_To Edit Mold Base Patterns to start from with this chapter.

1. Click Top to switch to the top view of the mold base.

2. Select the Main Guide 1 pattern.

• Either by double-click inside the top view

• Or by double-click on the listed pattern inside the summary tree.

The Pattern dialog box appears.

If a plate supplier provides default dimensions for a certain pattern in its catalog, this
values will be used as default in the entries Quantity and Pattern Size.

NOTE:
Be careful with changing pattern dimensions provided by suppliers. For guide patterns its
very unusual to change. The following steps are just described as an example.
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3. Click the visibility icon symbol in the first column. The icon switches to which
indicates that this pattern instance should be removed from the axis-pattern.

NOTE:
Leader pins, bushings etc. assembled on this axis pattern will also appear only on the
visible members of this pattern.

4. Close the dialog with OK.

The modification will be applied to the mold base assembly model.

5. Reopen the Main Guide 1 pattern dialog box
6. Modify the Y entry for Pattern Size to 200.

7. Recalculate the pattern members with the button.

The preview in Mold Base Definition shows the new position automatically without
regeneration of the 3D model.
NOTE:
Hidden members will become visible again when recalculate the pattern!

8. Close the dialog with OK.

The modification will be applied to the mold base assembly model.
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9. Reopen the Main Guide 1 pattern dialog box
10. Reset the Y entry for Pattern Size to 324.

11. Click again.
12. Close the dialog with OK.

The pattern is set back to the default values.
NOTE:
When changing the mold base Size, all default patterns are reset to the values from
catalog. Only patterns that are not explicitly defined by the plate supplier (i.e. ejector
guide patterns for Meusburger) will remain to the values you have specified.

8.14.1 Using 1+3 patterns
A common technique to avoid assembling mistakes of the mold base stack is to assemble
leader pins and bushings with different inner diameter at one pattern instance.

1. Reopen the Main Guide 1 pattern dialog box

2. Click .

Only the pattern leader of Main Guide 1 remains visible. In addition the pattern Main
Guide 2 is added with same Quantity and Pattern Size. In Main Guide 2 only the first
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position is suppressed. The different patterns are represented in Mold Base Definition by
different colors.

3. Close the Main Guide 1 dialog box with OK.

The suppressed pattern MAIN_GUIDE2 is resumed in the skeleton model, position and
amount of axis match to the definition you have made.

8.15 To Finish the Plate Stack
Download 16_To Finish the Plate Stack to start from with this chapter.

Add a cavity plate to the fixed half.

1. Open the Mold Base Definition dialog box.

2. Click with right-mouse button within the fixed half of the side view and click Add

plate above ▶ Cavity Plate

The Plate dialog box opens.
3. Select subassembly TUTOR_FH.

NOTE:
The subassembly designated with the function Fixed Half is automatically preselected.

4. Select type F50.
5. Select Thickness 86.
6. Close the Plate dialog box with OK.
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The cavity plate is assembled.

NOTE:
The cavity insert interferes with the cavity plates as the required cutout is still missing.

Add a clamping plate to the fixed half.

1. Click with right-mouse button on the cavity plate within the fixed half of the side view

and click Add plate above ▶ Clamping Plate
2. Select TUTOR_FH as Subassembly.
3. Click OK to leave the Plate dialog box.
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Add a clamping plate to the moving half.

1. Click with right-mouse button on the rail within the moving half of the side view and

click Add plate below ▶ Clamping Plate
2. Select TUTOR_MH as Subassembly.

NOTE:
The subassembly designated with the function Moving Half is automatically preselected.

3. Click OK to leave the Plate dialog box.

Add a core pin retainer plate.

1. Click with right-mouse button on the clamping plate within the moving half of the side

view and click Add plate above ▶ Corepin Retainer Plate
2. Select TUTOR_MH as Subassembly.
3. Set Reference Distance to 4 mm to leave some space for the stop system.
4. Close the dialog with OK.
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Add an ejector base plate.

1. Click with right-mouse button on the core pin retainer plate within the moving half of the

side view and click Add plate above ▶ Ejector Base Plate
2. Select TUTOR_MH as Subassembly.
3. Set Reference Distance to 0 mm.
4. Close the dialog with OK.

Add an ejector retainer plate.

1. Click with right-mouse button on the ejector base plate within the moving half of the side

view and click Add plate above ▶ Ejector Retainer Plate
2. Select the Ejector Base Plate as placement reference in the Side View.
3. Select TUTOR_MH as Subassembly

Close the dialog with OK.
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NOTE:
In case a second ejector package is needed repeat the assembly process for another ejector
base plate and another ejector retainer plate. For the second ejector base plate selected the
first ejector retainer plate as a reference in the side view of the Mold Base Definition
dialog box.

In some design cases it might be necessary to add ejector packages to the fix half.
Additional two ejector packages are supported in the Mold Base Definition dialog box.

8.16 About Assembling and Disassembling Components
You can assemble and disassemble all components except those that create cuts in a Cut by
quilt feature.

1. To assemble or disassemble a component, click EMX ▶ Component Status. The
Component Status dialog box opens.

2. Select or clear the part check boxes. This feature is not available for function units (slide
or lift assemblies) or for library components.

3. Click or to select or clear all available check boxes.
4. Click OK to update the assembly and close the dialog box or click Cancel to exit the

operation.

8.17 To Assemble Main Guide Components
Download 17_To Assemble Main Guide Components to start from with this chapter.
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8.17.1 Add Centered Guide Bush to first Guide Pattern Scheme
Before adding a guide component, specify the guide-pattern scheme to be used as assembly
reference.

1. Open the Mold Base Definition dialog box.

2. Select 1 from the Pattern Scheme pull down in the right bottom corner of the dialog.

3. Click with the right-mouse button on the moving half cavity plate in the summary tree and

click Add guide ▶ Centered Guide Bush .

The Guides dialog box appears.
NOTE:
The nominal dimensions DM1, DM2, LG and OFFSET are set automatically using the
Guide information of the plate cutouts and the thickness of the chosen plate.

4. Make sure the TUTOR_MH subassembly is selected before you continue.
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NOTE:
As the counter bore for this centered guide bush already exist in the cavity plate, the
cutouts are not created and the dimensions in cutout section of the Component dialog box
in the bottom part of the dialog box are not applied to the cutouts. The dimensions are
only used, in case a guide bush is placed on in a P-plate without predefined cuts. Then the
counter bore displayed with its dimensions D2, T2 and D3 would be added. See chapter
“To Understand Whether Cutouts in Plates are Driven by Component or Plate on page 68”
for details.

5. Close the dialog box with OK.

The guide bush is displayed in the same color like the pattern in the top view. So you can
see which components are related to which pattern position.

8.17.2 Set the Assembly Status of Components
There is no solid guide component to the assembly TUTOR_FHassembled yet.

1. Close the Mold Base Definition dialog box

2. Click EMX Assembly ▶ Mold Base ▶ Component Status

3. Check all component types with .

4. Close the dialog box with OK.
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From now on all solid component model will be assembled directly.

5. Click EMX Assembly ▶ View ▶ Wireframe Style

The centered guide bush component is now assembled.

8.17.3 Add Additional Centered Guide Bushes to second Guide Pattern Scheme
Add additional bushes with a different inner diameter on the second axis pattern.

1. Open the Mold Base Definition dialog box.

2. Select 2 from the Pattern Scheme pull down in the right bottom corner of the dialog.
3. Click again with the right-mouse button on the moving half cavity plate in the summary

tree and click Add guide ▶ Centered Guide Bush.

The Guide dialog box opens.

The second inner diameter is set to 32 mm for DM2 automatically.
4. Click OK to assemble the guide components.
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The bush on the second pattern is displayed beside the bush on first pattern in the side
view. The color is equals to the color of the second pattern.

Three additional guide bushes are assembled to in the mold.

8.17.4 Add Leader Pins

1. Select 1 from the Pattern Scheme pull down in the right bottom corner of the dialog.
2. Click with the right-mouse button on the fixed half cavity plate in the summary tree and

click Add guide ▶ Centered Leader Pin.

The Guide dialog box opens.

TUTOR_FH is already preselected as the target subassembly.

The inner diameter DM2 must be set to 30 mm to fit to the according bush. this is already
preselected.

3. Select 95 mm for LG2
4. Click OK to leave the Guides dialog box.
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5. Select 2 from the Pattern Scheme pull down in the right bottom corner of the dialog.
6. Select the Cavity Plate MH with LMB in the Side View as placement reference.

Make sure TUTOR_MH is the target subassembly. DM2 must be 32 mm now.
7. Click with the right-mouse button on the fixed half cavity plate in the summary tree and

click Add guide ▶ Centered Leader Pin.

The Guide dialog box opens.

TUTOR_FH is already preselected as the target subassembly.

The inner diameter DM2 must be set to 32 mm to fit to the according bush. This is already
preselected.

8. Select 95 mm for LG2
9. Click OK to leave the Guide dialog box.
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8.17.5 Add Centering Sleeves

1. Select 1 from the Pattern Scheme pull down in the right bottom corner of the dialog.
2. Click with the right-mouse button on the moving half clamping plate in the summary tree

and click Add guide ▶ Centering sleeve.

The Guide dialog box opens.

TUTOR_MH is already preselected as the target subassembly.
3. Set the LG value to 120.
4. Click OK to leave the Guide dialog box.

5. Select 2 from the Pattern Scheme pull down in the right bottom corner of the dialog.
6. Click with the right-mouse button on the moving half clamping plate in the summary tree

and click Add guide ▶ Centering sleeve.

The Guide dialog box opens.

TUTOR_MH is already preselected as the target subassembly.
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7. Set the LG value to 120.
8. Click OK to leave the Guide dialog box.

8.18 To Assemble Clamping Screws
Download 18_To Assemble Clamping Screws to start from with this chapter.

8.18.1 Add Clamping Screws FH
To fixture all plate clamping have to be added to the mold.

1. Open the Mold Base Definition dialog box.
2. Select Clamp Screw FH from the Screw pull-down to add the clamping screws to the

fixed half.

The Screw dialog box appears.

Screw dimensions like DM1 and LG1 are automatically predefined based on the catalog
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defaults from the supplier catalog. The OFFSET displayed is the default counter bore
depth in the clamping plate.

3. Click OK to leave the Screw dialog box.

8.18.2 Add Clamping Screws MH
1. Select Clamp Screw MH from the Screw pull-down to repeat the same steps for the

moving half.

The Screw dialog box appears with predefined settings for the screw type, diameter and
length.

2. Click OK to leave the Screw dialog box.
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8.18.3 Add Ejector Clamping Screws
The ejector plate package needs to be fixed as well

1. Select Ejector Screw MH from the Screw pull-down to the ejector plates.

The Screw dialog box appears.

TUTOR_MH is preselected as the target subassembly.
2. Click OK to leave the Screw dialog box.

All Clamping Screws are now assembled.

8.19 To Assemble Insulation Plates
Download 19_To Assemble Insulation Plates to start from with this chapter.

8.19.1 Add Insulation Plates to the Moving Half
In some case it is necessary to add thermal insulation plates to the mold base. This avoids
thermal interaction between the molding machine and the mold base assembly.

1. Select Thermal Insulation Plate MH in the Equipment pull-down.

The Thermal Insulation Plate dialog box appears.

The size of the according clamping plate was measured and the proper insulation plate
size is preselected.

TUTOR_MH is preselected as the target subassembly.
2. Enable the option Include leader pin cuts.
3. Click OK to leave the Thermal Insulation Plate dialog box.
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NOTE:
The option Include leader pin cuts handles the visibility of additional bores following
the dims of the clamping plate cutouts.

8.19.2 Add Insulation Plates to the Fix Half
Repeat the same steps for the fixed half.

1. Click Thermal Insulation Plate FH from the Equipment pull-down list.

The Thermal Insulation Plate dialog box appears.

TUTOR_FH is preselected as the target subassembly.
Make sure TUTOR_FH is the target Subassembly.

2. Enable the option Include leader pin cuts.
3. Click OK to leave the Thermal Insulation Plate dialog box.

8.20 To Modify Clamping Plates and Adjust Components
Download 20_To Modify Clamping Plates and Adjust Component to start from with this
chapter.
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8.20.1 Modify Clamping Plates
If a invalid plate was assembled to the mold base it’s type can easily be changed.

1. Open the Mold Base Definition dialog box.
2. Click with right-mouse button on the fixed half clamping plate in the side view and click

Modify.

The Plate dialog box appears.
3. Switch the Type to F45.
4. Select a Thickness of 36 mm.
5. Click OK to leave the dialog box.

6. Repeat the same procedure for the Clamping Plate MH

8.20.2 Adjust Clamping Screws due to new Plate Thickness
Due to new the new thickness of the clamping plates the screw need to be adapted manually.

1. Double-click on the Clamping Screw FH either in the side view or in the summary tree.
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The Screw dialog box opens.
2. Set the length LG1 to 40 mm.
3. Close the dialog box with OK.
Repeat the same steps for the moving half clamping screw.

1. Double-click on the Clamping Screw MH either in the side view or in the summary tree.

The Screw dialog box opens.
2. Set the length LG1 to 160 mm.
3. Close the dialog box with OK.

8.20.3 Adjust the Insulation Plate Size
The insulation plates need to be changed as well.

1. Double-click on the Thermal Insulation Plate FH either in the side view or the summary
tree

The Thermal Insulation Plate dialog box appears.
2. Change the INSULATION_ES_WIDTH value to 396 that it fits to the clamping plate.
3. Close the dialog box with OK.
4. Repeat the same procedure for the Thermal Insulation Plate MH.

NOTE:
By default changes to the related components need to be done manually. Still the are
configuration options available which can automate the update procedure. See chapter
About Modifying the Mold Base Size on page 334 as a reference.

8.21 To Assemble Ejector Guide Bushings and Pins
Download 21_To Assemble Ejector Guide Bushings and Pins to start from with this chapter.
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8.21.1 Set up the Ejector Guide Pattern
1. Open the Mold Base Definition dialog box.

2. Click Top to switch to the top view.
3. Double–click the Ejector Guide MH either in the top view or in the summary tree.

The Ejector Guide MH dialog box opens.
4. Enter Quantity 2 in both X direction.
5. Enter Quantity 1 in both Y direction.
6. Enter a value of 280 in X direction.

7. Click Recalculate to update the instances.

8. Close the Ejector Guide MH dialog box with OK.

8.21.2 Add Ejector Guide Bushings

1. Click Front to switch to the side view.
2. Click with right-mouse button on the Ejector Base Plate either in the side view or in the

summary tree. Click Add guide ▶ Ejector Guide Bush.

The Guides dialog box opens.

The TUTOR_MH subassembly is already preselected .
3. Set the DM2 value to 24.
4. Set the LG1 value to 22.
5. Set the LG2 value to 17.

NOTE:
In the summary tree all plate thicknesses are shown. This helps you to choose the right
sizes for your components.

6. Make sure that the Option Toggle Direction is enabled.
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This option specifies wether the bush shoulder is located in the ejector base plate or the
ejector retainer plate.

7. Close the Guides dialog box with OK and answer the message box with OK.

The ejector guide bushes are assembled to the mold base assembly.

8. Close the Mold Base Definition with Close.

8.21.3 Remove Cutouts from Ejector Core Pin
1. Open the part TUTOR_EJFIX_PLATE_MH_001.PRT
2. Delete the group GUIDE_STRAIGHT_HOLE

NOTE:
All cutout UDFs created with Creo Expert Moldbase Extension can be deleted with
default Creo Parametric functionality if required.
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8.21.4 Add Ejector Guide Bush with Circlip to the Core pin Plate
1. Open the TUTOR_MH subassembly.

2. Select EMX Components ▶ Components ▶ Guide Component.

The Guides dialog box opens.
3. Select TUTOR_MH as target subassembly from the subassembly pull down list.
4. Select E1110_ from the types pull down list.
5. Set the DM1 value to 30.
6. Set the DM2 value to 24.
7. Set the LG value to 22.
8. As the first assembly reference (1) Axis|Point select the datum axis EJP_GUIDE from

the pattern inside the TUTOR_SKELETON.PRTModel.
9. As the second assembly reference (2) Surface select the bottom side of the core pin plate.

10. Enable the option One Plate.

A different UDF Images appears in the cut out section. Circlip and shoulder cutouts are
added to the same plate.

11. Switch to the Options tab and check the optionPattern for all instances to create a guide
component for each axis inside the pattern.

12. Close the Guide dialog box with OK.
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The guide bushed and the according cutouts for the core pin plate are assembled to the
moving half assembly.

13. Close the TUTOR_MH.ASM and switch back to the main assembly.

NOTE:
When placing the combination of leader pins and guide bushes, you must always place the
bush first. If you start with the leader pins, this would create the smaller cutouts. Then the
required bush cutouts would miss as the plates to be cut can not be identified.

8.21.5 Add Ejector guide Pins
1. Open the Mold Base Definition dialog box.
2. Click with right-mouse button on the Clamping Plate MH either in the side view or in the

summary tree. Click Add guide ▶ Ejector Leader Pin.

The Guides dialog box shows up.

The TUTOR_MH subassembly is already preselected .
3. Set the DM1 value to 24.
4. Set the LG value to 160.
5. Close the Guide dialog box with OK and answer message box with OK.
6. Close the Mold Base Definition with Close.
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The leader pins are assembly to the mold base.

To fix the leader pins, circlips can be used. The image bellow shows a design example.

8.22 To Assemble the Return Pin / Back Pin
Download 22_To Assemble the Return Pin Back Pin to start from with this chapter.
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8.22.1 Define the Return Pin / Back Pin Pattern
1. Open Mold Base Definition dialog box.

2. Click Top to switch to the top view.
3. Double-click on Return Pin/Back Pin in the summary tree.

The Return Pin/Back Pin pattern dialog box opens.

For supplier meusburger no default pattern information is defined in the catalog.
4. Set X and Y Quantity to 2.
5. Enter Pattern Size 358 and 180.

6. Click to update the number of instances.
7. Click OK to close the pattern dialog.

8.22.2 Assemble the Return Pin / Back Pin

1. Click Front to switch to the side view.
2. Select Return Pin / Back Pin from the Screw pull-down.

The Ejector Pin dialog box appears.

TUTOR_MH is preselected as target subassembly
3. Select a cylindrical ejector pin of the Type E1710
4. Set the DM1 value to 12

References and the length are preselected automatically. The measured offset REF1 is the
distance between the splitting plane and the ejector retainer plate.

5. Leave the dialog box with OK.
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The return pins / back pins are assembled to the mold.

8.23 To Assemble Side Interlocks
Download 23_To Assemble Side Interlocks to start from with this chapter.

8.23.1 Modify the Side Interlock Pattern

1. Open Mold Base Definition dialog

2. Click Top to switch to the top view.
3. Double-click on Side Interlock in the summary tree.

The Side Interlock pattern dialog box opens.

The Pattern size values in the Side interlock dialog box are set to the current mold base
size by default.

4. Enter Quantity to 2 in both X- and Y-direction.

5. Select to update the number of instances.
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6. Check the placement of the Side Interlocks in the Top View of theMold Base Definition
dialog box.

7. Click OK to close the dialog and regenerate the pattern in the skeleton model.

8.23.2 Define the Side Interlock Properties
1. Select Side Interlock from the Equipment pull-down.

The Side Interlock dialog box opens.
2. Select the main assembly TUTOR_SHARED as target subassembly
3. Select hasco from the supplier pull down list.
4. Select Z07_17 from the types pull down list.
5. Select a value of 46 mm for B_.
6. Do not change any other default settings in the Side Interlock dialog box.

NOTE:
Side interlock components create their cutouts using a ‘Cut by Surface’ feature. In this
case just one Overview image is displayed in the UDF area, the quilt cut has no further
dimensions.
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7. Click OK to close the Side Interlock dialog box.
8. Close the Mold Base Definition with Close.

8.23.3 Assemble Predefined Screws in Side Interlock Assembly
For the Hasco Z07/17 side interlock assembly screws are already predefined.

1. Click EMX Components ▶ Component Handling ▶ Assemble predefined
components.

The Selection dialog appears.
2. Select the subassembly TUTOR_SHARED.ASM.

All predefined components within this assembly are assembled.

NOTE:
The predefined components are search recursively. The screws are assembled to the next
top subassembly which is found in the model tree.
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3. Leave the selection dialog with middle-mouse button.
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9
The Cavity Insert Assembly Cutouts

About Creating the Cavity Insert Assembly Cut-Outs
To Create the Cavity Insert Assembly Cut-Out
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9.1 About Creating the Cavity Insert Assembly Cut-Outs
Use the Cavity Cutout dialog box to define cavity plate cutouts.

1. The Cavity Cutouts dialog box can be opened opened by clicking EMX Assembly ▶

Cavity Cutouts.

The insert assembly outline dimensions automatically appear in the Cavity Size boxes and
preview window.

The preview orientation is the same as that in the Mold Base Definition dialog box
preview. Correct initial data appears only if the cavity insert assembly was assembled to
the cavity layout pattern. When the values are changed, the old values continue to appear
until the insert assembly outline is remeasured in the Classify dialog box.

In the top area the Cavity Size (outline of the insert assembly) is shown. The size (+,-X;
+,-Y;+,-Z ) can be edited here if the outline does not fit your requirements.

2. Select cutout definitions:

• No cutout — Removes existing cavity insert cuts.

• One rectangular cavity cutout — Enter values for the x- or y- offset, radii or
corner mouse ears, or both.

• Counterbore — One cutout is created for each cavity insert assembly
individuall

• Rectangular cutout pattern — One cutout is created for each cavity insert
assembly individually.

NOTE:
A rectangular cutout can have radii or corner mouse ears.

• Workpiece outline cutout — Creates a solid surface copy in all workpiece
components. The quilts are used to create Cut by Quilt features in models that
interfere with the quilts.

3. Click Preview to see the model in 3D so you can decide whether or not to keep the
changes you made.

4. Click OK to apply changes to the model or Cancel to restore the previous cutout shape.
The dialog box closes.

9.2 To Create the Cavity Insert Assembly Cut-Out
Download 24_To Create the Cavity Insert Assembly Cut-Out to start from with this chapter.
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1. Click EMX Assembly ▶ Mold Base ▶ Cavity Cutouts.

The Cavity Cutout dialog box opens.

2. Select the cut-out type Single rectangular .
3. Set Cut Radius to 13 mm.

4. Click Preview to update the cutouts in the graphics window.
5. Click OK.

The cutouts are added to both cavity plates.

6. The Cavity plates and the insert parts still interfere:

Open MOLD_VOL_ES.PRT and MOLD_VOL_IS.PRT.
7. Add round features of 13 mm to all the corners of the insert parts.
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The inserts assembly do no interfere with the cavity plates
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Notes:
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10.1 About Component Operations
There are five default operations for all component types:

• Define a component—From the EMX Components tab in the Components group, select
one of the components as shown in the list below. A dialog box for the selected
component opens.

○ Screw

○ Dowel Pin

○ Guide Component

○ Support Pillar

○ Stop disc

○ Stop pin

○ Equipment

○ Slider

○ Lifter

○ Latch Lock

The component definition dialog box opens. Define the component properties, and click
OK to close the dialog box. A reference group is created for the new component where
component information is stored as a parameter of this reference group. All cutouts and
the component itself are assembled as children of this reference group.

• Modify a component —Click EMX Components ▶ Modify or right-click the

component in the graphics window or Model Tree and select Modify. Select an
existing reference group. A component definition dialog box opens. Modify dimensions in
the dialog box or in the graphics window.

• Delete a component —Click EMX Components and then in the Component Handling

group, click Remove, or right-click the component in graphics window or Model Tree

and select Remove. Click OK to delete the reference group including the component
dependent geometry.
NOTE:
All other related components are also deleted.
NOTE:
When deleting a component, you can force EMX also to delete the model files from the
current working directory.

Set the configuration option DELETE_FILES_AFTER_DELETE to YES.

Its even possible to remove the files when simply disassemble the component in
Component Status dialog box with DELETE_FILES_AFTER_DISASSEMBLE.

Use these options with care.
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NOTE:
When deleting a component, all referring cut-outs will be removed without any warning.
To highlight them before deleting them, set configuration optionPRE_HIGHLIGHT_
BEFORE_DELETE to YES.

• Reassemble an existing component with new references—Click EMX Components and

then in the Component Handling group click Assemble again, or right-click the

component in the graphics window or Model tree and select Assemble again. A
dialog box in which you can define the component opens. Select this component type in
the Component Status dialog box. Select new placement references to place the
component and create the cutouts.

• Assemble an existing component as a copy with new references—Click EMX

Components and then in the Component Handling group click Assemble as a

copy or right-click the component in the Model Tree and select Assemble as a copy
to create a copy of the existing component. The component definition dialog box opens.
The settings of the existing component are displayed, but the component has a new unique
ID. Select new placement references. A copy of the component is placed with new
references and cutouts.

NOTE:
Fast placement of additional cooling components is possible if the configuration option
AUTO_REASSEMBLE is set to YES.

After assembling an initial component the reference will be prompted instantly for the second
instance in the message area.

After selecting the appropriate reference the next on will be prompted.

Continue selecting references to place further instances of t a component.

Stop the loop by Clicking Cancel in the Selection dialog box or by using the middle-mouse
button.

With this option multiple components of the same type can be created quickly in a row.

NOTE:
If this loop function should also be available for other type of components, set also the
configuration option AUTO_REASSEMBLE_ALL_TYPES.

10.2 About Assembling Predefined Components

To assemble predefined EMX components, click EMX Components ▶ Assemble
predefined components. Select an assembly or part that has reference groups with
predefined components. The component information is read from the reference group and the
assembly is assembled and cut.

You can predefine any component by selecting the Predefine Component check box during
its definition.
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10.3 About Redefining Placement Point References

1. Click EMX Components ▶ Component Handling ▶ Redefine point reference.
2. Click any EMX reference point. Creo Expert Moldbase Extension opens the regular

redefine dialog box for the component corresponding to the selected point.
3. Make modifications to the component and click OK to apply them. All components and

cutouts placed on the selected point are updated.
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About Components

11.1 About Component Options
From the dialog box in which you confine a component, select or clear the following check
boxes when you place a component:

• Pattern for all models—Adds the new component to each instance of the owner of the
first placement reference.

• Pattern for all instances—Places the new component on each instance of a reference
pattern of the first placement reference.

• First Cut In Face Owner— The cut out UDF defined on first position will be added to the
owner model of the first surface selected as placement reference.

• No Cutout—No cuts are generated.
• No Component—The component is not assembled.
• Predefine Component—The component can be predefined in part mode, to be assembled

later in the main assembly.
NOTE:
When the Predefine Component check box is selected, component data is saved with the

reference group. Click EMX Components ▶ Assemble predefined components
to assemble the component later.

• Copy Drawings: If a drawing template exist for the current component, you can let EMX
copy this drawing template together with the part/assembly-file.
NOTE:
The button Copy Drawings is only checked automatically, if a drawing template exist and
the component type is listed in the configuration EMX_CHECK_DWG_TYPES.

Background Information

With the EMX Option EMX_NO_CUT_PARAM you can specify an INTEGER-Parameter
name. If this Parameter exist at a certain model, it will never get a quilt cut, even it interferes
with the slider quilts.

The Option CUT_PLATES_ONLY also drives, which components will be cut. If the option is
set to YES, only EMX plates get cuts.

If EMX assembles components with cut quilts as a real pattern, the EMX Option PATTERN_
CUT_QUILTS set to YES will force EMX to create all cuts also as reference patterns. If the
option is set to NO, the cuts are added individually for each instance of the component pattern.
This is required if instances interfere with a different amount of models.

The last relevant option is PROMPT_FOR_CUTTING_PARTS. If this is set to YES, a dialog
box is displayed with all interfering parts. So the user can drive for each part if the quilt cut is
added or not.
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11.2 About UDF Component Dimensions
When you double-click a UDF dimension, it is highlighted in the UDF preview window. All
dimensions of all required UDFs for the current component appear in an overview list.

11.3 About the Component Detail Viewer

To activate the Component Details viewer, click in the definition dialog box for the
component. The Component Details dialog box opens.

• Click to view the previous image.

• Click to view the next image.
• Click Close to close the dialog box.

11.4 About Editing a Subcomponent
Define assembly subcomponents or modify default Bill of Materials (BOM) values by
selecting any of the subcomponents in the Subcomponents tab on the Component Editor
dialog box.

1. Click EMX Assembly ▶ Administrator Tools ▶ Component Editor. The Component
Editor dialog box opens.

2. Enter a component name in the Part Name box, or select the check box and type another
name. The component appears in the preview window.

3. The BOM Data tab opens automatically. Enter the following information:

• Part ID—Unique part ID string.
• BOM Name—Full description string.
• Group Layer—Name of the component layer. This layer is created in the active (sub)

assembly when the configuration option CREATE_LAYERS_PER_PART is set to
YES.

• Part ID—Unique part ID string.
• BOM Name—Full description string.
• Order Number—Order number.
• Customer Number—Customer specific identifier.
• Material—Material.

NOTE:
• You cannot set parameters and relations for subcomponents.
• There is no UDF information for subcomponents.
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11.5 About Defining Components
1. Click EMX Components and then in the Components group, select a component. A

definition dialog box for the selected component opens.
2. Set the unit of measurement to mm or inch. By default, the unit of measurement is the

same as that of the project assembly. You can, however, use multiple measurement types
in an assembly such as using metric plates in an inch assembly.

3. Select a supplier from the list.
4. Select the assembly in which to assemble the equipment component. You cannot change

this selection while redefining a component.
5. Select the subtype of the component from the list. A simplified image of the selected

component type is displayed in the preview window. The dimensions appear in the table.
6. Right-click a row in the table to open a shortcut menu from which you can measure

diameter, length, or offset.

7. Double-click the Value column to enter a new value or to select a value from the list
. You cannot change values marked .

NOTE:
You can use the configuration option MON_DIM_DISPLAY to reduce the visible
description of the driving dimension.

8. Enter a component name in the Part Name box. To enter an alternate name, select the
check box or type the name.
NOTE:
Change the default part name format or reset the part name, in the Part Names tab in the
Options dialog box.

9. Select references such as Axis|Point, Thread Surface, Surface, and so on and select the
assembly placement constraints in the graphics window. A constraint name that does not
appear in boldface indicates that this constraint was set automatically and does not need
further definition.

NOTE:
If you move your mouse above the panel the selected reference will be highlighted in the
graphics window.

10. Set Component options on page 120, component BOM data, parameters and relations, and
UDF dimensions on page 121.

11. Select the Standard Part check box to prevent editing.
12. Select the Add to BOM check box to include the component in the Bill of Materials.

13. Click to open a detail image of the current component.

14. Click to save current settings as the default for the type of component.
NOTE:
You can also automatically save the last component used by setting the configuration
option AUTO_SAVE_LAST_COMP to YES.

15. Click to reset save current settings.
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16. Select a placement plane, and then click to create assembly reference datum points
on the fly. The model reorients normal to the placement plane. A circle appears with the
main diameter of the component. Click to place the point, and then right-click to exit the
tool.

17. Click to preview the component.

• The mold base is in wire frame mode.
• The new component is in shaded mode.
• Changes after editing a component dimension.
NOTE:
In preview the new component is always displayed in shaded mode. The configuration
option PREVIEW_VIS_MODE drives how the other components should be displayed
(wireframe, hiddenvis etc).

18. Click or to collapse or expand the options tab when the dialog is too big such as
for screens with lower resolution.

19. Click OK to create the new component and cuts or click Cancel to close the dialog box
without making changes.

11.5.1 Background Information
• When placing components through the Mold Base Definition dialog box it is not required

to select the position as their placement is defined automatically.
• The point or coordinate system inside an reference group is renamed so it can be

identified for later redefine.

By default the name is <component_type>_<id> (i.e, GUIDE_51).
Set the configuration option USE_INSTANCE_IN_REFNAME to YES to force a naming
format like <component_type>_<id>_<instance> (i.e, GUIDE_51_
E1140_42_160).

11.6 About Measuring Dimensions
1. Right–click a line in the dimension table of a definition dialog box for a component or a

plate. A shortcut menu opens.
2. Select a dimension, diameter, length, or offset to measure from the shortcut menu, or

choose a dimension to modify directly from the table.
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12.1 About Stop System Components
To define stop components, stop discs, or stop pins, click EMX Components and then in the

Components group, click Stop disc or the Stop pin to define a new stop disc or a
new stop pin.

12.2 To Assemble the Stop System
Download 25 To Assemble the Stop System to start from with this chapter.

12.2.1 Define the Stop System Pattern
1. Open Mold Base Definition dialog box.

2. Click Top to switch to the top view.
3. Double-click on Stop System MH in the summary tree.

The Stop System MH pattern dialog box opens.

For supplier meusburger no default pattern information is defined in the catalog.
4. Set X Quantity to 4.
5. Set Y Quantity to 2.
6. Enter Pattern Size 358 and 180.

7. Click to update the number of instances.
8. Change instance 3 to 6 as seen in the image below.

9. In the Mold Base Definition dialog box enable the option Show Cavity to display the full
stop system pattern in the top view.
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10. Click OK to close the pattern dialog.
11. Leave the Mold Base Definition dialog box with Close.

12.2.2 To Assemble the Stop Pins
1. Open the moving half assembly TUTOR_MH.ASM.

2. Click EMX Components ▶ Components ▶ Stop pin

The Stop pin dialog box opens.
3. Set the DM3 value to 30 mm.
4. As the first assembly reference (1) Point|Axis select the first axis instance STOP_BORE

from the stop system pattern in the TUTOR_SKELETON model.
5. As the second assembly reference (2) Surface select the top surface of the clamping plate.
6. Switch to the Options tab and enable the option Pattern for all instances.

7. Click to preview the stop pins.
8. Click OK to leave the Stop Disc dialog box.

The Stop System will be added to the mold base.
9. Close the TUTOR_MH.ASM to return to the main assembly.

12.2.3 Remove Additional Stop Pin Bores from Ejector Base Plate
The new stop bore instance should not be added to the ejector base plate. They need to be
removed from the model

1. Open the ejector base plate TUTOR_EJBASE_MH_001.ASM.
2. Modify the pattern STOP_DISC_BORE.
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3. Suppress the instances 3 to 6

4. Close the TUTOR_MH.ASM to return to the main assembly.
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13.1 About Equipment
Some components are classified as equipment. These components can be locating rings,
insulation plates, sprue bushings, or knockouts. To create, modify or define equipment
features, click EMX Components, and then in the Components group, click the arrow next

to Equipment to see the equipment list described below:

Icon Equipment Function
Locating ring Defines a new locating ring

Thermal Insulation plate Defines a new insulation plate

Knockout Defines a new knockout

Side Interlock Defines a new side interlock

Top lock Defines a new top interlock

Compression spring Defines a new spring

Sprue bushing Defines a new sprue bushing

Support bushing Defines a new support bushing

Tubular Dowel Defines a new tubular dowel

NOTE:
Some equipment, including sprue or support bushings, can have both blind or straight holes.

13.2 To Assemble the Locating Ring
Download 26 To Assemble the Locating Ring to start from with this chapter.

13.2.1 Assemble the Locating Ring
1. Open the fixed half assembly TUTOR_FH.ASM

2. Click EMX Components ▶ Components ▶ Locating ring

The Locating Ring dialog box opens.
3. Select E1370 from types pull down list.
4. Select 125 mm for DM3.
5. Select 20 mm for LG.
6. Enter a value of -6 mm for OFFSET.
7. As first assembly reference (1) Axis|Point select AXIS_LOCATING from the TUTOR_

SKELETON.PRT model.
8. As the second assembly reference (2) Surface select the top surface of clamping plate.
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9. Close the dialog box with OK.

The locating ring is assebmly to the fixed half assembly.

13.2.2 Adapt the locating cutout in the insulation plate
The insulation plate template already contains a locating cutout feature. This feature needs to
be adapted to the assembled locating ring.

1. Open the insulation plate TUTOR_INSULATION_4.PRT
2. Edit the feature LOCATING.
3. Set the diameter to 127 mm.

4. Close the TUTOR_INSULATION_4.PRT
5. Close the TUTOR_FH.ASM
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14.1 To Assemble the Sprue Bushings
Download 27 To Assemble the Sprue Bushings to start from with this chapter.

14.1.1 Assemble the Sprue Bushing
1. Open the fixed half assembly TUTOR_FH.ASM.

2. Click EMX Components ▶ Components ▶ Sprue Bushing

The Sprue Bushing dialog box appears.
3. Select E1605 from the Types pull down list.
4. Set the D_2 value to 18.
5. Set the OFFSET value to 4.

The sprue bush will interfere with the clamping plate.
6. Set LG1 to 76.

The length needs to set to a value that the sprue bush reaches the splitting plane of the
mold.

7. As the first assembly reference (1) Axis|Point select the AXIS_LOCATING from the
TUTOR_SKELETON.PRT model.

8. As the second reference (2) Surface select the top surface of the cavity plate.
9. Close the Sprue Bushing dialog with OK.

The sprue bush is assembled to the fixed half and cut-outs are added to the cavity plate.

However, additional cutouts are required in the clamping plate and the cavity insert parts,
which will be designed in the following steps.
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14.1.2 Shorten the Sprue Bush
1. Open the TUTOR_E1605_18_76_4.PRT.
2. Create an Offset feature to shorten the sprue bushing about 4 mm.

14.1.3 Create a Groove for fixing the Sprue Bush in Clamping Plate
1. Create a groove of 2x4 mm by using a Revolve feature.

14.1.4 Create a Quilt Surface Additional Cut-Outs
1. Create a quilt surface with a Revolve feature.



14.1 To Assemble the Sprue Bushings

Page 138/448

2. Set the quilt surface color to transparent.

3. Close the sprue bushing TUTOR_E1605_18_76.PRT model.
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14.1.5 Create Cut-Out in Clamping Plate
1. Activate the clamping plate TUTOR_CLP_FH_001.PRT

2. Select the previously create quilt surface and create a Solidify feature with Remove
material option enable

3. Activate TUTOR_FH.ASM
4. Close TUTOR_FH.ASM and return to the main assembly.
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14.1.6 Create Cut-Outs in Cavity Insert Partse
1. Within the main assembly activate the insert parts MOLD_VOL_IS_1.PRT within the

first cavity insert assembly MFG_1.ASM.

2. Select the previously create quilt surface in the sprue bushing model and create a
Solidify feature with Remove material option enable
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3. Repeat the steps for MOLD_VOL_IS_2.PRT.

4. Activate TUTORORIAL.ASM.

The Sprue bushing is now full placed.



Notes:
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15.1 About Screws
Use screws to join components and use shoulder screws that are similar to latch locks to

control plate movement. Click EMX Components ▶ Screw to define a new screw.

You can place screws with a counterbore in the first component, and a straight hole or blind
hole in the last component. When you select One Plate the screw is assembled on only one
plate.

The placement references for screws always contain a (2) Surface and a (3) Thread Surface.

The offset of the two surfaces is measured and displayed in the REF1 Reference Distance, i.
e. 20 mm.

Within the screw image the meaning of the reference distance is displayed by the dimension
REF1.

The red dimension 12.0 indicates that the fixing length of the screw in the tapped hole is
deeper than the default thread depth. Either the length LG1 or the thread depth in the cut-out
dimension T4/T5 need to be adapted.

In case a shorter screw instance is selected the threaded depth dimension shows value 7.000
and switches to green, which indicates that the selected length is appropriate.

This dimension is calculated by the offset of the two surfaces and the selected screw length. If
the result is larger than 0 and smaller than T4 of the bore, it is considered to be okay.
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15.2 To Assemble Screws
Download 28 To Assemble Screws to start from with this chapter.

15.2.1 Create a Datum Point
1. Open the mold base TUTOR_FH.ASM.
2. Open the locating ring TUTOR_LOCATING_RING_2001.PRT.
3. Create a sketch of datum points as seen in the picture below.

4. Close the current window TUTOR_LOCATING_RING_2001.PRT and return to the
TUTOR_FH.ASM.

15.2.2 Assemble the Screw

1. Select EMX Components ▶ Components ▶ Screw .
2. In the Screw dialog box select the desired screw supplier meusburger and screw type

E1200 | Socket head cap screw.
3. Define the references.

a. Click (1) Point|Axis and select the previously created datum point on the locating ring
TUTOR_LOCATING_RING2002.PRT.

b. Click (2) Surface and select the top face of the model TUTOR_LOCATING_RING_
2001.PRT.

c. Click (3) Thread surface and select the locating cut face of the top clamping plate.

The default length for the screw is calculated by the rule defined in the configuration
Option MIN_SCREW_LENGTH_RULE.

The default value for this rule is 1.5*diameter+REF1+OFFSET.
4. Select Pattern for all instances.
5. Double click the DM1 Diameter Value and select 6.
6. Double click the LG1 Length Value and select 20.
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7. Close the Screw dialog box with OK.

8. Close the mold base TUTOR_FH.ASM and return to main assembly.

15.3 To Assemble Screws on Insert Parts
Download 29 To Assemble Screws on Insert Parts to start from with this chapter.

15.3.1 Create Points on Insert Parts
1. Open MOLD_VOL_IS.PRT.
2. Create sketched datum points on the top surface of the model as seen in the image below.

3. Close MOLD_VOL_IS.PRT and return to TUTORIAL.ASM.
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NOTE:
You can hide the Layers 00_BUW_SCREWS, 00_BUW_EJECTORS, 00_BUW_GUIDES
or 00_BUW_EQUIPMENT etc. to reduce the amount of points displayed in the assembly.

4. Repeat these steps for the MOLD_VOL_ES.PRT model.
5. Regenerate the Assembly TUTORIAL.ASM.

The points will be added to the parts MOLD_VOL_IS_1.PRT, MOLD_VOL_IS_2.PRT,
MOLD_VOL_ES_1.PRT and MOLD_VOL_ES_2.PRT.

15.3.2 Assemble the Screws for the Fixed Half insert Parts

1. Click EMX Components ▶ Components ▶ Screw .
2. Select TUTOR_FH as target subassembly form the subassembly pull-down list.
3. Define the references.

a. Click (1) Point/Axis and select the recently defined points from MOLD_VOL_IS_1.
PRT

b. As (2) Surface select the top surface of the cavity plate TUTOR_CAV_PLATE_FH_
0001.PRT

c. As (3) Thread Surface select the top surface of the MOLD_VOL_IS_1.PRT insert.
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4. Select DM1 — Diameter 8 mm.
5. Select LG1 — Length 50 mm.
6. Close the Screw dialog box with OK.

7. Repeat these steps for the MOLD_VOL_IS_2.PRT model.

15.3.3 Assemble the Screws for the Moving Half insert Parts

1. Click EMX Components ▶ Components ▶ Screw .
2. Select TUTOR_MH as target subassembly form the subassembly pull-down list.
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3. Define the references.

a. Click (1) Point/Axis and select the recently defined points from MOLD_VOL_ES_1.
PRT

b. As (2) Surface select the bottom surface of the cavity plate TUTOR_CAV_PLATE_
MH_001.PRT

c. As (3) Thread Surface select the bottom surface of the MOLD_VOL_ES_1.PRT
insert.

4. Select DM1 — Diameter 8 mm.
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5. Select LG1 — Length 45 mm.
6. Close the Screw dialog box with OK.
7. Repeat these steps for the MOLD_VOL_ES_2.PRT model.

In total 16 screws should be assembled to the mold base.

15.4 To Assemble Screws on Insulation Plates
Download 30 To Assemble Screws on Insulation Plates to start from with this chapter.

15.4.1 Create Points on Insulation Plates
1. Open TUTOR_FH.ASM
2. Open TUTOR_INSULATION_4.PRT
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3. Create sketched datum points on the top surface of the model as seen in the image below.

4. Close TUTOR_INSULATION_4.PRT and return to TUTOR_FH.ASM.

15.4.2 Assemble the Screws to the Insulation Plates

1. Click EMX Components ▶ Components ▶ Screw .
2. Select the screw E1220 from Types pull-down list.
3. Define the references.

a. Click (1) Point/Axis and select the recently defined points from TUTOR_
INSULATION_4.PRT

b. As (2) Surface select the top surface of the insulation plate TUTOR_INSULATION_
4.PRT

c. As (3) Thread Surface select the top surface of the clamping plateTUTOR_CLP_
PALTE_FH_001.PRT insert.

4. Select DM1 — Diameter 5 mm.
5. Select LG— Length 16 mm.
6. Close the Screw dialog box with OK.
7. Close TUTOR_FH.ASM and return to main assembly.
8. Repeat these steps for the INSUALTION_PLATE_3.PRT in the moving half.
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16.1 About Dowel Pins
Use dowel pins to prevent two components from moving relative to each other. Click EMX

Components and then in the Components group click Dowel Pin to define a dowel pin.

You can place dowel pins with a straight hole, a counter bore or a blind hole in both sides.

16.2 To Assemble Dowel Pins
Download 31 To Assemble Dowel Pins to start from with this chapter.

16.2.1 Create a Datum Point
1. Open the mold base TUTOR_FH.ASM.
2. Open the sprue bushing TUTOR_E1605_18_76_4.PRT.
3. Define a point on the existing dowel pin hole on the bottom side of the bush head.

4. Close the current window TUTOR_E1605_18_76_4.PRT and return to the TUTOR_
FH.ASM.

16.2.2 Assemble the Dowel Pin

1. Select EMX Components ▶ Components ▶ Dowel Pin.
2. In the Dowel Pin dialog box select the desired supplier meusburger and type E1300.
3. Define the references.

a. Click (1) Point|Axis and select the previously created datum point in the sprue
bushing TUTOR_E1605_18_76_4.PRT.

b. Click(2) Surface and select the flat cut-out surface of the sprue bushing.
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4. Select 4 mm for DM1.
5. Select 12 mm for LG.

NOTE:
For dowel pins the offset is initially always set to half of the length.

6. Activate the option Blind Hole Bottom.
7. Close the Dialog dialog box with OK.

8. Close the mold base TUTOR_FH.ASM and return to main assembly.



Notes:
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17.1 About Ejector Pins
Use an ejector pin to push the cold plastic part out of the cavity insert when the mold base is
opened.

Their placement can be specified using datum points in the reference model.

If no reference model exists the placement references for ejector pins can be defined in the
core model of the Creo Expert Moldbase Extension assembly.

Click EMX Components ▶ Ejector Pin and click one of the following commands:

• Ejector Pin Designer—Define Ejector Pins dynamically

• Ejector Pin—Defines a new ejector pin.

• Update existing Ejector Pins—Updates existing ejector pins in case reference
distance has changed..

• Delete all Ejector Pins—Deletes all ejector pins in the current assembly.

• Trim Ejector Pin Heads—Trims ejector pin heads against each other.

• Identify ejector pin owner models—Prepares the selected parts for predefining
ejectors with layout curve on page 190

• Add Ejector Bores—Checks and adds the cutouts for every assembled ejector pin if these
are not present.

• In Drawing Mode Only: Add drawing symbols—Places drawing symbols on all
ejector pin cutouts in the drawing model. Add notes to the drawing to see the ejector ID.

NOTE:
• You can use Trim to quilt/refmodel on all ejector pin types. To define the quilts, click

EMX Part Mode ▶ Preparation ▶ Identify trim faces or EMX Assembly ▶ Preparation
▶ Identify trim faces.

○ If a trim surface is defined then Creo Expert Moldbase Extension uses the
Solidify feature to create the trimmed surface.

○ If no trim surface is defined then Creo Expert Moldbase Extension trims the ejector

pin against the solid using the Mold Design Trim to Geometry.
• When you use an ejector pin as a core pin, you must assemble a different hole type to the

extracts. Select these hole types from a list of fixed rotation hole types.
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17.2 To Assemble Ejector Pins
Download 32 To Assemble Ejector Pins to start from with this chapter.

17.2.1 Assemble the Ejector Pin Target Subassembly

1. Click EMX Assembly ▶ Structure ▶ Add Subassemblies

The Subassembly dialog box opens.
2. Select TUTOR_MH from the Subassembly pull-down list.
3. Enter TUTOR_MH_EPINS into the Name input panel.
4. Select Ejector Pins from the Function pull-down list.
5. Click OK to leave the Subassembly dialog box.

A new EMX Subassembly will be added to the mold base assembly.

With the assigned Ejector Pins function all upcoming ejector pins will by default be
assembled to this subassembly.

17.2.2 Define the Ejector Pin Properties

1. Click EMX Assembly ▶ View ▶ Show ▶ Moving Half.

2. Select EMX Components ▶ Ejector Pin ▶ Ejector Pin .

The Ejector Pin dialog box opens.

TUTOR_MH_EPINS is preselected as Subassembly.
3. Select knarr from the Supplier pull-down list.
4. Select 37111 from the Types pull-down list.
5. Set the DM1 value to 4 mm.
6. Define the references

a. For (1) Point select a point from the multi point feature PNTS_ROUND_EPIN_4MM
in the ARTICLE_REF.PRT model.

After the Point has been selected the offset between the point and the default reference
surface will measured.

This offset (157.541 mm) is shown in the Reference Distance line of the
Dimensions.

The next valid instance is chosen automatically in case an instance of this ejector pin
exists, where the LG1 exceeds the measured distance.

NOTE:
Awarning dialog appears in case the required length for the selected diameter does not
exist in the catalog.
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b. The (2) Surface reference will be selected automatically and is used to align the head
of the ejector pin. By default the bottom face of the first ejector retainer plate in the
mold base is used.

NOTE:
A different surface can be selected by clicking the Surface button and select the
desired face in the model.

c. The (3) Orientation surface is preselected. The MOLDBASE_Y_Z of the skeleton
model is used by default for all ejector pins.

7. Click Preview to visualize the ejector pins.

On each point of the multiple point features an ejector pin is previewed.

NOTE:
It is not possible to place a single ejector component on a single datum point within a
point feature containing multiple point instances. The same ejector pin model will be
placed on all points.

8. Enable the option Individual ejector models on each point.

This option is necessary to be able to Trim the ejector pin heads on page 194 after
finishing the ejector pin placement.

NOTE:
With this option an individual ejector pin model will be placed on each point.

This automatically is used for:

• Ejector pins defined on multiple point features with different heights.
• Trimmed ejector pins on multiple point features.

9. Make sure Auto Length is activated.

With this option the length of the ejector is set to the Reference Distance value displayed
in the dialog box.

10. Switch to the Options tab and click Pattern on all models to add the ejector pins (and
their cutouts) to both ARTICLE_REF.PRT models.

11. Click Preview again to visualize the ejector pins.

On each point of the multiple point features and on both reference models an ejector pin is
previewed.

12. Close the Ejector Pin dialog box with OK.

The ejector pins and their according cutouts are assembled to the mold base.
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NOTE:
This ejector pin length is stored in the Parameter with the rule &remark to the model, by
default this is the NOTE Parameter.

Use the two configuration option EJP_NOTE_PRE_STRING and EJP_NOTE_POST_
STRING to specify additional text for this NOTE Parameter before and after the number.

13. Open the MOLD_VOL_ES_1.PRT model.

All cut-outs are created on part level.
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The groups EJP_CB_ANGLE can be treated and handled like any other feature..

14. Close MOLD_VOL_ES_1.PRT and return to the main assembly.

17.3 To Assemble Trimmed Ejector Pins
Download 33 To Assemble Trimmed Ejector Pins to start from with this chapter.

1. Click EMX Assembly ▶ View ▶ Wireframe Style.

2. Click EMX Assembly ▶ View ▶ Show ▶ Moving Half.

3. Click EMX Components ▶ Ejector Pin.

The Ejector Pin dialog box opens.

The TUTOR_MH_EPINS assembly is preselected.
4. Select knarr from the Supplier pull-down list.
5. Select 36111 from the Types pull-down list.
6. Set the DM1 value to 2 mm.
7. Define the references

a. For (1) Point select a point from the multi point feature PNTS_SHOULDERED_
EPINS_2MM in the ARTICLE_REF.PRT model.

The LG1 value is automatically set to 200 mm.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial


Ejector Pins

Page 163/448

8. Activate Trim to quilt/refmodel option.

9. Select Rotfix1 from the Fix Rotation pull-down list.

The former counter bore in the ejector retainer plate is replaced by a new UDF with the
rotation fix geometry. The ejector pin geometry is also modified to fit to the new cutout.

10. Switch to the Options tab and activate the Pattern for all models option.
11. Close the Ejector Pin dialog box with OK.

The cut-outs are generated and the ejector pin is assembled.

A Trim To Geom feature is added to each ejector pin to trim it against the reference
model.
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The rotation fixture UDF is added to the ejector retainer plate and the ejector models a
modified.

17.4 To Assemble Ejector Sleeves
Download 34 To Assemble Ejector Sleeves to start from with this chapter.

17.4.1 Assemble the Small Ejector Sleeves

1. Click EMX Assembly ▶ View ▶ Wireframe Style.

2. Click EMX Assembly ▶ View ▶ Show ▶ Moving Half.

3. Click EMX Components ▶ Ejector Pin.

The Ejector Pin dialog box opens.

The TUTOR_MH_EPINS assembly is preselected.
4. Select knarr from the Supplier pull-down list.
5. Select 38188 from the Types pull-down list.
6. Click RMB on the Value column of Diameter.
7. Pick Measure Diameter from the Measure Popup Menu.
8. Select the edge as displayed below. The measured diameter will be displayed in an EMX

message box with 4.221 mm
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9. Set the inner diameter DM1 value to 4.5 mm which is the next larger diameter comapre
to the measured value.

10. Set the outer diameter DM3 value to 7 mm.
11. Define the references

a. For (1) Point select a point from the multi point feature PNTS_SLEEVE_1 in the
ARTICLE_REF.PRT model.

The LG1 value is automatically set to 150 mm.
12. Make sure Pattern for all models is enabled.
13. Make sure Individual ejector models on each point is enabled.
14. Make sure that the Auto Length check box is enabled.
15. In the UDF Dimension set the LL value to 25 mm.
16. Close the dialog Box with OK.
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The ejector sleeves are added to the moldbase

17.4.2 Assemble the Large Ejector Sleeves

1. Click EMX Components ▶ Ejector Pin.

The Ejector Pin dialog box opens.

The TUTOR_MH_EPINS assembly is preselected.
2. Select knarr from the Supplier pull-down list.
3. Select 38188 from the Types pull-down list.
4. Click RMB on the Value column of Diameter.
5. Pick Measure Diameter from the Measure Popup Menu.
6. Select the edge as displayed below. The measured diameter will be displayed in a message

box with 8.023 mm
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7. Set the inner diameter DM1 value to 8.2 mm which is the next larger diameter compare
to the measured value.

8. Define the references

a. For (1) Point select a point from the multi point feature PNTS_SLEEVE_2 in the
ARTICLE_REF.PRT model.

The LG1 value is automatically set to 150 mm.
9. Make sure Pattern for all models is enabled.
10. Make sure that the Auto Length check box is enabled.
11. In the UDF Dimension set the LL value to 30 mm.
12. Close the dialog Box with OK.
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The ejector sleeves are added to the mold base

17.5 To Assemble Shims for Core Pins from the Library
Download 35 To Assemble Shims for Core Pins from the Library to start from with this
chapter.

17.5.1 Create the Placement Coordinate Systems
1. Open the TUTORIAL.ASM
2. Activate the TUTOR_MH.ASM

3. Click Point to create a datum point feature.

The Datum Point dialog box opens.
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4. Create 8 points in total within this feature.

For each point select as the first placement references the following axes:

a. MFG1.ASM— ARTICLE_REF.PRT— COREPINS_AXIS_1 (3 axis in pattern)
b. MFG1.ASM— ARTICLE_REF.PRT— COREPINS_AXIS_2 (1 single axis)
c. MFG2.ASM— ARTICLE_REF.PRT— COREPINS_AXIS_1 (3 axis in pattern)
d. MFG2.ASM— ARTICLE_REF.PRT— COREPINS_AXIS_2 (1 single axis)

As second placement reference select the bottom surface of core pin retainer plate
TUTOR_EFIX_PLATE_MH_001.PRT.
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5. Click OK to create the datum point feature

6. Click Coordinate System.

The Coordinate System dialog box opens.
7. Select the previously created datum points as placement references.
8. Switch to the Orientation tab
9. Select as first orientation plane the bottom surface of core pin retainer plate TUTOR_

EFIX_PLATE_MH_001.PRT and set the direction to Z.
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10. Select as second orientation plane the side surface of core pin retainer plate TUTOR_
EFIX_PLATE_MH_001.PRT and set the direction to X.

11. Make sure the orientation is correct for the library component that will be assembled in
the next section.

12. Click OK to create the coordinate system feature
13. Select the recently created coordinate system

14. Click on Pattern.
15. Set Point from the Select Pattern Type pull-down list.

16. Select From datum point for Set Type Settings.
17. Select the previously created datum point feature.
18. Click OK to create the pattern.
19. Activate the main assembly TUTORIAL.ASM

17.5.2 Assemble the Shims from the Library
1. Open the moving half subassembly TUTOR_MH.ASM

2. Click EMX Components ▶ Library ▶ Assemble

The Library Component dialog box opens.
3. Select the folder meusburger. from the tree.
4. Double–click on the E2680 library component in the list of Library Components.

The Component tab is activated.
5. Select a Length (LG) value of 40 mm.
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6. As the assembly reference (1) CSYS select the previously created patterned coordinate
system.

7. Enable the option Pattern Component.

8. Click on Preview and check if component is correctly oriented.
9. Click OK to assemble the shims.

17.5.3 Assemble the Predefined Screws defined on the Shims
1. Open the moving half subassembly TUTOR_MH.ASM

2. Click EMX Components ▶ Component Handling ▶ Assemble predefined
components

The Selection window opens.
3. Select the first instance in the pattern of the previously create shim.

All predefined screws and the cut-outs are assembled.
4. Leave the Selection window with Cancel.
5. Close the TUTOR_MH.ASM to return to the main assembly.

17.6 To Assemble Ejector Core Pins
Download 36 To Assemble Ejector Core Pins to start from with this chapter.
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17.6.1 Add the Trimmed Core Pins to the Large Ejector Sleeve

1. Click EMX Assembly ▶ View ▶ Wireframe Style.

2. Click EMX Assembly ▶ View ▶ Show ▶ Moving Half.

3. Click EMX Components ▶ Ejector Pin.

The Ejector Pin dialog box opens.

The TUTOR_MH_EPINS assembly is preselected.
4. Select knarr from the Supplier pull-down list.
5. Select 37111 from the Types pull-down list.
6. Set the DM1 value to 4.5 mm
7. Set the REF_ANGLE value to 90 degree
8. Define the references

a. Click (1) Point to select the point from the multi point feature PNTS_COREPIN_1 in
the ARTICLE_REF.PRT model.

The LG1 value is automatically set to 160 mm.
b. Click (2) Surface to select a different placement plane.

Select the top surface of the cutout created by the shims in TUTOR_EFIX_PLATE_
MH001.PRT.

The LG1 value is updated to 200 mm.
9. Make sure that the Trim to quilt/ refmodel check box is enabled.

10. Select Rotfix1 from the Fix Rotation pull-down list.
11. Make sure Pattern for all models is enabled.
12. Close the dialog box with OK to assemble the trimmed core pins.
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17.6.2 Add the Trimmed Core Pins to the Small Ejector Sleeve

1. Click EMX Assembly ▶ View ▶ Wireframe Style.

2. Click EMX Components ▶ Ejector Pin.

The Ejector Pin dialog box opens.

The TUTOR_MH_EPINS assembly is preselected.
3. Select knarr from the Supplier pull-down list.
4. Select 37111 from the Types pull-down list.
5. Set the DM1 value to 8.2 mm
6. Set the REF_ANGLE value to 90 degree
7. Define the references

a. Click (1) Point to select the point from the multi point feature PNTS_COREPIN_2 in
the ARTICLE_REF.PRT model.

The LG1 value is automatically set to 160 mm.
b. Click (2) Surface to select a different placement plane.

Select the top surface of the cutout created by the shims in TUTOR_EFIX_PLATE_
MH001.PRT.
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The LG1 value is updated to 200 mm.
8. Make sure that the Trim to quilt/ refmodel check box is enabled.

9. Select Rotfix1 from the Fix Rotation pull-down list.
10. Make sure Pattern for all models is enabled.
11. Close the dialog box with OK to assemble the trimmed core pins.
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17.7 To Assemble Core Pins in Insert Parts using the Option “As Core
Pin in One Plate”
Download 37 To Assemble Core Pins in Insert Parts using the Option As Core Pin in One
Plate to start from with this chapter.

17.7.1 Assemble Core Pin to Insert Parts On the Fixed Half

1. Click EMX Assembly ▶ View ▶ Wireframe Style.

2. Click EMX Components ▶ Ejector Pin.

The Ejector Pin dialog box opens.
3. Select TUTOR_SHARED as target subassembly from the subassembly pull-down list.
4. Select knarr from the Supplier pull-down list.
5. Select 37111 from the Types pull-down list.
6. Set the DM1 value to 8.2 mm
7. Define the references

a. Click (1) Point to select the point from the multi point feature PNTS_COREPIN_2 in
the ARTICLE_REF.PRT model.

The LG1 value is automatically set to 160 mm.
b. Click (2) Surface to select a different placement plane.

Select the top surface of the insert part MOLD_VOL_IS.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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The LG1 value is updated to 100 mm.
8. Make sure that the Trim to quilt/ refmodel check box is enabled.
9. Make sure that the As core pin in one plate check box is enabled.

NOTE:
As soon as this option is enabled the UDF image changes. A new UDF will be used which
created the ejector guide bore and the ejector head bore in one plate.

10. Select Rotfix1 from the Fix Rotation pull-down list.
11. Make sure Pattern for all models is enabled.
12. Close the dialog box with OK to assemble the trimmed core pins.
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17.8 About Creating Ejector Pins with the Ejector Pin Designer
Use the Ejector Pin Designer to speed up the process of defining ejector pins. It takes fewer
clicks to predefine ejector pins on reference models and to finally assemble ejector pin
models and cuts to the mold base.

1. Make sure that all cavity insert assemblies are classified correctly.

The Ejector Pin Designer only works on models that are classified as reference models.
2. The Ejector Pin Designer dialog box can be opened by clicking EMX Components ▶

Ejector Pin Designer.

A simplified representation is activated that only contains the classified reference models.

The Ejector Pin Designer dialog box contains the two tabs described below:

• Design—Contains functions for predefining and assembling ejector pins.
• Options—Contains filters and options to help you design the ejector pins.

During the initialization of the dialog the Reference Models list is populated.

The number of entries depends on how many reference models have been assembled to
the mold base.

3. In the Design tab click the Reference Model box, and select your active reference model.

The active working model is the model in which you can define, modify, or delete ejector
pins.
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4. In the Placement Location area, manage your active placement location for the ejector
pin head.

The Ejector Pin Designer supports up to four different placement planes on both sides of
the mold base, the moving half, and the fix half.

To setup the active placement location select MH or FH. The list of valid placement planes
is populated depending on the current mold base design.

The following plates are supported:

• Ejector Plate #1: Ejector Pin Head is placed to the first ejector pin plate.

• Ejector Plate #2: Ejector Pin Head is placed to the second ejector pin plate.

• Core Pin Plate: Ejector Pin Head is placed to core pin plate.

• Clamping Plate: Ejector Pin Head is placed to clamping plate.
5. Notice the ejector pin that appears in the Type Preselection area which specifies the

shape of the preview that is displayed while placing a new ejector pin.

The following information is listed for the preselected component:

• Shape—Round or rectangular
• Size—Diameter or length multiplied by width
• Rotation Angle
• Unit system
• Supplier
• Instance Type
• Target Subassembly

6. Click to preselect another ejector pin type.

The Ejector Pin Dialog Box opens. Select new ejector pin type and click OK.
NOTE:
Click EMX Assembly ▶ Options and set the configuration option EJP_DESIGNER_
DEFAULT_COMPONENT. By default, what you set is assigned to the preselected
component. A valid format for this EMX option is unit|supplier|instance_
name, such as mm|meusburger|E1725_2_8_0_5_80

7. In the Ejector Pin Designer dialog box, click the Options tab to set snapping rules and
collision control to support your waterline creation.

• Select or clear the check boxes under Snap Rules for support during your waterline
creation process.

The Ejector Pin Designer recognizes all point features in the reference model and
helps you to define new ones based on their positions.

• Select the Grid check box and then setWidth to a specified value.

This sets the accuracy of the decimal digits.
• Set the Snap Tolerance.
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If the snap tolerance is higher than the grid width, EMX can snap to existing points.
8. From the Ejector Pin Designer dialog box on the Design tab under Ejector Pin

Definition, you can create, modify, and delete predefinitions for ejector pins.

As you create ejector pins, the ejector pins for the currently selected reference model
appear in a list on the bottom of the dialog box.

The steps for creating, modifying, and deleting ejector pins and for assembling predefined
components of the ejector pins, are described below:

• To create an ejector pin, follow the steps below:

a. Click to start defining a new ejector pin.

The coordinates of your pointer position are visible with the origin on the
reference model standard coordinate system.

In the graphics window, the ejector pin cross section is previewed at the pointer
position.

b. Click anywhere within the outline boundaries of the reference to define the
intersecting point of the ejector pin with the reference model.

The point feature and a layout curve are assembled to the plate.

The layout curve represents the dimensions of the predefined ejector pin. The
Ejector Pin dialog box opens.

c. Finish your ejector pin type selection. You can select different suppliers, types, and
dimensions. Click Preview to preview the layout curve.

d. Click OK to complete component predefinition and close the dialog box for the
component or click Cancel to stop the definition process.

• To create an ejector pin on existing points follow the steps below:

a. Click to add a new ejector pin on existing points.
b. Select a sketch point or datum points inside of the reference model.

The Ejector Pin Designer dialog box opens.
c. Finish the type selection for your ejector pin.

You can select different suppliers, types, and dimensions.

d. Click Preview to preview the layout curve.
e. Click OK to complete component predefinition and close the dialog box for the

component or click Cancel to stop the definition process.

NOTE:
When creating ejector pins on existing points, you can define multiple ejector pins in
one step, depending on the number of points defined in the sketch or the datum point
feature.

The position of the ejector pin is updated if sketched points are modified.
• To modify an ejector pin follow the steps below:

a. Click to activate the modify mode for existing ejector pins.
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b. Place the pointer on one ejector pin until the color of the knot changes to red and
then click the knot and move the pointer.

The selected ejector pin follows the pointer within the plate.
c. Click again to place the selected ejector pin at the current position of the pointer.

The ejector pin point is updated to the new position. Middle–click when you want
to stop modifying.

d. Right–click one of the ejector pins that changed to red to open the Ejector Pin
dialog box.

In the Ejector Pin dialog box you can redefine the ejector pin type and dimension.

Click OK to close the Ejector Pin dialog box.
• To delete a waterline, follow the steps below:

a. Click and then place the pointer on the ejector pin to be removed.

The ejector pin changes to red.
b. Click the ejector pin to remove it.

The ejector pin, the component, and the ejector pin cut out are deleted from the
mold base.

9. After you finish defining the ejector pins within the reference model, you can assemble all
components including cut outs for all defined ejector pins in the current reference model.

Click Update Ejector Pins in 3D to assemble the ejector pins and the cut outs after
defining ejector pins, and when applying modifications.

If the ejector pin solid model is already in the assembly, the representing line in the table

of all ejector pins is locked .

If a modification should be applied to the ejector pin definition, double-click the icon and

set the line to +unlocked .
Only unlocked ejector pins can be modified and reassembled with Update Ejector
Pins in 3D.

10. As ejector pins are created, they appear in the bottom of the Ejector Pin Designer dialog
box.

Review the bullets listed below for information on customizing your list of ejector pins:

• In the list, an ejector pin is represented with a name in the Instance column.

Double-click the instance name to open the Ejector Pin dialog box where you can
define the ejector pin and the associated ejector pin cut out.

• Directly change the position of the ejector pin by editing the cell values in the X and Y
columns.

• Directly rotate the ejector pin can by editing the cell value in the column.

• The trim behavior of one ejector pin is visualized in the column.

The green hook represents trimming.
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Double–click to toggle this value directly within the table.

17.9 To Assemble Ejector Pins using the Ejector Pin Designer
Download 38 To Assemble Ejector Pins using the Ejector Pin Designer to start from with this
chapter.

17.9.1 Start the Ejector Pin Designer
1. Open the assembly TUTORIAL.ASM

2. Click EMX Components ▶ Ejector PinsEjector ▶ Pin Designer .

The Ejector Pin Designer opens.

A simplified representation which only contains the reference models and all ejector pins
defined with the Ejector Pin Designer is activated.

So far no ejector pins are defined by the Ejector Pin Designer.

The outline of the reference model is displayed as a green rectangle.

1. Use the default setting:

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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• Define on the reference model ARTICLE_REF.PRT.
• Assemble to the moving half MH.
• Place the ejector to the first ejector package Ejector Plate #1.

17.9.2 Manage Type Preselection

1. Click to preselect another ejector pin type.

The Ejector Pin Dialog Box opens.
2. Select knarr from the Supplier pull-down list.
3. Select 32141DLC from the Types pull-down list.
4. Select a SIZE of 5.5x1.

5. Click OK to leave the dialog box.

The preselected ejector pin information will be displayed in the dialog.

17.9.3 Predefined Ejector Pin dynamically

1. Click to start defining a new ejector pin.
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The view rotates to the bottom.

2. In the graphics window, the ejector pin cross section is previewed at the pointer position.

3. Click anywhere within the outline boundaries of the reference to define the intersecting
point of the ejector pin with the reference model.
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The point feature and a layout curve are assembled to the plate.

The layout curve represents the dimensions of the predefined ejector pin.

The Ejector Pin dialog box opens.

The previously preselected type is displayed in the Ejector Pin dialog box.

NOTE:
You can select different suppliers, types, and dimensions

4. Click OK to complete component predefinition and close the dialog box for the
component.

The ejector pin will be added to the list of ejector pins.
5. Click middle-mouse button to leave the interactive predefinition.

17.9.4 Working with list of Ejector Pins
As ejector pins are created, they appear in the bottom of the Ejector Pin Designer dialog box.

1. Double-click on X value and set it to 23.100
2. Double-click one Y value and set it to 48.000.

The curve will be moved top the new position. In case the position is invalid the old value
remains.
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17.9.5 Assemble the predefined Ejector Pins

1. Click Update Ejector Pins in 3D

The ejector pins will be assembled and create the cut-outs in all interfering plates and
components.

17.9.6 Delete Ejector Pins
1. Click with right-mouse button on the recently created ejector pin in the table and click

Delete Ejector Pin

The ejector pin, the component, and the ejector pin cut out are deleted from the mold base.

17.9.7 Predefined Flat Ejector Pins with 0° Rotation on existing points
1. Make sure all points in the reference model are visible.

2. Click to predefine a new ejector pin on existing points.

the view is rotated to the bottom view.

The Selection Window opens.
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3. In the graphics widow select a point from the multiple point featurePNTS_FLAT_EPIN_
5-5X1MM_0-DEG.

The point feature and a layout curve are assembled to the plate.

4. Make sure Trim to quilt/refmodel is activated.
5. Click OK to finish the predefinition.

The ejector pins are added to list.
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17.9.8 Predefined Flat Ejector Pins with 90° Rotation on existing points

1. Click to predefine a new ejector pin on existing points.

The Selection Window opens.
2. In the graphics widow select a point from the multiple point featurePNTS_FLAT_EPIN_

5-5X1MM_90-DEG.

The point feature and a layout curve are assembled to the plate.
3. Enter 90 for REF_ANGLE.

4. Click Preview to update the layout curves.

5. Make sure Trim to quilt/refmodel is activated.
6. Click OK to finish the predefinition.

The ejector pins are added to list.

17.9.9 Predefined Flat Ejector Pins with 23° Rotation on existing points

1. Click to predefine a new ejector pin on existing points.

The Selection Window opens.
2. In the graphics widow select a point from the multiple point feature PNTS_FLAT_

EPIN_5-5X1MM_90-DEG.

The point feature and a layout curve are assembled to the plate.
3. Enter 90 for REF_ANGLE.
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4. Click Preview to update the layout curves.

5. Make sure Trim to quilt/refmodel is activated.
6. Click OK to finish the predefinition.

The ejector pins are added to list.

17.9.10 Assemble the Flat Ejector Pins on Existing Points

1. Click Update Ejector Pins in 3D
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The ejector pins will be assembled and create the cut-outs in all interfering plates and
components.

2. Leave the Ejector Pin Designer with OK.

17.10 About Predefining Ejector Pins with Layout Curves in Part Mode
To speed up the process of defining ejectors, you can use this feature to predefine ejector pins
with layout curves directly in the article model.

As a result, you get a better view of where the ejector pins are placed on the article and
whether their dimensions fit into the design.

You can then assemble all predefined ejector pins at one time within the mold base assembly.

1. Prepare the models where you need to predefine ejector pins:

a. Click EMX Components ▶ Ejector Pin ▶ Identify ejector pin owner models.
b. Select one or several models where you need to predefine the ejector pins. This is

usually the article model.
c. Click OK. The Select dialog box closes.
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d. The selected models are prepared for predefining ejector pins.
2. Predefine the ejectors in the article model:

a. Open one of the models you prepared in the previous step.
b. Click EMX Components ▶ Ejector Pin to predefine an ejector pin.
c. Select a supplier, the subtype of the ejector, and edit the dimensions or the options. For

more details, see To Define Components on page 122
d. Note that the assembly placement constraints for Surface and Orientation Surface

are already selected and show the Select icons while the placement constraint for

the Point is not selected and shows the To be Selected icon
e. Select a point on the article to place the ejector pin.
f. Note that under Options, the Predefine Component check box on page 120 is

selected.

g. Click to assemble the layout curve and to preview the real position and size of
the ejector pin on the article

h. Make as many changes as necessary and preview the results by clicking .
i. Click OK to apply the changes and close the dialog box, or click Cancel to close the

dialog box and discard all changes.
j. Repeat these steps until you have defined all required ejector pins

3. The third step of the process is to assemble all predefined ejector pins at one time within
the mold base assembly:

a. Close the window of the article model and open and activate the window of the EMX
mold base main assembly.

b. Click EMX Components ▶ Assemble predefined components.
c. Select one or more models that have predefined ejector pins. EMX assembles the

ejector pins with the predefined settings including components and cuts. For all ejector
pins that were assembled successfully, the layout curve created in the previous step is
removed.

17.11 To Predefine Ejector Pins in Part Mode with Layout Curves
Download 39 To Predefine Ejector Pins in Part Mode with Layout Curves to start from with
this chapter.

17.11.1 Identify the Ejector Pin owner model
1. Open the TUTORIAL.ASM

Before adding ejector pins in part mode it is necessary to copy the placement reference
datum plane for ejector pins in the model. Otherwise the required length of the ejector
pins cannot be determined.

2. Select EMX Components ▶ Ejector Pin ▶ Identify ejector pin owner models .

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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3. Select the model ARTICLE_REF.PRT

EMX adds two orientation planes normal to the splitting plane and a copy of each
clamping plane, ejector reference plane, both fixed half and moving half.

4. Click OK.
5. Open ARTICLE_REF.PRT .

17.11.2 Predefine Ejectors in Part Mode

1. Select EMX Part Mode ▶ Components ▶ Ejector Pin .

The Ejector Pin dialog box shows up.
2. Select the Supplier knarr.
3. Select the Type 32141DLC.
4. Select SIZE 3.8x1.
5. Set the REF_ANGLE value to 90.
6. Define the references.

a. As first Reference (1) Point select a point from the multiple point feature PNT_
FLAT_EPIN_3-2X1MM_90-DEG.

NOTE:
Due to the previous Identify-Step the copy of the ejector retainer datum plane EMX_
EJP_REFPLANE_MH is set as default reference. So the REF-distance can be
measured like if you would work in assembly mode.

7. Make sure that the option Pattern for all models is enable.
8. Make sure Trim to quilt/refmodel is enabled.
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9. Preview with

An additional predefined layout curves of the ejector pin can be seen now.
10. Click OK to assembled the predefined components reference groups to the model.
11. Close the ASM_PALM_REF.PRT and go back to the TUTORIAL.ASM.

17.11.3 Assemble Ejector Pins with “Assemble predefined components”
1. Open the TUTOR_SHARED.ASM.

NOTE:
These predefined components are always assembled to the currently opened Subassembly.

The ejector pins will be assembled to TUTOR_SHARED.ASM.

2. Click EMX Components ▶ Component Handling ▶ Assemble predefined
components .

A selection window shows up and asks for the assembly from which the predefined
components should be assembled.

3. Select ARTICLE_REF.PRT.

All ejector pins will be assembled.
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Cut-outs are only crated to the insert parts so far..

4. Close TUTOR_SHARED.ASM and return to the main assembly TUTORIAL.ASM.
5. Click EMX Components ▶ Ejector Pin ▶ Add Ejector Bores from the Ejector Pin

overflow menu.

All missing cut-outs are created to the mold base assembly

17.12 About Trimming Ejector Pin Heads
Use the Trim Ejector Pin Heads function in case several ejector pins interfere after
assembling the ejector pins.

The Trim Ejector Pin Heads function can be started by clicking EMX Components ▶

Ejector Pin ▶ Trim Ejector Pin Heads.

Select a pair of interfering ejector pins to assemble the trim udfs.

17.13 To Trim the Ejector Pin Heads
Download 40 To Trim the Ejector Pin Heads to start from with this chapter.

17.13.1 Trim the Ejector Pin Heads
1. Open the TUTOR_MH_EPINS.ASM

Some ejector pin heads still interfere.
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2. Select EMX Components ▶ Ejector Pin ▶ Trim Ejector Pin Heads .

The Selection Window opens.
3. Select the first ejector pin of an interfering ejector pin pair.

4. Select the second ejector pin of an interfering ejector pin pair.
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5. Continue to select all pairs of interfering ejector pins.

6. Leave selection loop with Cancel.
7. Close TUTOR_MH_EPINS.ASM to return to the main assembly.
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17.14 About Updating Existing Ejector Pins
In can happen that design changes are required after the ejector pins are already assembled.

Certain design changes, i.e. changing the cavity plate thickness or changing the reference
model shrinkage require an update of the ejector pin length.

The Update Existing Ejector Pins dialog box can be opened by clicking on EMX

Components ▶ Ejector Pin ▶ Update existing ejector pins.

The dialog box contains a tree table with all assembled ejector pins and the related instances.

In the table columns one can find:

• The Order Number
• The Quantity
• The Current Length is measured at the time the ejector pin is assembled.
• The Required Length is measured at the time the Update Existing Ejector Pin dialog

box is opened.

The length values is measured for each ejector pin from the selected reference point to the
reference surface.

The values are different in case the mold base design has changed in a way that either the
reference point or the reference surface have changed their position.

• The Status.

In case the Current Length and the Required Length are different the update icon is
displayed.

In case no update is required the OK icon is displayed.

The update procedure can be started with Update.

For all ejector pins which are designated to be updated a new instance is selected which
exceeds the Required Length.

The Current Length and the Order Number are updated.

17.15 Interlude: Update Existing Ejector Pins
Download 41 Interlude Update Existing Ejector Pins to start from with this chapter.

17.15.1 Modify the Cavity Plate Thickness on the Moving Half

1. Click EMX Assembly ▶ Mold Base ▶ Assembly Definition.

The Mold Base Definition dialog box opens.
2. Double-click on the moving half cavity plate in the side view of Mold Base Definition.

The Plate dialog box opens.
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3. Change the Thickness to 86 .
4. Apply the modifications to the plate with OK.
5. Close the Assembly Definition with Close.

6. Click EMX Assembly ▶ View ▶ Show ▶ Moving Half.
7. Hide of the reference models.

The following problems can be discovered:

• Ejector pins with the option Auto Length are too short.

The length value in the ejector pin model is not regenerating automatically.

• Ejector pin models with the option Trim to quilt/refmodel have a correct length.

The Solidify and Trim to geometry feature regenerating,
• In both case the order number can be incorrect if the new required length exceeds the

nominal length of the selected instance.

17.15.2 Update the Ejector Pins

1. Click EMX Components ▶ Ejector Pin ▶ Update existing ejector pins.

The Update Existing Ejector Pins dialog box opens.

NOTE:
The difference between the Required length and the Current length is 10 mm, which is
the difference between the old and the new cavity plate thickness.

2. Click Update.
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The update procedure is started and all ejector pins are regenerated.

NOTE:
Some ejector pins have new a Order Number.

37111/4–160 was enough for a Current Length of 157.541 mm.
37111/4–200 is necessary to fit a Required Length of 167.541 mm.

3. Click OK to leave the dialog box.

17.16 About Deleting all Ejector Pins

1. Select EMX Components ▶ Ejector Pin ▶ Delete all Ejector Pins. The EMX
Question dialog box opens.

2. Click Yes to delete highlighted components and features. All ejector pins and cutouts are
deleted.
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18.1 About the Component Library
You can define any component as a Creo Expert Moldbase Extension library component. If
you integrate a Creo Parametric assembly into the EMX library, all components are handled

using EMX operations. On the EMX Components tab, click Assemble to assemble a
library component. The Library Component dialog box opens. Select the components
required and click OK. A reference group is created with the component and all required cuts.
All component information is stored as a reference group parameter.

18.2 About Assembling Library Components
1. Click EMX Components ▶ Assemble. The Library Component dialog box opens.
2. Select the name of the parent assembly.
3. The LIBRARY_PATH option sets the default root directory. Choose the unit of measure

<unit> as mm or inch, then set the root directory to /components/<unit>/
library.

4. Enter a search string and click to list all matches in the Library Components list,
or select a directory from the browser window.

5. Select a component from the active directory. The Component tab is activated and the
component is displayed in a preview window. The component dimensions appear in a
table adjacent to the preview window.

6. Right-click a line in the table to open the Measure dialog box, double-click a cell in the

Value column to edit the dimension value , or select a value from the list .
NOTE:
You cannot change values marked .

7. Enter a component name in the Part Name field. Select the check box to enter an alternate
name. The component is displayed in the preview window.

8. The reference names in boldface must be set manually. Click the displayed references
such as Axis, Plane, and so on and select the respective assembly placement constraints
from the graphics window.

9. Select an instance from the table.
10. When you select the Standard Part check box at the bottom of the window, you cannot

modify the parameter dimensions in the existing model. The new instance is substituted
for the existing component. When you clear the Standard Part check box, and set new
dimensions and parameters, the existing component is modified.

11. Select the Add to BOM check box to include the component in the bill of materials. When
the component is an assembly, you can set subassemblies independently.

12. Select the following general options in the Options tab for library components:
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• Create Cut—When you define a component with cut quilts, cut-by-quilt features are
created in all models that interfere with the new component after it has been
assembled.

• Pattern Component—When one of the assembly constraints is part of a pattern, the
library component is placed on each instance of that pattern.

13. Click to preview the assembled component. Awire frame assembly appears in the
mold base. The new component appears shaded so you can check the dimensions. If you
redefine a component, the existing model is suppressed temporarily during preview.

14. Click OK to apply the changes and close the dialog box, or click Cancel to close the
dialog box.

18.3 To Design the Runner
Download 42 To Design the Runner to start from with this chapter.

18.3.1 Create a Runner Assembly

1. Click EMX Assembly ▶ Structure ▶ Add Subassemblies

The Subassembly dialog box opens.
2. Select TUTOR_SHARED from the Subassembly pull-down list.
3. Enter TUTOR_RUNNER into the Name input panel.
4. Click OK to leave the Subassembly dialog box.

A new EMX Subassembly will be added to the mold base assembly.
5. Open the TUTOR_SHARED.ASM assembly.
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18.3.2 Create the Runner Quilt Surface
1. Active the TUTOR_RUNNER.ASM assembly.
2. Create a assembly dependent Copy Geometry feature which contains:

• The coordinate system CSYS_RUNNER from the ARTICLE_REF.PRT

• The relevant quilt surfaces from the article reference part. (You must be Show the
Layer 00_BUW_DATUM for catch it)

3. Open the TUTOR_RUNNER.ASM assembly.
4. Make quilt surfaces are not hidden by layers.
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18.3.3 Assemble the Conic Gate

1. Click EMX Components ▶ Library ▶ Assemble

The Library Component dialog box opens.
2. Select runner folder from the library tree.
3. Double-click on gate_cone.

The Component tab is activated.
4. As first placement reference (1) CSYS select the CSYS_RUNNER.
5. Set gate diameter DM to 1.8 mm
6. Set H height value to 4 mm

7. Click on Preview to display the gate in the graphics window.

8. Click OK to assembled the gate cone part.

Make sure all quilt surfaces are visible.

18.3.4 Create the Sprue Sketch
1. Create a Sketch on MOLDBASE_X_Y in the skeleton plane
2. Create the sketch as seen below.
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18.3.5 Create the Sprue Channels

1. Click EMX Components ▶ Library ▶ Assemble

The Library Component dialog box opens.
2. Select runner folder from the library tree.
3. Double-click on trapezoid_es.

The Component tab is activated.
4. ForW select a value 5 mm.
5. As first placement reference (1) Curve select a segment of the previously created sketch.
6. Click OK to assemble the sprue channel.

NOTE:
The trapzeoid_es is not a part or assembly. It is defined as UDF.

7. Repeat the assembly of the trapezoid UDF for all segments of the sketched sprue curve.
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8. Trim and merge the created quilt to finally retrieve the sprue.
9. Create round to avoid sharp corners.

18.3.6 Mirror the Quilt
1. Select the quilt and use Copy and Paste Special
2. Select Rotate for Settings
3. Select the AXIS_LOCATING from the TUTOR_SKELETON.PRT
4. Set a value of 180 degrees.
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5. Select the Options tab and disable Hide original geometry

6. Click OK to finish the special copy operation.
7. Merge both quilt surfaces.

18.3.7 Create the Sprue Puller Pin Channel

1. Click EMX Components ▶ Library ▶ Assemble

The Library Component dialog box opens.
2. Select runner folder from the library tree.
3. Double-click on sprue_puller_channel

The Component tab is activated.
4. As first placement reference (1) CSYS select the ORIGIN_MOLDBASE from the TUTOR_

SKELETON.PRT model.
5. Click OK to assemble the sprue puller pin channel.
6. Merge the quilts
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7. Create rounds to avoid sharp corners

8. Close TUTOR_RUNNER.ASM to return to the TUTOR_SHARED.ASM

18.3.8 Design the Sprue Retainer Bush
1. Create a new part TUTOR_RETAIN_BUSH.PRT and assemble it to the ORIGIN_

MOLDBASE.
2. Design the part using default functionality.

The major outline in this example is 38x38 mm
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3. Create to quilt surface which can be used for Solidify operation
4. Create Soldiify feature in

• MOLD_VOL_ES_1.PRT

• MOLD_VOL_ES_2.PRT
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18.3.9 Create the Solidify Cuts for the Runner in Insert Parts
1. Create the Solidify cuts in using the runner quilt surface in

• TUTOR_RETAIN_BUSH.PRT

• MOLD_VOL_ES_1.PRT

• MOLD_VOL_ES_2.PRT

• MOLD_VOL_IS_1.PRT

• MOLD_VOL_IS_2.PRT

18.3.10 Assemble the Sprue Puller Pin

1. Click EMX Components ▶ Ejector Pin.

The Ejector Pin dialog box opens.
2. Select knarr from the Supplier pull-down list.
3. Select 37111 from the Types pull-down list.
4. Set the DM1 value to 5 mm.
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5. Define the references

a. For (1) Point select the point PULLER_PIN from the TUTOR_SKELETON.PRT
model.

The LG1 value is automatically set to 160 mm.
6. Activate Trim to quilt/refmodel option.

7. Select Rotfix1 from the Fix Rotation pull-down list.
8. Make sure to set the D1 value in the UDF Dimensions to 5.000 mm m the Fix Rotation

pull-down list, otherwise the UDF can not be assembled
9. Close the Ejector Pin dialog box with OK.

The pin is assembled and trimmed.

Cut outs are added to the TUTOR_RETAIN_BUSH.PRT
10. Close the TUTOR_SHARED.ASM to return to the main assembly.
11. Click EMX Components ▶ Ejector Pin ▶ Add Ejector Bores from the overflow menu.

The missing bores for the puller pin are added to the mold base assembly
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19.1 About Lifters
Lifters are function units that allow demolding of undercuts without any intersection and
without the usage of sliders.

The sideways moving direction under a certain angle during the ejection process releases the
undercut geometry and the plastic part can drop out of the mold base with out any damage.

The movement of the lifter is driven by the ejector plate package, so its reach is more limited
compared to the free movement of a slider.

Click EMX Components ▶ Components ▶ Lifter to define a new lifter.

Use the Trim to quilt/refmodel option to trim the lifter bar to either the reference model or a
defined trim quilt..
NOTE:
The quilt surfaces can be designated as trim surface using EMX Assembly ▶ Preparation ▶

Identify trim faces

19.2 To Create a Lifter
Download 43 To Create a Lifter to start from with this chapter.

19.2.1 Create a Lifter
In this tutorial a lifter is designed to create the snap connection on the bottom side of the
plastic part ARTICLE_REF.PRT.

1. Open the mold base TUTORIAL.ASM
2. Display theMoving Half of the mold base.
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3. Click EMX Components ▶ Components ▶ Lifter .

The Lifter dialog opens.
4. Select TUTOR_MH from the Subassembly pull-down menu.
5. Select Supplier meusburger.
6. Select the Type E3246_E3240.
7. Define the references.

a. Click (1) Csys and select the CSYS_LIFTER coordinate system in the ARTICLE_
REF.PRT.

b. For reference (6) Surface select the bottom surface of the cavity insert part MOLD_
VOL_ES_1.PRT

c. Reference (4) Plane Guide and (5) Plane Retainer are set by default.
8. Click on (5) Plane Retainer to redefine this reference.

Select the top surface of the ejector plate TUTOR_EJFIX_PLATE_MH.PRT.
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9. Make sure that the option Trim to quilt/refmodel is enabled.
10. Enable the Option Pattern for all models.

11. Assemble the lifter with Preview

The position of the lifter is not correct and needs to be adapted.
12. Set the ALPHA value to 6 ° to adjust the position.
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13. Set the STROKE_Z value to 15 mm to adjust the position.

NOTE:
The resulting Reach is displayed in the Component image with green color.

It is calculated depending on the angle ALPHA and the STROKE_Z of the lifter.

The Reach value updates when the clicking on Preview.

14. Click Preview again.

The Reach value is set to 1.577 mm

The snap connection has a height of 1 mm.

The resulting reach is larger then the required reach.
15. Set the OFF_X value to -1.4 mm to adjust the position.

This ensures the lifter bar position is correctly interfering with the reference mode
16. Set the OFF_Z_RETAIN value to 6 mm to adjust the position.

This ensures the lifter retainer is not interfering with any ejector pins.
17. Set the CUT_S value to 2 mm.

This will create a step within the lifter bar. This step avoids damage to the ejector plates
due to the high pressures during the injection molding procedure.

18. Assemble the lifter again with Preview.

The resulting trimmed lifter bar is previewed.
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The position of the lifter is good, no other components are interfering.

19. Finally assemble the lifter with OK.

The trimmed lifter is assembled to the mold base and all cuts are created.
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The lifter creates now the contour of the snap connector and releases it during the mold
base opening process.
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19.2.2 Create Screws for the Lifter
1. Assemble E1200/5x20 screws to fixture the retainer to the TUTOR_EJFIX_PLATE_

MH_001.PRT

Make sure to assemble them with Pattern for all models.
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2. Assemble E1200/5x16 screws to fixture the guide to the TUTOR_CAV_PLATE_MH_
001.PRT

Make sure to assemble them with Pattern for all models.
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20.1 About Sliders
Use slider sets to define the vertical movement of the mold base components when the mold
base is opened or closed.

Sliders are elements used to achieve contours at the mold insert which cannot not be ejected
without any intersection.

Undercut geometry can be achieved by implementing the geometry directly into the slider.

The sideways moving direction under a certain angle during the ejection process releases the
undercut geometry and the plastic part can drop out of the mold base without any damage.

Click EMX Components ▶ Components ▶ Slider to define a slider.

Select Merge with CSYS parent to automatically merge the cam of a slider unit with the
assembly placement coordinate system.

20.2 To Create a Slider
Download 44 To Create a Slider to start from with this chapter.

20.2.1 Assemble a Slider
In this tutorial a slider will be designed to create the two snap connection at the top of the
plastic part ASM_PALM_REF.PRT.

The cavity assembly MFG_1.ASM already contains a slider part MOLD_VOL_SLIDER_1.
PRT which contains the contour geometry that needs to be moved sideways to prevent
damage from plastic part during the ejection process.
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1. Open the mold base TUTORIAL.ASM

2. Select EMX Components ▶ Components ▶ Slider.
3. Select the TUTOR_SHARED from the Subassembly pull-down menu.
4. Select strack from the Supplier pull-down menu.
5. Select Z4294L from the Type pull-down menu.
6. Select 1 from the TYPE_selector in the Nominal Values table.
7. Define the references.

a. Click (1) Csys and select the CSYS_SLIDER coordinate system in the ARTICLE_
REF.PRT.

8. Make sure that the option Remove tangent radii is enabled.

NOTE:
This option is necessary as this slider contains a cut quilt with radii at the corners.
Otherwise the cut geometry can not be created in case the sliders guide body is flush to
the cavity insert parts.

9. Enable the Option Pattern for all models.

10. Assemble the slider with Preview
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11. Measure the distance between the cavity insert side surface and the slider guide body.

The measured distance is 1.92237 mm.

12. Set the OFFSET_X value to the recently 1.92237 mm to make sure the sliders is flush to
the cavity insert part.

13. Assemble the slider again with Preview
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14. Finally assemble the sliders with OK.

Two sliders are assembled and cuts are created to the interfering parts.

20.2.2 Finish the Slider Design
The cut quilt surface of the slider assembly was interfering with the MOLD_VOL_SLIDER_
1.PRT part. Therefore a Solidify group was created in MOLD_VOL_SLIDER_1.PRT.

1. Delete the group QUILT_CUT in MOLD_VOL_SLIDER_1.PRT.

The geometry of the slider part MOLD_VOL_SLIDER_1.PRT need to be added to the newly
created slider cam TUTOR_S_CAM_3001.PRT.

1. Activate the TUTOR_S_CAM_3001.PRT within the new slider assembly.
2. Create a assembly depended Copy Geometry feature of all solid surfaces of the MOLD_

VOL_SLIDER_1.PRT

3. Open the TUTOR_S_CAM_3001.PRT.
4. Finish the slider design as seen in the image below using Solidify and Extrude features.
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20.2.3 Remove Obsolete Quilt Cuts from Cavity Insert Parts
The cut quilt surface of the original slider assembly was interfering with the cavity insert
parts.

These quilt cuts need to be removed.

1. Open MOLD_VOL_IS_1.PRT.
2. Delete the QUILT_CUT group MOLD_VOL_SLIDER_1.PRT which was created by the

slider assembly

3. Repeat this steps for

• MOLD_VOL_IS_2.PRT

• MOLD_VOL_ES_1.PRT
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• MOLD_VOL_ES_2.PRT

• MOLD_VOL_CORE_1.PRT

20.2.4 Assemble Screws to Fixture the Slider ComponentsAsl
1. Assemble E1200/6x50 screws to fixture the slider guide component to the moving half.
2. Make sure the Option Pattern for all models is active

3. Assemble E1200/6x16 screws to fixture the slider bar component to the fixed half.
4. Make sure the Option Pattern for all models is active



Notes:
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21.1 About Support Pillars
Support pillars are used for extra support between the cavity plate and the clamping plate.

They are used to give more strength to the Moving Half of the mold base.

Click EMX Components ▶ Components ▶ Support Pillar to define a support pillar.

Select the Toggle Direction check box to change support pillar orientation.

21.2 To Assemble Support Pillars on Mouse Pick Points
Download 45 To Assemble Support Pillars on Mouse Pick Points to start from with this
chapter.

21.2.1 Assemble the Support Pillars
1. Open the TUTOR_MH.ASM assembly.

2. Click EMX Components ▶ Components ▶ Support Pillar .
3. Select E1510 from the Type pull-down menu.
4. Select 40 mm for DM1.
5. Define the references.

a. As (2) Surface select the bottom side of the cavity plate TUTOR_CAV_PLATE_MH_
001.PRT.

b. As(3) Second Surface select the top side of the clamping plate .
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The REF1 Reference Distance displays the offset between the plates.

6. Click the Mouse Pick Placement .

The graphics window is reorientated to top view.

The Support Pillar dialog box is disabled now unless you have finished the placement
operation.

A Circle with the Diameter value 40 mm is drawn at the mouse position in the 3D
graphics window.

7. Add 2 points with the left mouse button.
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8. Stop the placement loop by pressing middle-mouse button.

New Points are created using the (2) Surface as placement plane.

The MOLDBASE_X_Z and MOLDBASE_Y_Z datum planes of the skeleton are used as
placement reference.
NOTE:
This mouse pick placement can only be used for the 6 main sides of the mold base right
now as the three skeleton datum planes are used as measurement references.

9. Make sure the option Toggle Direction is activated.
10. Close the Support Pillar dialog box with OK.

Two new support pillars are created.
11. Modify the previously created Datum Point feature.
12. Set the Offset References values to (50;0) and (-50;0)mm
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NOTE:
The NR_DIGITS_COMMON option is used to set the number of digits for this point offset
dimensions.

The increment that is used while you drag the mouse is defined in EMX Option
INCREMENT_POS.

Use i.e. value 1 to round the mousepick-point offsets to full millimeter.

21.2.2 Assemble the Screws for the Support Pillars
1. Assemble screws E1200/10x40 by using the previously create datums as point

reference.
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As surface references select

• the bottom surface of the moving half clamping plate

• the bottom surface of the support pillars.

1. Close TUTOR_MH.ASM to return to the main assembly.
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22.1 About Cooling Components
Connectors, plugs, and o-rings are used as cooling components to complete the waterline
inside a mold base. To define a cooling component, click the EMX Components tab and in
the Cooling Component group, select a command described below:

• Waterline Designer—Dynamically create cooling circuits.

• Cooling Component—Defines a new cooling component.

• Show waterline—Create a model that contains the full cooling circuits as surface
copies.

• Assemble a waterline curve—Assembles a waterline curve.
• Change diameter of all cooling holes—Modifies the diameter of all waterline holes.
• Change diameter of selected cooling holes—Modifies the diameter of single waterline

holes.
• Delete entire waterline—Deletes all waterline components and holes.

From the Cooling Component dialog box, you can select the Counterbore and Second
Diameter check boxes to assign a counterbore or a second diameter to all cooling bores. To
define the depth of the bore, in the Define depth by list, select one of the following:

• Enter value—Enter a value.
• Use model thickness—Measure the model thickness and calculate bore depth using a

UDF value.
• Use curve length—Measure the selected curve length as a placement reference and

calculate bore depth using a UDF value.
NOTE:
While the Reference Groups for all types of components are located in the same assembly
(like the component itself) cooling components can be fully placed in part mode. .Therefore
the configuration option ADD_COOLING_REF_IN_PART is set to YES by default.

22.2 To Assemble Cooling Components on Curves
Download 46 To Assemble Cooling Components on Curves to start from with this chapter.

22.2.1 Sketch the Cooling System Curves
Depending on the requirements sketched curves can be used to define the cooling bore
position.

In this tutorial a cooling is added to the cavity plates and the cavity insert parts.

1. Open the MOLD_VOL_ES.PRT.
2. Set the bottom side of the model to a transparent color.
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A sketch curve can be discovered within the cavity insert part.

This sketch curves can also be used in the duplicated cavity insert parts MOLD_VOL_ES_
1.PRT and MOLD_VOL_ES2.PRT.

3. Close the MOLD_VOL_ES.PRT model and return to the main assembly.
4. Open the TUTOR_CAV_PLATE_MH_001.PRT.
5. Create a sketch within the cavity plate similar to the image below.

As a placement reference a datum plane is used with an offset of 20 mm.
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Make sure the sketch refers to the sketch created in the MOLD_VOL_ES.PRT.

6. Close the TUTOR_CAV_PLATE_MH_001.PRT model and return to the main assembly.

22.2.2 Add Cooling Components on Sketched Curves
1. Open the subassembly TUTOR_SHARED.ASM.
2. Open the MOLD_VOL_ES_1.PRT and MOLD_VOL_ES_2.PRT
3. Set the bottom side of the models to a transparent color.

This improves the visibility of the curves.
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4. Select EMX Components ▶ Cooling Component ▶ Cooling Component.

The Cooling Component dialog box opens.
5. Select meusburger from the Supplier pull-down menu.
6. Select E2072 from the Type pull-down menu.
7. Select 12 mm for the DM3 nominal value.
8. Define the references.

a. Click (1) Curve|Axis|Point and select one of the curves created in the MOLD_VOL_
ES.PRT
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b. Click (2) Surface and select the side surface of the MOLD_VOL_ES_1.PRT
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.
9. Click OK to assemble the cooling component.

The cooling component and the related cuts are created.
NOTE:
The Selection window stays active.

You are now in a quick-placement loop.
10. To place the same cooling component again select

• a curve
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• a surface
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11. Finish the cooling circuit.

12. Leave the loop with middle mouse button and click Cancel to close the dialog box
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22.2.3 Modify Counter Bore Depth of Cooling Component
Several cooling components need some modification to finish the placement

1. Select the cooling component which is placed on the angular curve either in the model
tree or in the graphics window.

2. Click Modify from the mini toolbar or the right-Mouse menu.

The Cooling Component dialog box opens.
3. In the UDF Dimension table set the T3 value to 6 mm.
4. Click OK to adapt the modifications to the cooling component.

The counter bore has now a depth of 6mm.

22.2.4 Modify Additional Bore Depth of Cooling Component
Some cooling components need an additional drill depth to ensure the cross-section of the
cooling circuit always has the required diameter.

1. Select the cooling component displayed in the image below either in the model tree or in
the graphics window.
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2. Click Modify from the mini toolbar or the right-Mouse menu.

The Cooling Component dialog box opens.
3. In the UDF Dimension table set the T5 value to 4 mm.
4. Click OK to adapt the modifications to the cooling component.

22.2.5 Add Vertical Holes on Sketched Curves
To finish the circuit two vertical holes need to be assembled.

The vertical holes are the connections to the cavity plate on the moving half

1. Select EMX Components ▶ Cooling Component ▶ Cooling Component.

The Cooling Component dialog box opens.
2. Select meusburger from the Supplier pull-down menu.
3. Select Hole from the Type pull-down menu.
4. Select 8 mm for the NOM diameter value.
5. In the UDF Dimension table set the T5 value to 4 mm to ensure the additional bore depth
6. Define the references.

a. Click (1) Curve|Axis|Point and select one of the vertical curves created in the MOLD_
VOL_ES.PRT
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b. Click (2) Surface and select the bottom surface of the MOLD_VOL_ES_1.PRT

.
7. Assemble the second vertical hole in the quick selection loop.
8. Leave the loop with middle mouse button and click Cancel to close the dialog box.

The cooling circuit in the cavity insert parts is finished.
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22.2.6 Assemble Related Cooling Channels to Cavity Plate on the Moving half
In a first step two cooling nipples for in and out flow are defined

1. Open the subassembly TUTORIAL.ASM.

2. Click EMX Assembly ▶ View ▶ Wireframe Style.

3. Click EMX Assembly ▶ View ▶ Show ▶ Moving Half.

4. Select EMX Components ▶ Cooling Component ▶ Cooling Component.

The Cooling Component dialog box opens.
5. Select TUTOR_MH from the Subassembly pull-down menu.
6. Select meusburger from the Supplier pull-down menu.
7. Select E2000 from the Type pull-down menu.
8. Select 9 mm for the DM2 diameter value.
9. Define the references.

a. Click (1) Curve|Axis|Point and select one of the curves created in the TUTOR_CAV_
PLATE_MH_001.PRT
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b. Click (2) Surface and select the front surface of the TUTOR_CAV_PLATE_MH_001.
PRT
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.
10. Click OK to assemble the component.
11. Repeat the steps for the second cooling nipple

Assemble two additional seal plugs

1. Select EMX Components ▶ Cooling Component ▶ Cooling Component.

The Cooling Component dialog box opens.
2. Select TUTOR_MH from the Subassembly pull-down menu.
3. Select meusburger from the Supplier pull-down menu.
4. Select E2072 from the Type pull-down menu.
5. Select 12 mm for the DM3 diameter value.
6. Define the references.

a. Click (1) Curve|Axis|Point and select one of the curves created in the TUTOR_CAV_
PLATE_MH_001.PRT
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b. Click (2) Surface and select the left surface of the TUTOR_CAV_PLATE_MH_001.
PRT

.
7. Click OK to assemble the component.
8. Repeat the steps for the second seal plug

Assemble two additional o-rings to the vertical curves as connection to the cavity insert part

1. Select EMX Components ▶ Cooling Component ▶ Cooling Component.
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The Cooling Component dialog box opens.
2. Select TUTOR_MH from the Subassembly pull-down menu.
3. Select meusburger from the Supplier pull-down menu.
4. Select E2130 from the Type pull-down menu.
5. Select 11 mm for the DM1 diameter value.
6. In the UDF Dimension table set the T5 value to 4 mm to ensure the additional bore depth
7. Define the references.

a. Click (1) Curve|Axis|Point and select one of the curves created in the TUTOR_CAV_
PLATE_MH_001.PRT

b. Click (2) Surface and select the left surface of the TUTOR_CAV_PLATE_MH_001.
PRT
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.
8. Click OK to assemble the component.
9. Repeat the steps for the second seal plug

All cooling components for the first cooling circuit are assembled.

22.3 To Use Mold Analysis to Check the Wall Thickness
Download 47 To Use Mold Analysis to Check the Wall Thickness to start from with this
chapter.

22.3.1 Run an Mold Analysis for the Cavity Insert Part
The Mold Analysis for Creo Mold Design is a perfect tool to check the cooling circuit design.

1. Open the MOLD_VOL_ES_1.PRT.

2. Click Applications ▶ Mold/Cast

The Creo Mold Design ribbon is activated.

3. Click Mold &Cast ▶ Analysis ▶ Mold Analysis.

the Mold Analysis dialog box opens.
4. For Minimum Clearance set 4 mm.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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5. Click Compute to run the wall thickness check.

The result is displayed in the graphics window.

Several issues are found:

a. Interferences with screw hole
b. Interferences with screw hole
c. Interferences with screw hole
d. Cooling channel is too close to ejector pin bores

Design measures are require to fix these problems
6. Close the Mold Analysis dialog box with Close.
7. Click Mold &Cast ▶ Close ▶ Close to return to the Creo part mode.

22.3.2 Fix Issues discovered by Interference Check
1. Modify the Sketch 1 in the model tree to rearrange the screws.
2. Move the points to a position simillar to the image displayed below.
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3. Open the MOLD_VOL_ES.PRT model
4. Modify the Sketch 1 in the model tree to adapt the curves.

Make sure the angular curve has an sufficient distance to the reference model geometry
5. Open the TUTORORIAL.ASM.
6. Regenerate the mold base assembly.
7. Return to the MOLD_VOL_ES_1.PRT.
8. Run the Mold Analysis again.

The result is displayed in the graphics window.Several issues are found:
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The previously discovered issues are resolved.
9. Return to the main assembly TUTORIAL.ASM

22.3.3 Run an Mold Analysis for the Cavity Plate in the Moving Half
1. Open the TUTOR_CAV_PLATE_MH_001.PRT.
2. Run a Mold Analysis.

The result is displayed in the graphics window.

one issue is found:

a. The cooling channel interferes with the clamping screw
3. Modify the Sketch 1 in the model tree to rearrange the curves.
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4. Rerun the Mold Analysis.



The Cooling System

Page 259/448

The previously discovered issue is resolved.
5. Return to the main assembly TUTORIAL.ASM

22.4 About Creating Cooling Circuits With the Waterline Designer
Use theWaterline Designer to speed up the process of defining waterline circuits.

It takes fewer clicks to create waterline leading curves and the entire system of cuts and
cooling components.

1. Click EMX Components ▶ Waterline Designer.

TheWaterline Designer and the Select dialog boxes open.
TheWaterline Designer dialog box contains the two tabs described below:

• Design—Contains options for designing cooling circuits with the waterline.
• Options—Contains filters and options to help you design the waterline.

2. In the graphics window, select a list of the cavity plates where you need to define
waterline circuits and then in the Select dialog box click OK.

3. The Select Working Models list is populated.

NOTE:
You can create cooling circuits within just one working model, or between plates in
multiple working models.

4. In the Design tab, click the Select Working Models box, and select your active working
model.

The active working model is the model in which you can define, modify, or delete
waterlines.

In the Select Working Models area of this dialog box you can perform the actions
described below:

• To change the active working model click , select the model in the graphics
window, and then click OK in the Select dialog box.

• To add plates to the list of working models, click , and in the graphics window
select the plate you want to add.

The simplified representation is temporarily not visible.

Click OK in the Select dialog box and the complete mold design appears.
5. Use the Sketch Planes table to manage your sketch planes.

A sketch plane contains a Z position. The Z position of the drawing plane is measured
from the coordinate system ORIGIN_MOLDBASE which must be present in the
Creo Expert Moldbase Extension mold base assembly.



22.4 About Creating Cooling Circuits With the Waterline Designer

Page 260/448

A sketch plane is valid only if a waterline is defined on it. Sketch planes without
waterlines are automatically erased by theWaterline Designer.

• To add sketch planes click . By default the added sketch planes are placed in the
middle of the model.

• To change the placement of a sketch plane, edit the value of the sketch plane in the Z
column.

6. Use the Cooling Circuits table to add single waterlines to predefined cooling circuits.
Each cooling circuit is defined by a color and a diameter.

• In the color column the ten predefined colors for waterlines appear.

To make a cooling circuit active, double-click the row in the table.

TheWaterline Designer then adds new waterlines to the active cooling circuit.

You can change and add waterline analysis colors by following either of the methods
below:

○ Click EMX Assembly ▶ Options and then click the Technology tab.

In the Description column, scroll to the waterline_analysis_color
entries.

In the Hole Color column, click a color to change to the color. Place the pointer in

any waterline_analysis_color row and click to add new waterline
analysis color and then edit the Description and Hole Color as required.

The additional waterlines appear in the Cooling Circuits table.
○ From the <EMX_loadpoint> open the configuration folder. In the configuration

folder open bore_technology.cfg.

Scroll to the waterline_analysis_color entries and made additional
entries, such as waterline_analysis_color11.

The additional waterlines appear in the Cooling Circuits table.

• In the diameter column, the diameter of the cooling circuit appears.

This value is the designated diameter of the cooling circuit.

If you change this value all nominal waterline bores in the cooling circuit are adjusted.

NOTE:
All cooling bores in a cooling circuit should have the diameter value that is listed.

In Creo Expert Moldbase Extension, the cooling bore diameter is usually defined by
the selected component in the Component dialog box.

You can manually change the value of the cooling bore later, but as a result, the
component and the cooling bore diameter may not fit together.

Therefore, you should avoid changing the diameter of the cooling bore manually for
the components defined with theWaterline Designer.
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7. Click the Options tab to set snapping rules and collision control to support your waterline
creation.

• Select or clear the check boxes under Snap Rules for support during your waterline
creation process.

TheWaterline Designer recognizes all previously created waterlines and helps you to
define new ones based on their positions.

TheWaterline Designer supports snapping to knots and waterlines.

It also helps you to create waterlines that are orthogonal, symmetric, or directly on or
to the ORIGIN_MOLDBASE.

• If the Collision Control check box is selected, and the waterline intersects any cut
within the plate when moving the pointer to select the second point, the waterline
appears in red.

If no collision is detected or the Collision Control check box is cleared, the waterline
and the inlets appear in the color associated with the cooling circuit.

In the Stock allowance box, you can change the value that represents the minimum
allowed distance to the next hole in the plate.

8. In the Design tab, below the Cooling Circuits table, there are buttons for creating,
modifying, and deleting waterlines and for assembling predefined components of
waterlines.

As you create waterlines, the waterlines for the currently selected working model appear
in a list on the right panel of theWaterline Designer dialog box.

For more information on the list of waterlines, go to step 9. The steps for creating,
modifying, and deleting waterlines and for assembling predefined components of
waterlines, are described below:

• To create a horizontal waterline, follow the steps below:

a. Click and then click anywhere within the plate boundaries to define the first
point of the waterline.
NOTE:
The coordinates of your pointer position are visible in the plate with the origin on
the ORIGIN_MOLDBASE coordinate system.

b. In the graphics window, move the pointer within the plate boundaries to draw a
cylinder-shaped waterline showing the real position and size of the waterline bore

c. Click repeatedly while searching for the second point, to activate or deactivate the
inlets for the waterline, one at a time.

d. Click anywhere within the plate boundaries when the waterline is displayed as
valid, to select the second point for the waterline. The waterline curve is
assembled to the plate

• To create a waterline on a sketched curve follow the steps below:

a. Click and then select an existing straight sketched curve inside the current
working model.

A cylinder-shaped waterline appears at the selected curve.
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b. Right-click repeatedly to activate or deactivate the inlets for the waterline, one at a
time.

c. Click to finish the waterline.
NOTE:
Waterlines on existing curves update when regenerating, after the position of a
sketched curves changes.

• To create a vertical waterline, follow the steps below:

a. Click and then right-click anywhere within the plate boundaries.

A vertical waterline appears.

The cooling bore reaches to the top or to the bottom of the selected working
model.

b. Right-click repeatedly to change the up or down direction.

If the waterline in both directions is not valid, the creation process is interrupted.
• To modify a waterline follow the steps below:

a. Click to activate the modify mode for existing waterlines.

In this mode the waterline knots appear as white small squares on the waterline.
b. Place the pointer on one knot until the color of the knot turns red and then click the

knot and move the pointer.

The selected knot follows the pointer within the plate.
c. Click again to place the selected knot at the current position of the pointer.

The waterline curve is updated to the new position.

Middle–click when you want to stop modifying.
d. Click a waterline which is parallel to one of the main axes and then move the

pointer.

The waterline moves in parallel to the previous direction.

Click again to relocate the waterline to the new position.
e. Right–click one of the knots that turned red to open the Knot dialog box.

In the Knot dialog box you can set each coordinate of the selected knot.

To update the values in the model, click .
NOTE:
In the Options tab you can select the Shift all aligned knots check box to shift all
other knots of the defined waterlines which are on the same coordinate, with the
selected knot.

Click OK to close the Knot dialog box.

If an incorrect coordinate was entered and you want to go back to the previous

settings, click and the previous coordinates are applied.
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• To delete a waterline, follow the steps below:

a. Click and then place the pointer on the waterline to be removed. The
waterline is highlighted.

b. Click the waterline to remove it. The waterline, the component, and the cooling
bore cut out are deleted from the mold base.

• After you finish defining the waterlines in the plate, you can assemble all components
including cooling bore cut outs for all defined waterlines.

Click to assemble the cooling components and the cut outs after defining
waterlines, and when applying modifications.

9. As waterlines are created, they appear in the right panel of theWaterline Designer dialog
box.

Review the bullets listed below for information on customizing your list of waterlines,
and on the Cooling Component dialog box:

• In the Options tab, under Show Waterlines in List, select or clear the check boxes to
customize your list of waterlines.

You can show all waterlines, waterlines in the active working model, or waterlines in
the active cooling circuit.

• In the list, a waterline is represented with icons for the start and end component.
Depending on the type of component, you see a stylized preview.

• Double-click the component icon , to open the Cooling Component dialog box
where you can define the components and the associated cooling bore cut out.

• Click EMX Assembly ▶ Options and set the configuration option WATERLINE_
DESIGNER _DEFAULT_COMPONENT. By default, what you set is assigned at start
and end of the waterline. A valid format for this EMX option is unit|supplier|
instance_name, such as mm|meusburger|E2074_8_10

• In the color column you can see the color of the associated cooling circuit.

• The eye-shaped icons, or indicate whether a start or end component should
be assembled.

10. When working with theWaterline Designer, consider the related EMX configuration
options which are listed below:

• WATERLINE_DESIGNER_DEFAULT_COMPONENT—Defines the component which
is added to the waterlines by default.

A valid option format is unit|supplier|instance_name such as mm|
meusburger|E2074_8_10.

• DEFAULT_WATERLINE_DIA—Defines which diameter is assigned to the cooling
circuits by default.

NOTE:
Consider your mold base unit system. A diameter which is set to 8 in an INCH-
Assembly may be larger than expected.
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• WATERLINE_DESIGNER_OVERMEASURE—Defines the overmeasure value which
is set by default.

• WATERLINE_DESIGNER_DIA_LABEL—Defines all diameter values available for
selection in the diameter column of the Cooling Circuits table.

A valid option format is dia1|dia2|dia3 such as 8|10|12.
• WATERLINE_DESIGNER_XSEC_CREATE—If set to YES theWaterline Designer

creates cross-sections through all defined sketch planes in the selected working
models when you click OK to close theWaterline Designer dialog box.

You can then easily investigate your recently created cooling circuits. Note that these
cross sections may be erased during futureWaterline Designer sessions.

NOTE:
Click EMX Assembly ▶ EMX Options and then select the Technology tab.

In the Description column, scroll to the waterline_analysis_color entries.

In the Hole Color column, click a line to change its color.

Place the pointer in any waterline_analysis_color row and click to add new
waterline analysis color and then edit the Description and Hole Color as required.

The additional waterlines appear in the Cooling Circuits table.

The new entry will be stored in the file <EMX_loadpoint>/configuration/bore_
technology.cfg.
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22.5 To Define Cooling Circuits Using the Waterline Designer
Download 48 To Define Cooling Circuits Using the Waterline Designer to start from with this
chapter.

22.5.1 Start the Waterline Designer
1. Open the assembly TUTORIAL.ASM

2. Click EMX Components ▶ Cooling Components ▶ Waterline Designer .

TheWaterline Designer and the Select dialog boxes open.

TheWaterline Designer is still empty which means that the working models are not
selected yet.

3. Select all cavity plates and models you want to define waterline circuits on.
4. Select the components:

• TUTOR_CAV_PLATE_MH001.PRT

• MOLD_VOL_ES_2.PRT

5. Click OK in the Select dialog box.

TheWaterline Designer dialog box opens.

A simplified representation is activated which only contains the listed working models.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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22.5.2 Define Waterline on Existing Curves Cavity Plate

1. Click to define a waterline on an existing curve.

The Select window appears.
2. Select the initial curve for the circuit with the left-mouse button.

Awaterline preview is displayed in the graphics window.
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3. Click the right-mouse button to toggle the inlets.

Stop with toggling in case the inlet is set to the outer surface of the cavity plate as seen in
the image above.

4. Click left-mouse button to finally place the waterline.
5. Repeat these steps for the next two curves.
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6. Leave the selection loop with Cancel
7. Select MOLD_VOL_ES_2 in the Select Working Models pull-down menu to make it the

active working model.

8. Click again to define a waterline on an existing curve.

The Select window appears.
9. Continue to place waterlines on the existing curves step by step within the MOLD_VOL_

ES_2.PRT.
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10. Leave the selection loop with Cancel
11. Select TUTOR_CAV_PLATE_MH001.PRT in the Select Working Models pull-down

menu to make it the active working model.

12. Click again to define a waterline on an existing curve.

The Select window appears.
13. Continue to place waterlines on the existing curves step by step within the TUTOR_CAV_

PLATE_MH001.PRT.
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All waterlines are defined.

22.5.3 Work in the Waterline Table to Define Different Component Types
Modify the type of the first waterline to a cool nipple.

1. Double-Click on in the first row of the waterline table.

The Cooling Component dialog box opens.
2. Select E2000 in the Types pull-down menu.
3. Select 13.5 mm for DM2 value.
4. Click OK to finalize the type definition.

The new type is defined and the icon changes to , which stands for cooling nipple.

Modify the type of the second waterline to a seal plug.

1. Double-Click on in the second row of the waterline table.

The Cooling Component dialog box opens.
2. Select E2072 in the Types pull-down menu.
3. Select 12 mm for DM3 value.
4. Click OK to finalize the type definition.

The new type is defined and the icon changes to , which stands for seal plug.
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Modify the type of the second waterline to a o-ring.

1. Double-Click on in the second row of the waterline table.

The Cooling Component dialog box opens.
2. Select E2130 in the Types pull-down menu.
3. Select 11 mm for DM1 value.
4. Select 11 mm for DM1 value.
5. Click OK to finalize the type definition.

The new type is defined and the icon changes to , which stands for o-ring.

Modify the types using the right-mouse quick selection.

1. Right-Mouse Click on in the last row of the waterline table.

2. Click on the E2000_13_14 button.

The new type is defined and the icon changes to , which stands for cooling nipple.
NOTE:
These quick selection types can be set up using the configuration option WATERLINE_
DESIGNER_DEFAULT_COMPONENT

Finish the component type definition using for all waterlines in the table.
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22.5.4 Assemble the Cooling Components

1. Click to assemble all cooling components.

All components and cuts are created to the mold base.

2. Close theWaterline Designer dialog box with OK.

22.5.5 Check the Design Using the Automatically created Cross-Sections
Within the mold base assembly a set of Cross-Section is created

1. Activate the WD_—55 cross section.

The cooling channels still interfere with screw bore.

The incoming cooling nipple is quite close to the clamping screw
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2. Activate the WD_—13 cross section.

The cooling channels still interfere with screw bore.
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3. Run Mold Analysis to check the minimal wall thickness.
4. Modify the screw positions and curve sketches to fix the design issues
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22.6 To Assemble Cooling Components On Points
Download 49 To Assemble Cooling Components On Points to start from with this chapter.

22.6.1 Assemble Cooling Nozzle Cavity Core
1. Open the TUTORIAL.ASM.

2. Select EMX Components ▶ Cooling Component ▶ Cooling Component.

The Cooling Component dialog box opens.
3. Select TUTOR_FH from the Subassembly pull-down menu.
4. Select meusburger from the Supplier pull-down menu.
5. Select E2110 from the Type pull-down menu.
6. Select 2.4 mm for the DM2 diameter value.
7. Set 90 ° for the ROT_ANGLE value.
8. Define the references.

a. Click (1) Curve|Axis|Point

Select the point from the sketch COOL_NOZZLE in the MOLD_VOL_CORE_1.PRT

b. Click (2) Surface and select the top surface of the MOLD_VOL_CORE_1.PRT
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c. Click (3) Orientation Surface and select the side surface of the TUTOR_CAV_
PLATE_FH_001.PRT

.
9. Set the LG2 value to 25 mm

10. Click Preview to display the component
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11. In the UDF Dimension set the T5 value to 30 mm.
12. Click OK to assemble the cooling nozzle.

The component is assembled to mold base and the cutouts are create in the cavity plate
and the core model.

13. Select the TUTOR_E2210_10_2_4.PRT model either in the modeltree or the graphics
window.

14. Click Assemble again to reassemble the exact same component, but with different
assembly constraints.

15. Define the references.

a. Click (1) Curve|Axis|Point

Select the point from the sketch COOL_NOZZLE in the MOLD_VOL_CORE_1.PRT
b. Click (2) Surface and select the top surface of the MOLD_VOL_CORE_1.PRT in the

second MFG_2.ASM
c. Click (3) Orientation Surface and select the frontsurface of the TUTOR_CAV_

PLATE_FH_001.PRT

16. Click Preview to display the component.

NOTE:
Make sure the ROT_ANGLE is set correct that the flow in and flow out of the nozzle fits
you cooling circuit.

17. Click OK to assemble the cooling nozzle.
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The second nozzle is assembled to mold base and the cutouts are create in the cavity plate
and the core model.

22.6.2 Assemble O-Rings for the Cooling Nozzles
1. Assemble Meusburger O-Rings E2130/11,8x2,4 around the nozzles.
2. Make sure the optionWithout Core Bore is active.

22.6.3 Create Sketch for Nozzle Cooling Circuit
1. Create a sketch within the TUTOR_CAV_PLATE_FH_001.PRT similar to the image

below.

Make sure to refer to the cooling component placement points, e.g. by using a Copy
Geometry
feature.
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2. Create a second cooling circuit using theWaterline Designer.
3. Make sure to activate the second cooling circuit in the Cooling Circuits table.
4. Double-Click on the first column in the #2 row.
5. Set the cooling circuit diameter to 6 mm.

6. Finish the cooling circuit by adding components on curves, defining correct type and
assembling the components
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22.7 About Extracting a Waterline Model

1. Click EMX Components ▶ Cooling Component ▶ Show waterline. The Show
Waterline dialog box opens.

2. In theWaterline Model Name box, enter the waterline model name.
3. Select the Include Components check box to copy all cooling component surfaces.
4. Select the Include Reference Model check box to add the reference model.
5. Select the Include PTC Waterline Features check box to include Creo Parametric

waterline feature surfaces.
6. Select the Create solids check box to automatically create cylindrical solid models for

each waterline.
7. Select the Create MOLDFLOW curves check box to automatically create curve features

for each waterline.
8. Select the Create a circuit for each part check box to create an individual waterline

model for each plate of the mold base

9. Click to begin the analysis. If the waterline model does not exist in the assembly, a
new model is created and assembled using the configuration/templates/
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waterline_template template. All waterline features are copied to this model. If a
waterline analysis model exists, the included surface copies are updated.

10. Click Close to close the dialog box.
NOTE:
The Waterline Model can either be a part or an assembly. In the EMX Options dialog box, set
USE_ASM_WATERLINE_MDL to YES to create an assembly instead of part.

22.8 To Extract the Waterline Model
Download 50 To Extract the Waterline Model to start from with this chapter.

22.8.1 Finish the Cooling Circuits
1. Before running the waterline analysis, finish the cooling circuits in the moving and the

fixed half.

22.8.2 Run the Analysis with a Target Part

1. Click EMX Components ▶ Cooling Component ▶ Show waterline .

The ShowWaterline dialog box opens.
2. Make sure the option Include Components is enabled.
3. Make sure the option Include Reference Model is enabled.

4. Click to start the analysis.

A new model TUTOR_WATERLINE_0 will be assembled and the surfaces of the cooling
circuits will be copied.

5. Leave the dialog box with Close.
6. Open the model TUTOR_WATERLINE_0.PRT to check the result.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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The assembly contains several parts:

• WATERLINE_ES.PRT: Contains all the waterline surfaces from the moving half
• WATERLINE_IS.PRT: Contains all the waterline surfaces from the fixed half
• A list of the insert reference models
• A list cooling components
• WATERLINE_ANALSYIS.PRT:A part that represents the copied waterlines as

solids
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It is possible to show either all cooling circuits from the fixed half or from the moving by
using the predefined representations in the assembly.

7. Switch back to TUTORIAL.ASM.

22.9 About Assembling Waterline Curves
Use theWaterline dialog box to choose a standard curve and place it as a waterline on the
model's points, axes, or curves.

1. Click EMX Components ▶ Cooling Component ▶ Assemble a waterline curve.
TheWaterline dialog box opens.

2. Select Assemble Model or Assemble UDF.
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3. Choose a predefined waterline from the list.
4. Select Add waterline to the moving and fixed sides to assemble the waterline to both

sides of the mold base.

5. Click and select the placement coordinate system.
6. Click OK to close the dialog box and assemble the model or UDF waterline, or click

Cancel to exit.
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23
Latch Lock Assemblies

About Latch Locks
To Create a Latch Lock
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23.1 About Latch Locks
You can use a latch lock to allow a non-standard component to move along the mold base

opening axis. Click EMX Components and then in the Components group, click Latch
Lock to define a new latch lock.

23.2 To Create a Latch Lock
Download 51 To Create a Latch Lock to start from with this chapter.

23.2.1 Create and Pattern Coordinate System in Ejector Fix Plate
1. Open the fixed half assembly TUTOR_MH.ASM.
2. Open the ejector plate TUTOR_EJFIX_PLATE_MH_001.PRT.
3. Create a coordinate system as seen in the image below.

Make sure the X direction is normal to the side surface of the plate.

Make sure Z direction is normal to the bottom surface of the plate.

4. Create an Axis pattern with 2 members and 180° around the A_Y axis of the plate.

23.2.2 Create Positioning Plate for Steady in Clamping Plate
1. Open the ejector plate TUTOR_EJFIX_PLATE_MH_001.PRT.
2. Create a datum plane in the middle of the plate as seen in the image below.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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23.2.3 Assemble the latch lock

1. Click EMX Components ▶ Components ▶ Latchlock

The Knockout dialog box appears.
2. Select strack from the supplier pull down list.
3. Select Z4 from the Types pull down list.
4. As the first assembly reference (1) CSYS select the previously created and patterned

coordinate system from the ejector plate TUTOR_EJFIX_PLATE_MH_001.PRT model.
5. As the second assembly reference (4) pos_steady select the previously created datum

plane from the clamping plate TUTOR_CLP_PLATE_MH_001.PRT model.
6. As the third assembly reference (5) cut_bar select the top surface of the ejector base plate

TUTOR_EJBASE_PLATE_MH_001.PRT model.
7. Set the TYP value to 11.
8. Set the S1S2 — Stroke value to 15 mm.
9. Set the OFF_X value to –22.3 mm.
10. Set the CUT_BAR value to 17 mm.
11. Enable the option Pattern for all instances.
12. Click Preview to verify the assembly constraints
13. Close the Latchlock dialog box with OK.

The latch lock is assembled to the moving half. The latch lock is patterned twice.and. The
cut-outs are added to the plates.
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23.2.4 Finish the Latch lock Design
1. Fix the latch lock bar to the ejector base plate and ejector retainer plate using screws.

Work with option Pattern for all modelsto make sure screws and pins are also assembled
to the other pattern member.

2. Ensure correct position of the latch bar using pins
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3. For the steady screws and pins are already predefined.

Use Assemble Predefined Components and select the latch lock assembly
TUTOR_LATCH_ASM_1001.ASM.

Repeat this step for the other pattern member
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4. Finally the latch lock control plate needs to be fixed to the clamping plate using screws.

As placement reference axis from the TUTOR_LATCH_STDY_1001.PRT can be used.
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5. Finish the cutouts inside the plates to reduce manufacturing costs,
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24
Knockouts

To Assemble the Knock Out
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24.1 To Assemble the Knock Out
Download 52 To Assemble the Knock Out to start from with this chapter.

24.1.1 Assemble the Knockout
1. Open the fixed half assembly TUTOR_MH.ASM.

2. Click EMX Components ▶ Components ▶ Knockout

The Knockout dialog box appears.
3. Select E1050 from the Types pull down list.
4. Set the DM1 value to 20.
5. As the second assembly reference (2) Surface select the bottom surface of the ejector base

plateTUTOR_EJFIX_PLATE_MH_001.PRT model.
6. Close the Knockout dialog box with OK.

The knockout is assembled to the moving half and cut-outs are added to the plates.

24.1.2 Fix Knockout using a Set Screw

1. Click EMX Components ▶ Components ▶ Screw

The Knockout dialog box appears.
2. Select E1230 from the Types pull down list.
3. Set the DM1 value to 12 mm.
4. Set the LG value to 30 mm.
5. Set the OFFSET value to 18 mm.
6. As the second assembly reference (2) Surface select the bottom surface of the ejector base

plateTUTOR_EJFIX_PLATE_MH_001.PRT model.
7. Select the option No Cutout.
8. Close the Screw dialog box with OK.

The set screw is assembled to the moving half.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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25
Create the Moldbase Documentation

About the Bill of Materials
About Editing BOM Parameters
To Edit the Bill of Materials
About the Bill of Materials Dialog Box in Drawing Mode
To Work with Drawing Support Features
About Opening Drawings
To Write BOM to Excel via Macro
About Applying and Modifying Ejector Pin Symbols
To Add Ejector Pin Symbols to Drawing
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25.1 About the Bill of Materials
The bill of materials is based on part and component parameter definitions.

• Click EMX Assembly ▶ Bill of Materials or click EMX Drawing Mode ▶ Bill of
Materials. The Bill of Materials dialog box opens. Use it to define part and component
parameters before you start working on the design.

• To modify BOM parameters for a single part, click EMX Assembly ▶ Edit BOM
Parameters. The Edit BOM Entry dialog box opens. Select a component in the current
assembly to edit.

NOTE:
You can also define BOM parameters in the EMX Options dialog box.

25.2 About Editing BOM Parameters

1. Click EMX Assembly ▶ Edit BOM Parameters. The Edit BOM Entry dialog box
opens.

2. Click a Parameter Name to unlock the parameter value. A locked parameter is indicated

by the icon.
3. To edit the value, double-click the value in the Value box.

4. To reset a parameter to its default value, click again. The Default Value is
automatically calculated using the rule defined in the EMX Options on page 358 dialog
box.

5. To remove the component from the bill of materials, select the Ignore this component in
the BOM check box.

6. Click OK to save changes and close the dialog box, or click Cancel to discard changes
and close the dialog box.
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25.3 To Edit the Bill of Materials

25.3.1 The General Bill of Material Structure
The bill of material (BOM) generally displays information about parts and assemblies of the
mold base as parameter values.

1. Select EMX General ▶Moldbase ▶ Bill of Material to open the BOM.

While most of the parameters can be customized, the first 3 columns of the BOM table are not
changeable.

• The EXPAND column can be used to expand summarized components.

• By switching the VISIBLE entry from to the component will be added to the
Hidden Area at the bottom of the BOM. This can be useful to exclude parts like
workpieces or subassemblies.

• In the MODEL column the component type and the component name are displayed.

Parts and assemblies are displayed with different icons and .

In case a component occurs multiple times in the mold base the parent is highlighted with

a tiny .

25.3.2 Customize the Parameters for the BOM
The Bill of Material can be modified to the customers needs. Different parameters can be
displayed and handled depending on the configuration.

1. Open the EMX Options and switch to the tab Parameter.
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By default EMX offers a list of parameters as seen in the picture below.

All parameters which are defined in the Parameters tab will be shown in the BOM if their
entry Show In GUI is set to YES.

There are some important parameters and their Default Values that are explained here.

• POS: To this parameter the default value &pos_id is assigned. This default value
describes the position of the component in the BOM list. If this parameter does not exist
in the BOM it is not possible to display all components in the right order.

Do not change this parameter entry manually!
• QTY: This parameter represents the quantity of the components and describes how often

they are assembled to the mold base. It is important that the Default Value &qty is
assigned. If this parameter does not exist the summarizing of components which occur
multiple times in the mold base does not work.

Do not change this parameter entry manually!

NOTE:
In case no &qty and no &pos_id parameter exists, the BOM can not work correctly. The
parameter names can be different!
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• MATERIAL: EMX does not only provide the material as a STRING-Parameter, it will also
set a Creo Material to every model that is assembled by EMX. It is important that the
Default Value &material is assigned.

NOTE:
Make sure the required material files are located in the MATERIAL_PATH (in the EMX
Options) with the correct MATFILE_EXTENSION.

For any other parameter customization take the default parameter settings as a reference.
There are several other default value that can be assigned to parameters.

NOTE:
When you need to show the describing BOM_NAME in more than one languages (i.e. you
share design on several countries) EMX allow usage of up to 5 additional BOM_NAMES
from other languages. Set the EMX Option ADD_LOCALIZED_BOM_NAME1 to a different
language, i.e. german. When closing the EMX Option dialog box, EMX will read the
partname-entries from the <install_emx>/text/german folder and adds a new
column in partnames with German entries. Now additional Parameters with the rule
&bomname_loc1, &bomname_loc2 etc. can be added in Parameter configuration.

Following default values for EMX Parameters are available.

• &partname: Use this parameter default value to assign the name of the Creo part or
assembly to the parameter.

• &partid: This default value assigns an unique ID string to the parameter. This ID string
can be customized individually. For each component template a rule for the part id is

defined in the Part Names tab of the EMX Options .
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In the default configuration the part name ID has 7 digits. Beginning with a 2 digits
number that represents the EMX component type (e.g. 07 stands for cooling components).
The last 4 digits are a simple integer variable which increments with any newly assembled
component of this type.

If the EMX Option SORT_BOM_WITH_PARTID is set to YES. EMX will use this part ID
string to sort the BOM. This can be very handy because all components are then listed by
type. Plates with 01, Screws with 02, Guides with 03, Ejector Pins with 04, Equipment
with 05, Support Pillars with 06, Cooling Components with 07, Slider with 11 etc.

• &bomname: This default value assigns a descriptions which can also be customized in

the Part Names tab of the EMX Options to the parameter.
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• &supplier: Important default value, which assigns the supplier of a component to the
parameter

• &ord_number: Important default value, which assigns the order number of a component
to the parameter

• &size: EMX comes with an algorithm to calculate the outline of each part in the mold

base. Click to start this calculation. EMX writes all outline values to the size
parameter.

• &remark: EMX uses this default value to write notes into the BOM. For ejector pins and
baffle cooling components the trimmed length is written to this parameter. In this example
the ordered length of the ejector pin is 200 mm. The trimmed length is 177 mm.

• &modeled_by: The designer defined in the Project dialog box is written to this
parameter.

• &date: The date defined in the Project dialog box is written to this parameter.
• &projectname: The project name defined in the Project dialog box is written to this

parameter.
• &prefix:The project prefix defined in the Project dialog box is written to this parameter.
• &postfix: The project post fix defined in the Project dialog box is written to this

parameter.
• &side: The side fixed or moving half which the component is assigned to is written to this

parameter.
• &sim_group: the simulation group for the opening simulation is assigned to this

parameter.
• &ptc_common_name: The PTC_COMMON_NAME value is assigned to this parameter.
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25.3.3 Summarize Equal Components in BOM
Define the criteria to sum up the components in the BOM.

1. Open the EMX Options and switch to the tab Parameter.

In the Parameter tab the row Use to summarize can be found.

By default EMX uses the parameters PARTNAME with a default value of &partname and
the parameter ORD_NUMBER with an assigned default value &ord_number to
summarize the components.

This means: If a component has the same value in PARTNAME and in ORD_NUMBER
EMX will summarize them in just one line of the BOM.

NOTE:
In the BOM the Use to summarize flag is displayed with a in front of the parameter
name
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25.3.4 Edit Parameters individually

1. Double-Click in the row of a summarized component. This will expand all single
entries.

Parameters can be edited manually by Double-Click the certain entry in the BOM.
2. Edit the Parameter ORD_NUMBER of one of the components manually.

3. Click Refresh .Remember that the parameter ORD_NUMBER was used to
summarize the components.

Even if the PARTNAME parameter has still the same value, the ORD_NUMBER value is
now different. As a result EMX will not summarize the component any more in the BOM.

NOTE:
A manually edited parameter is displayed with the *.

It is possible to edit all entries of the summarized components at once. Simply Double-
Click the desired entry of the component row while it is collapsed.

25.3.5 Do not Show Parameters in BOM
1. Open the EMX Options and switch to the tab Parameter.

The flag Show in table can be set for each parameter individually. If the flag is set to NO
the parameter will not be displayed in the BOM.

25.3.6 Working with the BOM
After finishing the mold base the BOM can be edited by the designer via a variety of tools.
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It is possible to select multiple components with Ctrl or Shift

1. Select a couple of rows using the Shift key.
2. Use the RMB menu and Copy-And-Paste functionality to move them to another position

in the BOM.

NOTE:
Use Ctrl +X and Ctr +Vas shortcuts to Cut and Paste rows in the BOM.

3. You can also move the selected components up or down step-by-step with and
.

4. Toggle the VISIBLE flag for multiple components at the same time by using the RMB
menu and the Show/Hide items feature.

5. Find the Find feature it is easy to find entries in the table.. All found entries are
highlighted in red color.
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25.3.7 Create a Quick Selection pull down menu with sel_list.txt
1. To define a list of values (like for ARTICLE or LIST_EXAMPLE), edit the file

/configuration/sel_list.txt as follows:

2. Identify the Parameter with a "#"-symbol. All following lines are the values that will be
displayed.

25.3.8 Recalculate Component Size
The Size of a component can be assigned to a parameter with the default value &size. By
Default EMX adds the parameter SIZE to all components.

The size is computed by an algorithm which uses the outline of the model.

With this calculation process can be started again.
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NOTE:
If the EMX Option RECALC_SIZE_WHEN_OPEN_BOM is set to YES the size of all
components will be calculated automatically when the BOM dialog box opens. Be aware that
this can take same time. All models that have a parameter included specified with EXCL_
SIZE_CALC_PARAM will not be calculated. Use this for standard parts to speed up the
functionality.

When the option RECALC_SIZE_WHEN_OPEN_BOM is set to YES, the Recalculate Size
button is not visible.

25.3.9 Export neutral 3D model files from BOM
With EMX you can export neutral 3D file formats as STEP and IGES from the BOM dialog.

1. Select a component in the list and specify the file format .

2. Export the file with .The neutral 3D file will be written to the working directory.

25.3.10 Export neutral 2D drawing files from BOM
Drawings can also be export in the neutral file format PDF and DXF.

This can only be done in case a drawing exists.

NOTE:
Set the EMX Option SAVE_DRAWINGS to YES to automatically save drawings of plates and
components defined in the Component Dialog.

Additionally the export can only work properly if the EMX Option CHECK_DWG_WHEN_
OPEN_BOM is set to YES.

By default this is set to NO as checking for drawings can take very long for large assemblies.

1. Set this option to YES.
2. Return to the BOM dialog.In case a drawing for the component was found in the working

directory a symbol will be displayed in the MODEL column.

3. Select one of these components and specify the desired file format.
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4. Export the file with .The PDF file will be written to the working directory.

25.3.11 Export BOM to a text file
The content of the BOM can be exported to a specified text file.

1. Click to export the text file to the working directory
NOTE:
With the EMX Option BOM_FILENAME the desired name of this file can be set.

There is also an opportunity to use a VBA macro to format the content before exporting it
to Excel. For further details read chapter Write BOM to Excel via Macro on page 314.

25.3.12 Export BOM to a xml file
The content of the BOM can be exported to a specified xml file.

1. Click to export the text file to the working directory
NOTE:
With the EMX Option BOM_FILENAME the desired name of this file can be set.

25.3.13 Copy/Paste content to Excel
The BOM content can be copied and pasted to Excel.

1. Click to export the content to the Clipboard.

2. Paste the content to an Excel worksheet.

25.3.14 Exclude all assemblies from the BOM
Usually the assemblies of a Creo Moldbase do not appear in the BOM. They are used for
structural reasons only. Right now models like ASM_PALM_1.ASM or TUTOR_STOP_ASM2
are still visible in the BOM. Instead of changing their visibility status manually, you can set
the EMX Option EMX_HIDE_ASSEMBLIES_IN_BOM to YES.
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25.3.15 Include IDs as prefix in component names
If the EMX Option PART_RENAME_FORMAT is set to a wildcard including <pos_id> and/or
<partid>, two extra functions will appear in the BOM dialog box.

With the selected models will be renamed to the new name defined by this
wildcard.

With this renaming is set back.

25.4 About the Bill of Materials Dialog Box in Drawing Mode
From the Bill of Material dialog box, you can place BOM balloons in the current drawing.

Use the following commands from the shortcut menu to add and delete balloons:

• Right–click an item and select Add Balloon Note. The Bill of Materials dialog box is
minimized, and item is selected in the drawing sheet. Click one time, define the
attachment position, and click a second time to define the balloon position.

• Click Remove Balloon Note to remove all balloons from the selected item.
NOTE:
• You can place multiple balloons for each BOM item.
• You can select multiple items. The balloons are placed in a loop

25.5 To Work with Drawing Support Features

25.5.1 Add a format to all plate drawing templates
Beside the BOM the drawing is still one of the most important sources of information for
mold manufacturing. EMX offers drawing templates for almost all template models. They are
located in the installation directory of EMX.

Beside the assembly drawing that is created when create/modify an EMX project, additional
drawings might be required for individual components such as plates, ejector pins, etc. EMX
provides drawing-templates for most EMX components. They are located in the <install_
emx>/components/mm/<comptype> folder.

In the Plate dialog box, the check button to copy the drawing is activated by default. All
drawings that have the plate-template name included are listed in the drawing pull-down.
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The available plate types (with ES for moving half and IS for fix half) are:

plate_1 Clamping plate

plate_2 Corepin Retainer Plate

plate_3 Support Plate

plate_4 / plate_4_left Rail (one or two models)

plate_5 Cavity Plate

plate_6 Ejector Retainer Plate

plate_7 Ejector Base Plate

plate_8 Stripper Plate

1. Add your drawing formats to this templates BEFORE starting your design. Use the
function Administrator Tools ▶ Add Drawing Formats to support this task.

If you want to use EMX drawings it is recommended to set the EMX Option SAVE_
DRAWINGS to YES. It is not possible to create a plate drawing automatically if you forgot
it during the initial plate definition.

For other EMX components, you can decide wether the check button Copy Drawing in
the Component dialog box is set or not in the EMX Option EMX_CHECK_DWG_TYPES.
Simply list the component types for which the checkbutton should be active, the default is
ejector|slider|lifter|latchlock.

2. Use the option SET_EMX_DTL to decide wether the dtl-settings from file <install_
emx>/configuration/symbols_dtl/<unit>/emx.dtl should be applied to a
drawing or not.
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25.5.2 Quick Access to drawings when working in assembly mode

1. Select EMX Assembly ▶ Documentation ▶ Open Drawing of selected model to
open the drawing from the current working directory or from session directly.

2. Select a component with LMB. If a drawing with the same name exist, it will be opened.

25.5.3 Balloon placement with EMX
1. Open the assemblyTUTORIAL.ASM.

Use EMX Assembly ▶ Documentation ▶ Open Drawing of current model to
open the drawing from session directly.
NOTE:

In case no drawing exists use EMX Assembly ▶ Project ▶Modify . The Project
Dialog box appears. Select the check button Copy Drawings and close the dialog with
OK. EMX will create a drawing.

2. Select Bill of Materials to open the EMX Bill of Materials dialog box.

A symbol in the table indicates wether the balloon for a component exist or not .

3. Click RMB on this symbol in the line of TUTOR_INT_PLATE_MH001 and Select Add
BOM Number.

The model is highlighted in all views of the current sheet and the Bill of Materials is
hidden.
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4. Click with LMB the position of the arrow end (LMB 1)and click again for the balloon
position (LMB 2).

5. Click RMB again on the symbol again in the BOM table and remove the balloon again
with Remove BOM Number .
NOTE:
By default the Parameter &pos_id is displayed in the balloon. If the EMX Option USE_
PARTID_IN_BALLOON is set to YES, the parameter with rule &part_no is displayed in
the balloon.

If SORT_BOM_WITH_PARTID is set to YES, EMX will sort the BOM always by the
content of the parameter with rule &part_no.

Additional relevant EMX Options are BALLOON_ARROW_END_TYPE and BALLOON_
SIZE. PLACE_BALLOON_ON_FACE is by default set to YES.
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25.5.4 Balloon placement with Creo
Creo offers a flexible way to place balloons. Based on the BOM-Table with repeat region on
sheet 3 of the EMX assembly drawing the balloons can be placed with Table ▶ Ballons ▶
Balloon Note.

It is possible to define the content in the balloon rather flexible. The easiest way is to use the
Component Parameter BUW_ORD_POS in the balloon note.

Background Information

The symbols and their diameter-table are located in <install_emx>/configuration/
symbols_dtl/<unit> . In ejpin_symbols.cfg the nominal diameter for ejector
pins and their related symbol is listed. With option SUPPRESS_EJP_NOTE set to YES the
display of the extra note can be avoided.

25.6 About Opening Drawings
You can use one of the following commands to quickly open drawing files.

• Click EMX Assembly ▶ Documentation ▶ Open drawing of current model to
open a drawing with the same name as the current model.

• Click EMX Part Mode ▶ EMX Tools ▶ Open drawing of current model to open a
drawing with the same name as the current model.

• Click EMX Assembly ▶ Documentation ▶ Open drawing of selected model and
select a component in the current assembly.

• Click EMX Part Mode ▶ EMX Tools ▶ Open drawing of selected model and
select a component in the current assembly.

NOTE:
If there is no drawing, nothing happens.

25.7 To Write BOM to Excel via Macro
In most cases a formatted EXCEL-file for the BOM is needed. This chapter explains how to
set up a special Macro for EXCEL. The EMX BOM content can be imported automatically to
an EXCEL-template.
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25.7.1 Use the template emx_bom.xls
The setting of the option BOM_FILENAME drives the output format of the button Copy

content to windows clipboard .

1. Set the EMX Option BOM_FILENAME to C:\TMP\buw_excel.txt

It is important to use an absolute file path in this case. With this setting, the Export to
EXCEL-command will create two files in C:\TMP.

2. Make sure the folder C:\TMP exists.

3. Export the BOM with .

buw_project_excel.txt has five lines with the first five Project Parameters
defined in EMX Options.

buw_excel.txt is a listing of all components in the BOM with their parameters
&pos_id, &partid, &qty, &bomname, &supplier, &ord_number, &material, &remark,
&special and &dwg_page.
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After exporting these two files EMX will open EXCEL automatically using the template
/configuration/templates/emx_bom.xls. This EXCEL-file has an Import
Macro that will be started automatically when open the file. Due to the fix content of the
two export files, the macro can import and resort the parameters into the correct sheets
(Blatt 1–Blatt3) of the template.

25.7.2 Use the template emx_bom_adv.xls
While the method mentioned above can only handle certain parameters, EMX offers a more
flexible way to define the content of the EXCEL-template.

1. Set the EMX Option BOM_FILENAME to C:\TMP\emx_bom_adv.txt to use this
more flexible template configuration/templates/emx_bom_adv.xls.

2. Open the EXCEL template <emx_install>\configuration\templates\emx_
bom_adv.xls

Before using the xls-file, you need to configure the column names and (optional) the
substructure.

Check if the Source File Name is equal to the previously set EMX Option BOM_
FILENAME, in this case C:\TMP\emx_bom_adv.txt.
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3. In row number 2 (EMX_PARAMETER_NAMES) add the exact parameter names used in
EMX Options.

In row number 3 (CUSTOMER_COLUMN_NAMES) add the according column names
used in the BOM sheet.

In this example six EMX parameters are used: MODEL, POS, QTY, BOM_NAME,
SUPPLIER, MATERIAL

In the BOM sheet of the columns look like this:

In the System sheet of the excel the parameters need to be set up accordingly:

NOTE:
There are two special parameter columns GROUP_COLUMN and POS_COLUMN.

• Without a correct POS_COLUMN the macro does not work. It is important, that the
EMX Parameter with the default value &posid is used here.

• GROUP_COLUMN specifies the column in which the group titles appear.
4. It is possible to add extra comment lines in the BOM.

Add the desired group titles in row 9 (GROUP_TITLE). It is possible to set up as much
comments as you want. In the row underneath (STARTING_POS_NR) a position id needs
to be defined which describes the starting position

Set up four titles as shown below and make sure GROUP_MODELS option is set to YES
in row 6.

5. Save the emx_bom_adv.xls and close EXCEL.

6. Go back to Creo and export the BOM with .
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In case macros in Excel are deactivated active content.

7. Run the Import of EMX Parameters with Developer Tools ▶ Macro ▶
ImportFrom ProE

A new EXCEL file will be created named emx_bom_adv_output.xls and written to
the current working directory.
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If you want the Import Macro run automatically when open the file, uncomment this line
ImportFromProE in the Visual Basic Macro
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25.8 About Applying and Modifying Ejector Pin Symbols
1. Open a drawing that contains models with ejector pin cutouts.

2. Click EMX Drawing Mode ▶ Add drawing symbols.
3. Select a view of the model. All the ejector pin cutouts in the model are identified, and

diameter-dependent symbols are added or updated.
NOTE:
These symbols can be modified. They are located in <installdir>/configuration/
symbols_dtl/<unit>. The cutout diameter is automatically compared with the epin_
symbols.cfg file setting to determine the correct symbol to use.

25.9 To Add Ejector Pin Symbols to Drawing
EMX can place certain symbols on plate drawings to indicate ejector pin holes. The symbol
size is adapted automatically to the real diameter of the ejector pin bore.

1. Open drawing TUTOR_EJRET_PLATE_MH001.DRW.

2. Select Add drawing symbols from the EMX Drawing Mode tab.
3. Select the TOP_VIEWof the plate.
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EMX add size-specific symbols to each ejector pin cutout and adds a note with the Ejector
ID



Notes:
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About Saving An Assembly Recipe
About Loading an Assembly Recipe
To Load and Save Mold Base Recipes
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26.1 About Saving An Assembly Recipe

1. Click in the Mold Base Definition dialog box to open the Save EMX Assembly
dialog box. The current mold base appears in the preview window.

2. Select a supplier from the Supplier list.
3. Enter a name for the mold base assembly in the box below the Stored Assemblies list.

4. Click to save the current mold base assembly.
5. Click OK to save the assembly and return to the Mold Base Definition dialog box, or

click Cancel to close the operation without saving changes.

26.2 About Loading an Assembly Recipe
Mold base definitions and supplier default mold bases are stored in the assembly database.

1. Click in the Mold Base Definition dialog box. The Load EMX Assembly dialog box
opens.

2. Select a supplier from the Supplier list.
3. Select a mold base from the Stored Assemblies list. The selected mold base appears in

the preview window, and the mold base name appears in the box under the list.
4. Select the Keep size and model data check box to retain the current mold base size and

cavity layout after the new mold base is loaded.

5. Click to remove the active mold base from the list.

6. Click to load the active mold base. A preview appears in the Mold Base Definition
dialog box, but no changes are generated in the assembly.

7. Click OK to apply changes to the assembly and return to the Mold Base Definition dialog
box, or click Cancel to undo all changes and return to the Mold Base Definition dialog
box.

26.3 To Load and Save Mold Base Recipes

26.3.1 Load a Mold Base Recipe
It does not make sense to set up the mold base for each project step by step. This is the reason
why EMX supports "recipes", that predefines sets of plates and components for the mold
base.

1. Create new EMX Project and open the Mold Base Definition dialog.

2. Click Load assembly definition from file .
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The Load EMX Assembly dialog box provides a list of predefined mold bases for each
supplier.

3. Select the file emx9_tutorial_3asm and click Load

A EMX warning message appears.

The current EMX project does not contain the correct number of EMX subassemblies. In
the given recipe emx9_tutorial_3asm three subassemblies are defined. The blank
EMX project has zero subassemblies. Due to that EMX is not able to assemble all defined
components from the recipe to the correct subassemblies.

4. Leave the EMX Warning with OK.
5. Close the Load EMX Assembly dialog box with Cancel.
6. Close the Mold Base Definition dialog box with Close .
7. Add 3 subassemblies to the EMX project withEMX Assembly ▶ Add subassemblies

8. Reopen the Load EMX Assembly dialog box and selected emx9_tutorial_3asm.

Click Load
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9. The entire mold base is previewed in the Mold Base Definition dialog box.

In this case the size and cavity-settings in the stored recipe are identical with the current
mold base size and cavity layout you have defined.

If you are working on a mold base with a different size, activate the button Keep size and
model data. In that case EMX will try to convert all components to the mold base size
you have defined before retrieving the recipe.

10. Click OK to load all plates and models.

The complete mold base is created in the 3D-model. The previously defined side
interlocks and ejector guidance components had been removed as they are not included in
the recipe. The cavity cutout has a radius instead of the mouse ears defined before.

NOTE:
All components are loaded to the correct subassembly.

11. Close the Mold Base Definition dialog box with Close.

12. Open the Component Status , activate all types and click OK.
13. Set the Style VIS0001 in the Creo View Manager.
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This automatically created rule based style is added when starting an EMX project. Its
name is defined in the EMX Option NAME_COMP_DISPLAY.

If you like to modify details of some components, you can also edit them directly in the
graphics window. As an example we modify the properties of the FH locating ring.

14. Select the Locating Ring TUTOR_LOCATING_RING2.PRT in the 3D graphics window
and press RMB.

15. Select Modify Component from the RMB menu. The Locating Ring dialog box is
opened again.

16. Select 125 for diameter DM3.
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17. Check the No Cutout button (the cutout is defined in plate F020 anyhow).

18. Close the dialog box with OK.

The locating ring is set to the new size.
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NOTE:
As you can see, all components defined in the Mold Base Definition dialog box can be
redefined also outside the dialog box in direct editing mode.

Background Information

The Component Status works different if the EMX Option NAME_SUBASM_COMP is set:

Here is an example on how an assembly looks like when NAME_SUBASM_COMP is not "-":

After creating the project and three sub assemblies have been added:
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...and after retrieving the recipe emx_tutorial_3asm - template:

If you toggle the Component Status to hidden for i.e. screws, the models remain in the model
tree
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but the layer 00_SCREW in the layer tree is set to hidden in all assemblies.



Notes:
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27.1 About Modifying the Mold Base Size
If the mold base size needs to be modified while components have already be assembled,
these existing clamping screws, leader pins, bushings etc. will not automatically be updated.

To adjust the components automatically to the new mold base size set configuration Option
UPDATE_MOLDBASE_COMPS to YES.

Additionally existing ejector pins and support pillars will be updated if UPDATE_
ADDITIONAL_COMPS is set to YES.

27.2 To Modify the Mold Base Size

27.3 About Machine Parameters
Use the Machine dialog box to define machine-dependent parameters. Changes made in this
dialog box appear in the Mold Base Definition preview window.

1. Click on the Mold Base Definition dialog box. The Machine dialog box opens.
2. Select a supplier from the list.
3. Set the unit of measure (mm or inch).
4. To show machine features (machine bars, plates and minimum/maximum opening ranges),

select the Show Machine check box.
5. Select a machine from the list. The selected machine appears in the preview window.

Machine dimensions appear in the table. To change a dimension value, double-click a cell
in the Value column.

6. Values for the Machine Bar Pattern and the Knockout Pattern appear in the Quantity,
Pattern Size, and Pattern Diameter boxes.

7. Double-click a cell in the table to change a value. or indicates visibility status.
8. Select the Automatically Recalculate check box to automatically recalculate the machine

bar and knockout patterns after editing. To manually recalculate the pattern, click .
9. Click OK to close the dialog box and to update the assembly, or click Cancel to close the

dialog box, and return to the Mold Base Definition dialog box.
NOTE:
If the Show Machine check box is selected in the Machine dialog box, the Machine layer
is set to VISIBLE in the assembly.
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27.4 About Reseting the Current Assembly

1. Click in the Mold Base definition dialog.
2. When prompted to delete all plates and components, click Yes. All components are

deleted in the 3D assembly.
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28.1 About Creo Expert Moldbase Extension Tools
To streamline design creation, Creo Expert Moldbase Extension provides various tools.

For additional tools click EMX Assembly ▶ EMX Tools and then select a tool described
below:

• Model Size—Determines the exact bounding box of a solid part. The result of this
analysis is saved as a model parameter.

• Measuring Points—Defines the measurement positions of solid parts. This is available
when working with a part in EMX. Click EMX Part Mode ▶ EMX Tools.

• Set Technology Colors—Opens the Predefined Colors dialog box.
• Calculate Clamping Force—Determines the projected area of all reference models and

runner features.
• Set Accuracy—Modifies the accuracy of one or more assembly components.
• Export CSYS Position—Saves the x, y and z positions of a coordinate system that is

identified with a specific feature parameter to a file.

28.2 About Determine the Model Size

1. Click EMX Assembly ▶ EMX Tools ▶ Model Size or click EMX Part Mode ▶
Model Size to measure the model outline in part or assembly mode. The Model Size
dialog box opens.

2. Click , available if the current model is an assembly, to select a model. The name of
the selected model appears in the Selected Model box. If the current model is a part, the
name is automatically set.

3. Click to select a coordinate system. The name of the coordinate system appears in
the Selected CSYS box.

4. Click to run an analysis.

• The bounding box outline and volume appears in the Calculated Size box.
• The string format is A x B x LG.
• The rotational symmetric part outline string is formatted as DM x LG.
• The gray box displays the volume of the bounding box.
• The number of digits is defined by the option NR_DIGITS_COMMON.
• The preview box shows the top and side projections on which the analysis result is

based.
5. Use Convert outline result to to convert the result into INCH or MM.
6. Click OK to save the model outline as a parameter and close the dialog box, or click

Cancel to close the dialog box without saving the results.
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28.3 To Determine the Model Size

1. Select EMX Assembly ▶ EMX Tools ▶Model Size .
2. Select a model from the assembly.

3. Click and select TUTOR_LOCATING_RING2.PRT .By default the models origin
is used to determine the x-, y- and z-axis of the outline determination. You can also click

and select any other coordinate system of the model if you want to define other
defaults.

4. Click and select the ORIGIN_MOLDBASE as reference coordinate system. The
Outline string prints the result.
NOTE:
For rotational symmetric parts the format is "diameter x thickness", otherwise "length x
width x height".
Make sure the coordinate system has the correct orientation.

The entry right beside size shows the volume.
NOTE:
The numbers of digits used for printing the result is defined by the EMX Option NR_
DIGITS_BOM .

5. Close the Model Size dialog box with OK.

28.4 About Setting Accuracy
1. Set the following Creo Parametric configuration options:

• enable_absolute_accuracy to YES.
• accuracy_lower_bound to an appropriate value.

2. Click EMX Assembly ▶ EMX Tools ▶ Set Accuracy to set the accuracy of single
components or an entire assembly. The Set Accuracy dialog box opens.

3. Enter a value in the Accuracy box.
4. Select or clear the Absolute or Relative check boxes.

5. Click to select components. The system attempts to set component accuracy to the
given value and type.

6. Click Close to close the dialog box.
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28.5 To Set Accuracy

28.5.1 Set Accuracy of the whole Mold Base
EMX offers an easy way to set the accuracy for single parts or the whole assembly to the
same value.

1. Open the Set Accuracy dialog boy with EMX Assembly ▶ EMX Tools ▶ Set Accuracy.
2. Set you desired value, either absolute or relative.

3. Click and select the mold base TUTORIAL.ASM in the model tree. EMX will set
the accuracy for all components of the assembly.

Background information

The default for Accuracy Type and Accuracy Value can be predefined with the EMX Options
ACCURACY_TYPE and ACCURACY_VALUE.

28.6 About Exporting CSYS Positions
1. Click EMX Assembly ▶ EMX Tools ▶ Export CSYS Position to save parameter-specific

coordinate system positions and orientations to a file. The Export CSYS Position dialog
box opens.

2. Enter a string parameter in the Parameter box.
3. Enter a file name in the File Name box.

4. Click to search all coordinate systems that include a STRING parameter with the
given name. The orientation and the x, y and z positions are saved in the file specified by
File Name.

5. Click Close to close the dialog box.

28.7 About Exporting Measurement Points
1. Click EMX Part Mode ▶ EMX Tools ▶ Measuring Points to place measuring points on

Creo Parametric solid parts. The Measuring Points dialog box opens.

2. Click to select the Reference CSYS in the 3D model.
3. The Measuring point list table shows existing measuring points. Each line is represented

by one point. Select the symbol in the ID column to create a 3D note. The X, Y, and Z
columns show the measuring-point position on the solid part. The (X), (Y), and (Z)
columns show the offset position of 0.5 * probe diameter normal to the solid face.

4. Enter the Probe Diameter. This represents the OMM machine ball diameter and will be
used to calculate the offset between the original points on the solid and the required
measurement position.
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5. Enter the Grid Width. This value is used to calculate a grid of x and y positions when a

new set of points is created on a solid part with .

6. Click to remove the selected entry from the point list.

7. Click to select a position on the model. The position and the related offset point are
added as new line to the point list.

8. Click to save the point list to the file QMM_FILENAME.
9. Click OK to create or update a point in the assembly that represents the position of all

measurement points.
10. Click Cancel to close the dialog box without saving.

28.8 About Setting the Technology Colors

1. Click EMX Assembly ▶ Administrator Tools ▶ Set Technology Colors. The
Predefined Colors dialog box opens.

2. Click the required item in the table.

3. Click to select one or more surfaces. Selection of several surfaces by defining a
rectangular box is supported. The selected color is applied to the selected surfaces.

4. Click Close to close the dialog box.

28.9 To Set Up Technology Colors

28.9.1 Define the colors in EMX Options
1. Open EMX Options ▶ Technology.

This lists shows two types of features:

Plate features are the suppressed features in the plate templates. Their name is written in
capital letters in the Feature Name column. One example is the LOCATING-feature in
the clamping plate templates. The value define in the Value column will be written to an
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additional feature parameter. Its name is defined in EMX Option TECH_PARAM. It will be
written to the feature when ADD_TECH_PARAM is YES.

2. Double click in the Hole Color column.

If the EMX Option ADVANCED_TECH_COLOR is set to YES, a certain list of predefine
colors is displayed.

If the option is set to NO, the regular Windows color selection dialog box is shown.
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3. Select the desired color and click Close.
4. Repeat this steps in the columns Face Color and 2nd Hole Color.

This color setting is used when EMX Option ADD_TECH_COLOR is set to YES. If you
edit a plate now that has the feature LOCATING included, its faces are colored
automatically with this color when closing the Plate dialog box.

Beside these plate features, all UDFs that create cutouts on the fly can be configured the
same way. So ejector pin cutouts, screw holes etc. can be automatically colored in the
predefined colors. EMX enables only three colors per cutout, the first cylindrical cut, the
first plane face and the second cylindrical cut (i.e. for a counterbore).
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For each UDF in the components-folders an extra coloring can be defined.

1. Open EMX Options again and modify the colors for dowel-pin cutouts like this.

If you display the Features in the modeltree its very easy to find the according UDF-
names used by EMX. Here its the PIN_STRAIGHT_HOLE-feature. When adding new
cutouts now, they will appear in yellow.

28.9.2 Using more flexible coloring with SmartHolechart.
Due to the limitation of EMX Technology color setting, users that need even more flexibility
should use the coloring function from SmartHolechart. For each individual base feature of a
complex bore an individual color can be set in the Hole types/UDF tab of the Configuration
Dialog. See the SmartHolechart documentation for more details.
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28.10 About Calculating The Clamping Force
Use this Calculate Clamping Force to assess the compatibility of a mold base with a specific
injection machine.

1. Click EMX Assembly ▶ EMX Tools ▶ Calculate Clamping Force. The Clamping Force
dialog box opens. The machine defined in the Mold Base Definition dialog box is
displayed with values for possible injection pressure and clamping force.

2. Enter a value for the injection pressure (less than the possible value). The top view of the
mold base is displayed in the drawing area.

3. The color of the reference models and runner features changes to gray. The Projected
Area and the Clamping Force are automatically calculated.

4. Click and select additional features in the graphics window. All selected features
appear in the Additional Runner Features list.

5. Click to remove a selected line from the list.
6. Click OK to close the dialog box.
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28.11 To Calculate the Clamping Force

28.11.1 Calculate Clamping Force for Insert Parts only
EMX offers the possibility to calculate the necessary clamping force depending on the
projection of the reference model.

1. Select EMX Assembly ▶ EMX Tools ▶ Calculate clamping force
2. Insert the Injection Pressure value. If a machine was defined in Mold Base Definition,

the Machine Clamping Force can be found in the top-right corner.

3. Start a Calculation with .

EMX displays the projection in the Drawing Area.

As a result you will get the Projected Area and the Req. Clamping Force.

28.11.2 Assemble a Runner
It is possible to add runners to the projection. Before you can assemble the runner make sure
you have the correct sprue bushing assembled.

The Sprue Bushing should reach down to the separation plane of the mold base.
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Runner can be found in the Component Library. You can define as many different runners as
you want. Look for this in chapter To Add a Part to the Library on page 388

1. Select EMX Components ▶ Library ▶ Assemble .
2. Select the directory runner from the directory tree.
3. Select part runner2 with Double-Click.
4. Set the OFF_PLUS_Y value to 25.
5. Set the OFF_MINUS_Y value to 25.
6. As assembly reference for runners (1) CSYS the coordinate system ORIGIN_MOLDBASE

is predefined.

7. Leave the Library dialog box with OK.

The runner is assembled to the TUTORIAL.ASM and cut outs are added to the moving
half insert parts MH_PALM_1.PRT and MH_PALM_2.PRT.

28.11.3 Calculate Clamping Force for Insert Parts and Runners
1. Click EMX Assembly ▶ EMX Tools ▶ Calculate clamping force .

2. Click to add a runner to the projection.
3. Select the quilt of the previously created runner in the graphic window.
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The result can be seen in the Calculate Clamping Force dialog box. The runner is
displayed in the Drawing Area as well.

28.11.4 Calculate the MOULDING plastic part
While opening this Clamping Force dialog box, a second action can be run by EMX that is
related to the Projected Area calculation.

1. Set the EMX Option ENABLE_MOULDING_REPAIR to YES.

When creating a MOUDLING model with Creo Pro/TOOLDESIGN, all ejector pin
cutouts added by EMX will generate a wrong geometric result in this model. The ejector
pin cuts are added to the moulding volume. This cause troubles when calculate the
required amount of plastic.

2. Click EMX General ▶ EMX Tools ▶ Calculate clamping force again.
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Now you are prompted to select the MOULDING model that was designed previously.
EMX will find all ejector pin cutouts and remove them from the MOULDING.

28.12 To Apply a Set of Measurement Points for 3D Measurement

28.12.1 Create Reference CSYS
EMX supports the usage of 3D measurement for Quality Assurance. To define the required
position for the probe ball of the measurement machine you need to know its center position
normal to the face where the "real" point to be measured is located. EMX can calculate this
position for you.

1. Open the mold base TUTORIAL.ASM.
2. Open the model MH_PALM_1.PRT.
3. Create a coordinate system as shown below.

This coordinate system will be used as reference for the set of measurement points. The
direction of the z-axis is important if you like to add a full set of points in one step.

4. Make sure Show 3D Notes is enabled.

28.12.2 Add Single Measurement Points
1. Select EMX Part Mode ▶ EMX Tools ▶ Measurement Points .

The Measuring Points dialog opens.

2. Select to identify the reference coordinate system.
3. Select the previously created CS0.

4. Click and pick the points to be measured on the models top face.With each pick a
note is displayed with the real x,y,z position regarding CS0 and the required probe ball
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position. The position is also listed in the Point list of the Measurement Points dialog
box.

NOTE:
Make sure the Probe diameter is set to the correct value as this is used to calculate the
offset points.

5. Cancel the input loop with MMB.If you select a line from the points list its related note
gets highlighted in the graphics window.

6. Close the Measurement Points dialog box with OK.A point feature is added to the
current model MH_PALM_1. Each entry of the Measurement points list is represented
by an extra point.

28.12.3 Export List of Points
1. Select EMX Part Mode ▶ EMX Tools ▶ Measurement Points .
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EMX will read the stored positions of all points again and displays them in the
Measurement points list.

2. Select any line to highlight the according point in 3D.

3. Click .The content of the list is written to file specified in EMX Option QMM_
FILENAME.

By default the file will be stored in the working directory.

28.12.4 Create a Grid of Measurement Points
1. Delete the previously created point feature and the annotations.
2. Select EMX Part Mode ▶ EMX Tools ▶ Measurement Points again.
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3. Set the Grid Width of the point pattern to 10.

4. Start the creation process of the points pattern with A set of Measurement Points
with a constant distance of 10 mm is added to the MH_PALM_1.PRT.

28.13 To Export EDM Positions

28.13.1 Set the search options
EMX offers a function to print an easy form of burnsheet where position and orientation of
electrodes can be found.

1. Select EMX Tools ▶ Export CSYS Position.
2. Set EMX Options EMX_CSYS_PARAMETER toEDM_TEST .
3. Set EMX Options EDM_CSYS_RESULT_FILE toedm_position.txt .

The result with all coordinate system positions will be stored in this file.

28.13.2 Run the Export
1. To demonstrate the functionality, open the assembly TUTOR_INSERT.ASM.
2. Add an INTEGER-parameter EDM_TEST to the CS0–coordinate systems in the models

ASM_PALM_REF and SLIDER_PALM. A very convenient way to add a parameter to a lot
of features is this:

3. Show it as an extra column in the model tree. Then click in this column, and you can
easily set up the desired Parameter. EMX will only check if a parameter with the name
EDM_TEST exists.
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4. Start the function with EMX Tools ▶ Export CSYS Position. The predefined Options are

set as default but can be overwritten.
5. Click the Run-button.EMX search through the entire assembly for coordinate systems

marked with the parameter EDM_TEST. Once this is done, this dialog shows up

The resulting file in the current working directory looks like this

28.14 About he Machine Representation
The EMX machine data is hosted in <install_emx90>/components/<unit>/
machines subdirectories.

1. Open the Mold Base Definition dialog box.

2. In Mold Base Definition dialog box click .

The Machine dialog box is opened.

If no file <install_emx50>/components/<unit>/machines/supplier.
txt exist, all sub-directories will be listed in the supplier list of the Machine dialog box.

All data hosted in the machine_data.txt file is provided in the GUI.
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The MACHINE_NAME can be selected from the machine list. EMX will display any gif-
image that has the name of the machine in the Machine dialog box (i.e. 270_c_400-90.
gif).

All further columns are listed in the dimension list so you can select a machine by any of
its dimensions.
NOTE:
The columns HOLM_xxx and KNOCKOUT_xxx columns have a special meaning as they
are used to calculate the machine bar pattern and the knockout pattern.

3. Select Machine Supplier Arburg Type 470_C_1500.
4. Click Show machine in top right corner. The preview of the chosen machine is shown in

Mold Base Definition dialog box:

a. In the side view the minimum and maximum machine opening is displayed using three
plates.
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b. In the top view the machine bar pattern and the knockout pattern are displayed.
5. Close the Machine dialog box with OK.The layer with the model TUTOR_MACHINE.

PRT is displayed in TUTORIAL.ASM so you can check if the machine is big enough to
host your mold base.
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About Configuration Options

29.1 About the EMX Options Dialog Box

Click EMX Assembly ▶ Options to open the EMX Options dialog box. Use the tabs to
set Creo Expert Moldbase Extension parameters and defaults. Any changes made to
parameters using this dialog box are immediately applied. The following tabs are available:

• Options—Edit common Creo Expert Moldbase Extension settings.
• Parameter—Edit common BOM parameter definitions.
• Project Parameter—Edit project-specific BOM parameter definitions.
• Part Names—Edit predefined model and BOM names, ordering numbers and other

settings.
• Technology—Edit Creo Expert Moldbase Extension cutout type colors and parameters.
• Cooling Bore Data—Edit cooling bore dimension defaults.
• Ejector Bore Data—Edit ejector pin bore dimension defaults.
• Screw Hole Data—Edit screw bore dimension defaults.

All configuration files are located in <installdir>/configuration directory. If the
EMX_USER_CONFIG_PATH environment variable exists, the system automatically looks for
it in the path defined by EMX_USER_CONFIG_PATH/configuration instead.

29.2 To Set Creo Expert Moldbase Extension Configuration Options
1. Click the Options tab in the EMX Options dialog box to access

Creo Expert Moldbase Extension configuration options. When you select an option from
the list, its name and value are copied to the Option and Value boxes.

2. Select or type a value for the option.

29.3 Common Configuration Options

ADD_COOLING_REF_IN_PART
NO: Assemble Refgroups for cooling components in the chosen subassembly.

YES: Assemble Refgroups for cooling components in the part that is owner of the placement
surface.

Default: NO.

ARCHIV_PATH
Path to the archive used to create component instances. Default: <installpath>/
archive.
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COMPANY_ID
Special company identifier used to activate certain hidden options. Default: -.

CUT_PLATES_ONLY
NO: All components that interfere with a new component will be cut using the CUTQUILT.

YES: Only EMX plates that interfere with a new component will be cut using the
CUTQUILT.

Default: NO.

DEFAULT_EMXNAME
Default value for the EMX Projectname. Default: 123.

DEFAULT_PREFIX
Default value for the project prefix. Default: 123.

DEFAULT_POSTFIX
Default value for the project postfix. Press ENTER to hide the input panel for the postfix.
Default: 456.

DEFAULT_WATERLINE_DIA
The default D5-diameter for all cooling bores. Set it to 0 (zero) to ignore this option.

Default: 8.

DELETE_FILES_AFTER_DELETE
NO: The part files are left on the disc after parts have been deleted in Creo Parametric.

YES: When deleting a part the respective part-files will be erased from the hard-disc.

Default: NO.

DELETE_FILES_AFTER_DISASSEMBLE
NO: The part files are left on the disc after parts have been disassembled in Creo.

YES: During part-disassembly also the files are erased from the hard-disc.

Default: NO.

ENABLE_MULTI_EJP
Sets the default value for the check box, Individual ejector models on each point in the
Ejector Pin dialog box.

NO: No Action.
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YES: When defining ejectors on a multiple point feature with different height, place
individual ejectors on all points.

Default: NO.

ENABLE_SUBASM_PREFIX
NO: Subassemblies must have same Project Prefix like the main assembly.

YES: Allow the user to define individual prefixes for subassemblies.

Default: NO.

LIBRARY_PATH
Root path to the EMX library. Default: <installpath>/components.

LIBRARY_THUMB_SIZE
Size in pixels of the thumbnail pictures in the Library Component dialog box.

Default: 100.

MATERIAL_PATH
Root path to the directory where Creo Parametric Material files are located.

Default: -.

PDM_SYSTEM
0: No PDM system.

1: Retrieve standard parts from the SEARCH_PATH variable.

2: Retrieve standard parts from Windchill.

Default: 0.

PRE_HIGHLIGHT_BEFORE_DELETE
NO: Do not highlight dependent components before delete-prompt - faster than using YES.

YES: Highlight all features and components that are dependent before delete prompt. Can be
slow.

Default: YES.

PROMPT_FOR_CUTTING_PARTS
NO: All components that interfere with a new component will be cut using the CUTQUILT.

YES: Creo Expert Moldbase Extension displays a dialog box for the user to select which
components should be cut.

Default: NO.
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SAVE_LOCAL_PARAM_IN_ASM
NO: All project parameters are stored in the file project_parameter.cfgin the local
working directory (4.1 behavior).

YES: Project parameters are stored in the Creo Expert Moldbase Extension main assembly. It
is better to use this for PDM-systems.

Default: NO.

SAVE_SIZE_OF_PART_IN_EMPTY_ORDNUMBER
NO: No Action.

YES: The calculated outline of parts is written into order number in case the order number
string is empty.

Default: NO.

WINDCHILL_AUTONUMBER
NO: Parts and assemblies are renamed with partnames.cfg rules

YES: Parts and assemblies are renamed with auto number from Windchill in case Windchill is
active.

Default: NO.

29.4 Assembly Options

ALLOW_SIZE_EDIT
NO: No Action.

YES: In the Mold Base Definition dialog box, edit the size manually. You can set up the mold
base without restriction.

NOTE:
All pattern values must be defined manually

Default: NO.

ASSEMBLY_UNIT
0: Sets mm (millimeters) as default unit in the Project dialog box.

1: Sets inch (inches) as default unit in the Project dialog box.

Default: 0.

BALLOON_ARROW_END_TYPE
Set to AUTOMATIC, ARROWHEAD, DOT, FILLED_DOT ,DOUBLE_ARROW, SLASH,
INTEGRAL, BOX, FILLED_BOX, NONE, TARGET, HALF_ARROW, TRIANGLE
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Default: FILLED_DOT

BALLOON_SIZE
Absolute size of BOM-balloon

Default: 1

CREATE_ASM_DRAWING
NO: Do not create an assembly drawing.

YES: Create an assembly drawing.

Default: YES.

CREATE_ASM_REPORT
NO: Do not create an assembly report.

YES: Create an assembly report.

Default: YES.

CREATE_GROUP_LAYER
NO: No action.

YES: Create a group layer and place each part-layers on it if the group layer is not preceded
by a hyphen (-) in configuration/partnames.cfg.

Default: NO

CREATE_LAYER_PER_PART
NO: No action.

YES: Create a layer for each part if the layer name is not preceded by a hyphen (-) in
configuration/partnames.cfg.

Default: NO

DELAY_MOLDBASE_REGEN
NO: Creo Expert Moldbase Extension will immediately regenerate the mold base after any
modification in the mold base definition.

YES: User must regenerate the EMX assembly manually in the mold base definition.

Default: NO.

EJP_DESIGNER_DEFAULT_COMPONENT
Instance name for the component to use as the default in the Ejector Pin Designer.

Default: mm|meusburger|E1725_2_8_0_5_80.
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EMX_HIDE_ASSEMBLIES_IN_BOM
NO: Does not automatically hide assemblies in the BOM.

YES: Always hides assemblies in the BOM.

Default: NO.

KEEP_SIZE_DEF_SETTING
NO: Clear the Keep size and model data check box in the Load EMX Assembly dialog box.

YES: Select the Keep size and model data check box in the Load EMX Assembly dialog
box.

Default: NO

MATFILE_EXTENSION
mat: Use *.mat files from MATERIAL_PATH.

mtl: Use *.mtl files from MATERIAL_PATH.

— : Do not consider content of MATERIAL_PATH.

Default: mat

NAME_COMP_DISPLAY
Name of a style where all plates are set to wireframe. Insert '-' if EMX should not create this
style.

Default: VIS0001.

NAME_FIX_HALF
Names the side layer and simplified representation of the fixed half.

Default: 01_FIX_HALF.

NAME_MOVING_HALF
Names the side layer and simplified representation of the moving half.

Default: 01_MOVING_HALF.

NAME_SUBASM_COMP
Name of the automated created subassembly for all components. Use '-' if you do not want to
create this subassembly.

Default: -.

NAME_SUBASM_COOL
Name of the automated created subassembly for waterline components in the assembly
NAME_SUBASM_COMP. Use '-' if you do not want to create this subassembly.
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Default: -.

NAME_SUBASM_DOWEL
Name of the automated created subassembly for dowel pins in the assembly NAME_
SUBASM_COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_EJECTOR
Name of the automated created subassembly for ejector pins in the assembly NAME_
SUBASM_COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_EQUIPMENT
Name of the automated created subassembly for equipment in the assembly NAME_SUBASM_
COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_GUIDE
Name of the automated created subassembly for guide components in the assembly NAME_
SUBASM_COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_LIB
Name of the automated created subassembly for library_components in the assembly
NAME_SUBASM_COMP. Use ‘-’ if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_SCREW
Name of the automated created subassembly for screws in the assembly NAME_SUBASM_
COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_STOP
Name of the automated created subassembly for stop disc and stop pins in the assembly
NAME_SUBASM_COMP. Use '-' if you do not want to create this subassembly.

Default: -.
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NAME_SUBASM_SUPPORT
Name of the automated created subassembly for support pillars in the assembly NAME_
SUBASM_COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_SLIDER
Name of the automated created subassembly for sliders in the assembly NAME_SUBASM_
COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_LIFTER
Name of the automated created subassembly for lifters in the assembly NAME_SUBASM_
COMP. Use '-' if you do not want to create this subassembly.

Default: -.

NAME_SUBASM_LATCHLOCK
Name of the automated created subassembly latchlocks in the assembly NAME_SUBASM_
COMP. Use '-' if you do not want to create this subassembly.

Default: -.

CONFIG_ASM_LABEL_PARAM
Name of a parameter which can be defined at the EMX subassemblies. In the parameter exist,
its value appears in the EMX subassembly lists instead of the subassembly name.

Default: - (hyphen).

PREVIEW_VIS_MODE
disabled: Do not modify display and style in preview mode for components.

shade: Set display to shade when preview a component.

wireframe: Set display to wireframe when preview a component.

hiddenvis: Set display to hiddenvis when preview a component.

hiddeninvis: Set display to hiddeninvis when preview a component.

shadewithedges: Set display to shadewithedges when preview a component.

shadewithreflect: Set display to shadewithreflect when preview a component.

Default: hiddenvis

UPDATE_ADDITIONAL_COMPS
NO: No action.
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YES: If a plate is modified, added or removed, ejector pins and support pillars in the 3D mold
base are updated.

Default: NO.

UPDATE_CUTS_IN_REDEFINE
NO: When redefine a library component EMX only updates existing cuts

YES: When redefine a library component always remove existing cuts and place new ones

Default: NO

UPDATE_MOLDBASE_COMPS
NO: No action.

YES: If a plate is modified, added or removed mold base components are updated.

Default: NO.

CONFIG_USE_LAYER_FOR_SIDE_VIEWS
NO:

YES:

Default: NO.

USE_P_PLATE_STACK
NO: Cutouts for mold base screws and guide components are defined as plate features.

YES: None of the mold base plates has predefined cuts for screws and guide components.
These cuts are generated by the components.

Default: NO.

USE_RULEBASED_LAYER_CONCEPT
NO: Use default EMX layers for new EMX Projects.

YES: Use rule-based layers and combined states defined in template files configuration
\templates\rule_layers for new EMX Projects.

Default: NO.

WATERLINE_DESIGNER_DEFAULT_COMPONENT
Instance name for the component to use as the default in the Waterline Designer.

Default: mm|meusburger|E2074_8_10.

WATERLINE_DESIGNER_SHOW_Z_POS_IN_WORKMDL_COORDS
YES: Show drawing height in coordinates of current working model with Waterline Designer.
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NO: Show drawing height in ORIGIN_MOLDBASE coordinates.

Default: YES

WATERLINE_DESIGNER_DIA_LABEL
Defines all diameter values available for selection in the diameter column of the Cooling
Circuits table. A valid option format is dia1|dia2|dia3.

Default: 8|10|12.

WATERLINE_DESIGNER_OVERMEASURE
The default overmeasure up to the next cut for all cooling bores.

Default: 3.

WATERLINE_DESIGNER_XSEC_CREATE
YES: Automatically creates a cross section through sketch planes with the Waterline
Designer.

NO: Does not a create a cross section through sketch planes with the Waterline Designer.

Default: YES.

29.5 Component Options

ADD_TECH_COLOR
NO: No action.

YES: Set technology color in EMX UDFs.

Default: YES.

ADD_TECH_PARAM
NO: No action.

YES: Add technology parameter in EMX UDFs.

Default: YES.

AUTO_ASSEMBLE_SCREWSPINS
NO: No Action.

YES: Assemble predefined components on a library part automatically.

Default: NO.

AUTO_REASSEMBLE
NO: No action.
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YES: Creo Expert Moldbase Extension will prompt the placement references for a cooling
component in a loop after the first placement. Stop component placement with Middle Mouse
Button.

Default: NO.

AUTO_REASSEMBLE_ALL_TYPES
NO: No action.

YES: Creo Expert Moldbase Extension will prompt the placement references for any
component in a loop after the first placement. Stop component placement with Middle Mouse
Button.

Default: NO.

AUTO_SAVE_LAST_COMP
NO: No action.

YES: Creo Expert Moldbase Extension will save the parameters of the last component to
reuse it when open the component dialog box again.

Default: NO.

COOLING_ADDITIONAL_BORE_DEPTH_RULE
Rule for calculating the additional bore depth rule to apply to all cooling components defined
on curves such as 0.5*BORE_REF_DIA.

Default:— (hyphen)

EJP_NOTE_PRE_STRING
Text to add before the real ejector pin length in the &remark-parameter.

Default: -.

EJP_NOTE_POST_STRING
Text to add after the real ejector pin length in the &remark-parameter.

Default: –.

EMX_CHECK_DWG_TYPES
List all component types such as guide|plates|slider|library, that have the Copy
Drawings check box selected by default, when the drawing exists in same folder. Set to – to
disable drawings.

Default: ejector|slider|lifter|latchlock.

EMX_TOL_MODE
Tolerance display of EMX components and UDFs.
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-1: Do not modify tolerance display of EMX components and user-defined features (UDFs).

0: Set all dimensions to nominal.

1: Set all dimensions to plus-minus.

2: Set all dimensions to limits.

3: Set all dimensions to plus-minus-sym.

Default: 0.

EMX_NO_CUT_PARAM
Name of a INTEGER-Parameter. If this Parameter exists at a part with value 1,
Creo Expert Moldbase Extension will not cut this part.

Default: “-”.

EXCL_SIZE_CALC_PARAM
Name of an integer parameter that directs EMX not to calculate size from the owner model.
Use – to ignore this functionality.
Default: –.

INCREMENT_POS
Increment that should be used for point offset when creating points picked by mouse.

Default: 0.01.

MIN_SCREW_LENGTH_RULE
Rule for calculating the minimum screw length once the references have been chosen.

Default: 1.5*diameter+REF1+OFFSET

NOM_DIM_DISPLAY
0: Show dimension Symbolname + description in the Nominal Dimension list of the
component dialog box

1: Show only dimension Symbolname in the Nominal Dimension list of the component dialog
box

2: Show only description in the Nominal Dimension list of the component dialog box

Default: 0

NR_DIGITS_BOM
Set the number of decimal places to format the SIZE and ORDER NUMBER Parameter
String. Set this parameter to 0 to use NR_DIGITS_COMMON for all formatting.

Default: 3.
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NR_DIGITS_COMMON
Number of decimal places for all dimensions in EMX components.

Default: 3.

PATTERN_QUILT_CUTS
NO: Run interference check and add cuts for patterned components individually.

YES: Run interference check for patterned components only one time and create a reference
pattern for the cuts.

Default: YES.

PARAM_PLATE_LENGTH
Parameter name to save the plate length to the plate.

Default: -

PARAM_PLATE_WIDTH
Parameter name to save the plate width to the plate.

Default: -

PARAM_PLATE_THICKNESS
Parameter name to save the plate thickness to the plate.

Default: -

PARAM_VOLUME
Parameter name to save the volume of the Model Size dialog box.

Default: -

SAVE_DRAWINGS
NO: No action.

YES: Save drawings of all EMX components automatically.

Default: NO.

SET_EMX_DTL
NO: No action.

YES: Set drawing options /configuration /symbols_dtl/ <unit>emx.dtl for
each drawing.

Default: NO.



Configuration Options - Admin Tutorial

Page 371/448

SHOW_PRYSLOT
NO: Hide PRYSLOT-features in all plates in any case.

YES: Show PRYSLOT-features in all plates even when they are defined in a different way in
the feature_data.txt file.

Default: YES.

USE_INSTANCE_IN_REFNAME
NO: Rename references using the format "<component-type>_<id>".

YES: Rename references using the format "<component-type>_<instancename>_<id>".

Default: NO.

USE_ONE_MDL_RAIL
Sets the default of the Both rails in one model check box, in the Plate dialog box.

NO: Rails are represented by two individual models.

YES: Both rails use the same Creo Parametric model.

Default: NO.

USE_SHORT_NAME_TRIM_EJP
NO: Add the geomitem-id to the name of multiple, trimmed ejector pins.

YES: Use a short id for the name of multiple, trimmed ejector pins

Default: NO.

29.6 Parameter Options

ADD_LOCALIZED_BOM_NAME1
-: Do not add additional localized ordering names in partnames.cfg.
chinese_cn: Add traditional Chinese ordering names in partnames.cfg
chinese_tw: Add modern Chinese ordering names in partnames.cfg
french: Add French ordering names in partnames.cfg
german: Add German ordering names in partnames.cfg
italian: Add Italian ordering names in partnames.cfg
japanese: Add Japanese ordering names in partnames.cfg
korean: Add Korean ordering names in partnames.cfg
spanish: Add Spanish ordering names in partnames.cfg
usascii: Add English ordering names in partnames.cfg.
Default: -.

ADD_LOCALIZED_BOM_NAME2
-: Do not add additional localized ordering names in partnames.cfg.
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chinese_cn: Add traditional Chinese ordering names in partnames.cfg
chinese_tw: Add modern Chinese ordering names in partnames.cfg
french: Add French ordering names in partnames.cfg
german: Add German ordering names in partnames.cfg
italian: Add Italian ordering names in partnames.cfg
japanese: Add Japanese ordering names in partnames.cfg
korean: Add Korean ordering names in partnames.cfg
spanish: Add Spanish ordering names in partnames.cfg
usascii: Add English ordering names in partnames.cfg.
Default: -.

ADD_LOCALIZED_BOM_NAME3
-: Do not add additional localized ordering names in partnames.cfg.
chinese_cn: Add traditional Chinese ordering names in partnames.cfg
chinese_tw: Add modern Chinese ordering names in partnames.cfg
french: Add French ordering names in partnames.cfg
german: Add German ordering names in partnames.cfg
italian: Add Italian ordering names in partnames.cfg
japanese: Add Japanese ordering names in partnames.cfg
korean: Add Korean ordering names in partnames.cfg
spanish: Add Spanish ordering names in partnames.cfg
usascii: Add English ordering names in partnames.cfg.
Default: -.

ADD_LOCALIZED_BOM_NAME4
-: Do not add additional localized ordering names in partnames.cfg.
chinese_cn: Add traditional Chinese ordering names in partnames.cfg
chinese_tw: Add modern Chinese ordering names in partnames.cfg
french: Add French ordering names in partnames.cfg
german: Add German ordering names in partnames.cfg
italian: Add Italian ordering names in partnames.cfg
japanese: Add Japanese ordering names in partnames.cfg
korean: Add Korean ordering names in partnames.cfg
spanish: Add Spanish ordering names in partnames.cfg
usascii: Add English ordering names in partnames.cfg.
Default: -.

ADD_LOCALIZED_BOM_NAME5
-: Do not add additional localized ordering names in partnames.cfg.
chinese_cn: Add traditional Chinese ordering names in partnames.cfg
chinese_tw: Add modern Chinese ordering names in partnames.cfg
french: Add French ordering names in partnames.cfg
german: Add German ordering names in partnames.cfg
italian: Add Italian ordering names in partnames.cfg
japanese: Add Japanese ordering names in partnames.cfg
korean: Add Korean ordering names in partnames.cfg
spanish: Add Spanish ordering names in partnames.cfg
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usascii: Add English ordering names in partnames.cfg.
Default: -.

BOM_FILENAME
Full path to the BOM ASCII file that can be exported from the BOM dialog box.

Default: emx_bom.txt.

CHECK_DRAWING_WHEN_OPEN_BOM
NO: No action.

YES: Check if a drawing exists for each part when opening the BOM.

Default: NO.

CHECK_RELATIONS_WHEN_OPEN_BOM
– (hyphen) : When opening the BOM do not check relations defined in EMX rel-files. No
action.

FOR_PARTS_AND_ASMS: When opening the BOM, check and set relations from EMX rel-
files for parts and assemblies.

FOR_PARTS_ONLY: When opening the BOM, check and set relations from EMX rel-files
for parts only.

FOR_ASMS_ONLY: When opening the BOM, check and set relations from EMX rel-files for
assemblies only.

Default: NO.

CREATE_LOCAL_PARAMS
NO: No action.

YES: Defines additional project-specific parameters in the current working directory.

Default: YES.

DATE_FORMAT
Date format. d = day; m = month; y = year.

Default: dd-mm-yyyy.

PART_RENAME_FORMAT
Format string for renaming parts using POS or PARTID in BOM dialog box. Use '-' to
deactivate this function. Use <name>, <pos_id> and <partid> as placeholders.

Default: -.
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PLACE_BALLOON_ON_FACE
NO: Balloons in drawings are attached to the view only.

YES: Balloons in drawings are attached to a selected face.

Default: YES.

RECALC_MASS_PROPS
NO: No action.

YES: Recalculate the point of gravity when closing the mold base definition dialog box.

Default: YES.

RECALC_SIZE_WHEN_OPEN_BOM
NO: No action.

YES: Determine the solid outline of every component when opening the EMX BOM dialog
box.

Default: YES.

SORT_BOM_WITH_PARTID
NO: When open BOM dialog box sort components by &POS_ID

YES: When open BOM dialog box sort components by &PART_ID

Default: NO.

SUPPRESS_EJP_NOTE
NO: Display the ejector ID as additional note on the drawing when placing ejector symbols.

YES: Do not display the ejector ID as additional note on the drawing when placing ejector
symbols.

Default: NO.

TECH_PARAM
Name of technology parameter.

Default: TECH.

USE_PARTID_IN_BALLOON
NO: Display the content of the parameter &POS_ID in BOM balloons.

YES: Display the content of the parameter &PART_ID in BOM balloons.

Default: NO.
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CONFIG_BOM_BALLOON_CUSTOM_PARAM
Name of a parameter that appears in the BOM Balloons instead of the position ID.

Default: - (hyphen).

29.7 Analysis Options

ACCURACY_VALUE
Accuracy value set with the Set Accuracy command.

Default: 0.001.

ACCURACY_TYPE
0: Set the accuracy type to absolute when using the Set Accuracy function.

1: Set the accuracy type to relative when using the Set Accuracy function.

Default: 0.

ADD_TRIM_FACE_IN_CORE
NO: No action.

YES: Add a solid surface copy to all solid models classified as "Reference model" that can be
used as ejector trim face.

Default: NO.

ADVANCED_TECH_COLOR
NO: Regular technology color handling.

YES: Allow usage of HASCO standards for surface coloring.

Default: YES.

EDM_CSYS_PARAMETER
Name of the parameter used in the Print EDM Position function.

Default: EDM_ORIGIN.

EDM_CSYS_RESULT_FILE
Name of the result file generated by the Export CSYS Position command.

Default: edm_position.txt.

ENABLE_MOULDING_REPAIR
NO: No action
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YES: Repaint ejector cutouts in molding part when calculating the clamping force

Default: NO

QMM_FILENAME
Name of the file used with the Measurement Points function.

Default: qmm_points.txt.

SIZE_FORMAT
L1xL2xL3: Sort dims by size from largest to smallest.

XxYxZ: Sort dims by x, y, and z.

Default: L1xL2xL3.

TEST_MODE
NO: No action.

YES: Save additional debug information in the Creo Parametric trail file.

Default: NO.

USE_ASM_WATERLINE_MDL
NO: Use partfile for waterline analysis and copy all faces into it.

YES: Use assembly for waterline analysis and assemble refmodel and cooling comps.

Default: NO.

29.8 About Common Parameters
To set Bill of Materials parameters, click EMX ▶ Options. The EMX Options dialog box
opens. Select the Parameter tab. This tab lists all parameters associated with each
Creo Expert Moldbase Extension assembled component. Double-click a parameter to modify
its value.

The Parameter tab contains the following columns:

• Parameter Name—Displays the parameter name.
• Belongs to—Displays the type of parameter (PART or COMP) to create.
• Parameter Type—Displays the parameter type (STRING, INTEGER or DOUBLE).
• Format—Displays the drawing/report table and the ASCII file output format. Enter the

number of characters to use for STRING and INTEGER, or the number of characters or
digits for DOUBLE parameters.

• Designate—Indicates whether the parameter is for INTRALINK.
• Show in Table—Indicates whether the parameter is for BOM.
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• Show in GUI—Indicates whether the parameter can be edited in an
Creo Expert Moldbase Extension dialog box.

• Use to summarize—Indicates whether the parameter can be used to compare identical
components in the Bill of Materials dialog box.

• Default Value—Displays the default parameter value. Click to display a default value list.

• Click to add a new parameter. When a parameter is selected, it is copied to a new
line.

• Click to delete the selected parameter.

29.9 Default Parameter Configuration Options
To set internal parameter values, enter these parameter configuration options in the Value
column of the Parameter definition table.

Rule Definition Source
&pos_id Unique position # Bill of Materials dialog box

&qty Quantity of model instances used in the
Creo Expert Moldbase Extension assembly

Bill of Materials dialog box

&partname Model name of a component • Options tab
• Part Names tab
• The dialog box in which the component is defined

&partid Part ID to presort the BOM • Options tab
• Part Names tab
• The dialog box in which the component is defined

&bomname Part name for BOM • Options tab
• Part Names tab
• The dialog box in which the component is defined

&bomname_loc1 1st localized part name for BOM • Options tab
• Part Names tab

&bomname_loc2 2nd localized part name for BOM • Options tab
• Part Names tab

&bomname_loc3 3rd localized part name for BOM • Options tab
• Part Names tab

&bomname_loc4 4th localized part name for BOM • Options tab
• Part Names tab
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Rule Definition Source
&bomname_loc5 5th localized part name for BOM • Options tab

• Part Names tab
&supplier Supplier The dialog box in which the component is defined

&material Material The dialog box in which the component is defined

&ord_number Order number • Options tab
• Part Names tab
• The dialog box in which the component is defined

&size Model size Bill of Materials dialog box

&drw_page Page number in the drawing where the model is shown in a
view

Bill of Materials dialog box

&bom_page Page number in the report where the model is listed in the
BOM table

Bill of Materials dialog box

&remark Remark • Options tab
• Part Names tab
• The dialog box in which the component is defined

&special Identifies this component is a standard part or not The dialog box in which the component is define.

&modeled_by Name of the designer The dialog box in which the component is define.

&date Current date The dialog box in which the component is defined

&projectname Name of the Creo Expert Moldbase Extension project Project dialog box

&prefix Project prefix Project dialog box

&postfix Project suffix Project dialog box

&side Fixed half or Moving half The dialog box in which the component is defined

&sim_group Name of the simulation group to which the component
belongs

The dialog box in which the component is defined

&user_number Content of the Column USER_NUMBER in the parts comp_
data.txt file

The dialog box in which the component is defined

&sap_number Name of the simulation group to which the component
belongs

The dialog box in which the component is defined

&weight Component weight that will be recalculated when the BOM
dialog box is opened

Bill of Materials dialog box

&price Content of the Column PRICE in the parts comp_data.
txt file

The dialog box in which the component is defined.
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29.10 About Project Parameters
Project parameters are project-specific parameters that are stored in the project working
directory. The default values for these parameters are defined when a new
Creo Expert Moldbase Extension project is created.

When you click the Project Parameter tab, the following table appears:

• Parameter Name—Shows the parameter name.
• Belongs to—Shows the parameter as a part or component. Set the value to PART or

COMP.
• Parameter Type—Shows the parameter type. Valid types are STRING, INTEGER, or

DOUBLE.
• Format—Shows the Drawing/report table and the ASCII file output format. Enter the

number of characters used for STRING and INTEGER, or the number of characters or
digits for DOUBLE parameters.

• Designate—Determines if a parameter is automatically designated for INTRALINK.
• Show in Table—Determines if this parameter is used in the BOM.
• Show in GUI—Sets the parameter as editable or not editable in an EMX dialog box.
• The Use to summarize column shows whether this parameter is used to compare

identical components in the BOM dialog box or not.
• Default Value—Shows the default parameter value. Click to see default parameters

supported by EMX list.

• Click to add a new parameter. When a parameter is selected, it is copied to a new
line.

• Click to delete the selected parameter.

29.11 About Part Names
When you assemble a component, you must add data to uniquely identify each part. Click the
Part Names tab in the EMX Options dialog box to set default values for most Bill of
Materials (BOM) parameters.

• File Name—Links the file name to the component template. When the component
template name and the file name are the same, these values in this line are used.

• Standard Part—Sets component usage as standard (not modifiable) or non-standard
(modifiable).

• Add to BOM—Sets the default value in the Component dialog box. When set to N, the
component is suppressed in the BOM.

• Side—Determines if a component is renamed when assembled on the Moving or Fixed
Half of the mold base. Enter ES for the moving half or IS for fixed half. If the names on
both halves are identical, enter -.

• Simulation—Sets the default simulation group to use for this template.
• Part Name—Uses a wildcard-based formatted name for the component.
• Alternate part name—Defines an alternative name using the same wildcards.



29.12 About Part Name Wildcard Characters

Page 380/448

• Part ID—Defines an ID used to sort the BOM so you can list parts in an order that you
define.

• Group Layer—Sets the group layer name.
• Layer—Shows the layer name to use.
• BOM Name—Describes the component to print in the BOM. To use multi-language

entries, set the configuration option ADD_LOCALIZED_BOM_NAME1 to ADD_
LOCALIZED_BOM_NAME5. You can set up to five additional languages.

• Order Number—Defines the order number format. By default, order number is set to a
value from the database represented by the wildcard <ord_number. Overwrite this
setting as needed.

29.12 About Part Name Wildcard Characters
Use the following wildcards when defining part names, part IDs, layers, and order numbers in
the Part Names tab of the EMX Options dialog box:

• <ord_number>
• <instance>
• <sap_number>
• <pre> is replaced by the project prefix defined in the Project dialog box.
• <post> is replaced by the project suffix defined in the Project dialog box.
• <xid> where x represents the number of characters used to print the component specific

id. For example if you set x to equal 3, than the result is 001, 002, and so on.
• <typ> is replaced by the supplier-dependent type name for a component. For example

Z41 may be the name for an ejector pin.

Use any component dimension as a wildcard for ordering numbers. Add the dimension
symbol name in angled brackets (<>). For example, the ordering number for dowelpin1 is
represented by the dimension symbols.

29.13 About Technology Data
Click the Technology tab in the EMX Options dialog box to set feature colors using
customizable color codes, or to define feature parameters with feature-dependent values.

• Description—Feature or UDF description.
• Technical ID—Internal identifier.
• Feature Name—Unique geometry-feature name.
• Value—Technology parameter value.
• Hole Color—Hexadecimal color code for the first (larger) feature or UDF cylinder faces.
• Face Color—Hexadecimal color code for the first feature or UDF flat face (counterbore).
• 2nd Hole Color—Hexadecimal color code for conic or cylindrical features or UDF faces.
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29.14 About Cooling Bore Data
You can modify the default cooling component bore parameters. When you define a cooling
component, its main nominal dimension is compared with the data on the Cooling Bore Data
tab. You can also set defaults for other dimensions such as bore diameter, counterbore
dimensions, and so on.

• COOL_NOM—Nominal dimension used to find the correct data set.
• COOL_CORE_DIA—Core diameter.
• COOL_CORE_DEPTH—Core depth.
• COOL_THREAD_DIA—Thread diameter.
• COOL_THREAD_DEPTH—Thread depth.
• COOL_BORE_DIA—Bore diameter.
• COOL_CB_DIA—Counterbore diameter.
• COOL_CB_DEPTH—Counterbore depth.
• COOL_HALF_ANGLE—Blind hole half angle.

29.15 About Ejector Bore Data
When you place an ejector pin, a set of cutouts is automatically made in several plates. These
holes and counterbores should comply with company-specific standards. The standard values
are defined on the Ejector Bore Data tab of the EMX Options dialog box:

• EJP_LOWER_B—Lower limit of the ejector pins nominal diameter.
• EJP_UPPER_B—Upper limit of the ejector pins nominal diameter.
• EJP_LL—Minimum length of the ejector pin guided section in the core-plate.
• EJP_LD—Add this value to the guided bore diameter add-on (fit H7).
• EJP_FD—Add this value to the diameter add-on of the counterbore in the core-plate.
• EJP_BD—Add this value to the diameter add-on of all thru holes.
• EJP_ND—Add this value to the diameter add-on for the smaller diameter in the head

counterbore.
• EJP_CD—Add this value to the head counterbore diameter assigned in the ejector pin

dialog box.
• EJP_CL—Add this value to the head-counterbore depth assigned in the ejector pin dialog

box.
• EJP_FL—Default length for Rotation fix-cutout (use absolute value or <x>*D for

multiple nominal diameter).
• EJP_FW—Default width for Rotation fix-cutout (use absolute value or <x>*D for

multiple nominal diameter).
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29.16 About Screw Hole Data
Screw cutouts follow standards similar to those for cooling holes and ejector holes. You can
set twelve hole dimensions on the Screw Hole Data tab:

• SCR_TYPE_ID—Screw types for which these values must be used. (ANY applies settings
to all screw types.)

• SCR_NOM—Screw nominal dimension. Use to identify the correct line of this list.
• SCR_CB_DIA—Counterbore diameter.
• SCR_CB_DEPTH—Counterbore depth.
• SCR_DIA_F—Thru holes diameter, fine.
• SCR_DIA_M—Thru holes diameter, middle.
• SCR_DIA_R—Thru holes diameter, rough.
• SCR_CORE_DIA—Thread bore core diameter.
• SCR_THREAD_DEPTH—Minimum thread depth.
• SCR_CORE_DEPTH—Thread bore core depth.
• SCR_TOL—Fit (number, no set-id, default values are H7.)
• SCR_PITCH—Thread per inch or mm = Pitch.
• SCR_CB_DIA_WASHER—Counterbore diameter if using spring washer.
• SCR_CB_DEPTH_WASHER—Counterbore depth if using spring washer.
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About the Component Editor
About the Data Structure
About Setting BOM Data in Component Editor
About the Options, Features, and Subcomponents Tabs in the Component
Editor Dialog Box
About Setting Assembly References in Component Editor
About Setting Nominal Dimensions in Component Editor
About Setting Cuts And Threads In the UDF Tab of the ComponentEditor
About Setting Instances in Component Editor
To Add a Part to the Library
To Add Predefined Screws to Components
To Add an Assembly to the Library
About Migrating comp_data.txt and udf_data.txt Files to *.dat Files
About Creating Copies of Existing *.dat Files
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30.1 About the Component Editor

Click EMX Assembly ▶ Administrator Tools ▶ Component Editor to open the
Component Editor dialog box. Use options in this dialog box to maintain the EMX
component and library parts database.

30.2 About the Data Structure
The data structure in Creo Expert Moldbase Extension 10.0 and later is different from the data
structure in earlier releases. In Creo Expert Moldbase Extension 10.0 and later, there is a
separate *.dat file for each component. The *.dat file contains all information required
for the following:

• The component data such as assembly constraints, nominal values, and instances
• The entire cut-information such as UDFs and UDF options

The comp_data.txt file contains a listing of available component types so that you can
sort the order in the selection list and change the description text.

The advantages of using .dat files are listed below:

• Less content for each file, making it easier to manipulate and organize.
• Individual files make it easy to transfer components from one custom configuration to

another.
• The UDF section can be changed for each component individually.

You can migrate comp_data.txt and udf_data.txt files to *.dat files or continue to use the data
structure from previous releases.

30.2.1 Data Structure in Creo Expert Moldbase Extension 9.0 and Earlier
The data structure in Creo Expert Moldbase Extension 9.0 and earlier is also supported. In
Creo Expert Moldbase Extension 9.0 and earlier, the component data of component types
such as the cooling and locating component types for suppliers, are listed in comp_data.
txt files. Additionally, the user–defined feature (UDF) information for each component is
hosted for all component types in the udf_data.txt file. From the Component Editor
dialog box, EMX administrators have direct access to the comp_data file.txt, but not
to the udf_data.txt information. Therefore, manual editing of udf_data.txt in
Creo Expert Moldbase Extension 9.0 and earlier is required. As the result of rising demands
in new components and UDF flexibility, the following occurs in
Creo Expert Moldbase Extension 9.0 and earlier:

• The comp_data.txt and udf_data.txt files are more complex.
• There is a higher–level of effort for EMX administrators to edit components.
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30.3 About Setting BOM Data in Component Editor

1. Click EMX ▶ Administrator Tools ▶ Component Editor to open the Component
Editor dialog box.

2. Click Open model or *.dat file and then browse to and double-click the *.dat. file of a
library component or any standard EMX part. The path to the currently active library
component or EMX component appears.

3. View the list of instances in the file.
4. Enter the required component details.

5. Click to update the preview image of the current model.
6. The Model Type (Part or Assembly) is automatically set when a model is in session.
7. Enter the remaining settings on the following tabs:

• BOM Data
• Assembly References
• Nominal Dimensions
• UDFs
• Options
• Features
• Instances
• Subcomponents

8. Click the BOM Data tab and enter the BOM related data.

• Select the Standard Part check box to prevent changes to the model and define the
default model behavior.

• Select Add to BOM to show the value in the component definition.
• Select Add/Modify entry in part name configuration to add or update the BOM data

in the partnames configuration file.
9. Select Archive all instances to create new models for each instance of the current library

component or standard part. Use the ARCHIV_PATH configuration option to set the path
to the archive.

10. Click to take a snapshot of the current window.

11. Click to preview the all of the component data in a dialog box.

12. Click to save component data.
13. Click Close to close the dialog box.
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30.4 About the Options, Features, and Subcomponents Tabs in the
Component Editor Dialog Box

30.4.1 Options Tab
In the Options tab you can define customized options for an EMX component. A fully-
defined option contains the items listed below:

• Option display name—Translated string
• Option name— Keyword used by the software
• Default value—The default value for the option
• Options type—Select from the list or click Yes or No.

Options are not completely customizable. For different component types there are several
valid options such as COUNTERBORE and SECONDBORE for screws, TRIM or AUTO_
LENGTH for cooling comps, and ROTFIX for ejector pins.

30.4.2 Features Tab
From the Features tab you can suppress and resume certain features in models depending on
a defined option and its value. A valid feature definition requires the following:

• Feature name—A list of features by names in the model is available in the option menu
• Option name—From the Options
• Value—The value for the option which needs to be set to make the feature visible.

30.4.3 Subcomponents Tab
When you define an assembly as a library component, you need to provide EMX with the
location of the definitions of the subcomponents in the EMX components directory. Valid
subcomponents require the information listed below:

• Name of the component
• Unit (mm or inch)
• Directory such as screw, dowel pin, lifter, and so in the components folder
• Supplier such as Hasco
• File name (name of the template part)
• Type name. EMX searches for this name under Instances. In the instances section for each

assembly instance, a valid subcomponent instance must be defined.
• Side value defines the view to which the component is added.

A valid assembly contains multiple parts. Subassemblies are not possible.



The Component Editor - Admin Tutorial

Page 387/448

30.5 About Setting Assembly References in Component Editor

1. Click EMX ▶ Administrator Tools ▶ Component Editor to open the Component
Editor dialog box.

2. Click Assembly References.
3. Click a line to activate the assembly reference.
4. Set default constraint set values:

• —Axis or point, datum plane, and orient plane.

• —Axis or point and datum plane.

• —Axis or point, or curve and datum plane.

• —Axis or point on curve, datum plane, and orient plane.

• —Coordinate system.

• —Datum plane.

• —Prints the internal Creo Parametric identifiers of the selected geometry. This
ID is used to identify the component assembly reference.

5. Click to add a new constraint to the list using the current edit area values, or click

to remove the active constraint.

30.6 About Setting Nominal Dimensions in Component Editor

1. Click EMX ▶ Administrator Tools ▶ Component Editor to open the Component
Editor dialog box.

2. Select the Nominal Dimensions tab.
3. Select a row and edit the dimensions.

4. Click to add a new nominal dimension or click to remove an active nominal
dimension.
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30.7 About Setting Cuts And Threads In the UDF Tab of the
ComponentEditor

1. Click EMX Assembly ▶ Component Editor. The Component Editor dialog box
opens.

2. Select the Cuts and Threads tab.
3. Select a UDF to create cutouts for the component. For library components this is QUILT_

CUT.
4. The predefined threads in the current model are displayed in the list of predefined threads.

The UDF auto_libthread.gph represents the information required to add a tapped
bore to models that interfere with this UDF after the component is placed in the assembly.

5. The selected cut quilts are displayed in the cut quilt list. Ensure that the quilts used for
cutouts are closed.

6. Click to add a new quilt or thread, or click to remove the selected cut quilt or
thread from the list.

30.8 About Setting Instances in Component Editor
Component instances are saved in a family table.

1. Click EMX ▶ Administrator Tools ▶ Component Editor to open the Component
Editor dialog box.

2. Select the Instances tab.
3. Double-click an instance to edit it.

4. Click to copy all instances information to the clipboard for editing externally, such
as editing in an EXCEL file.

5. Click to paste the externally edited instances information back to the component
editor. You can edit the cell values and insert new columns.

6. Click to add a new instance. When you select a row, the information is copied to the
new instance.

7. Click to remove the selected instance from the list.

30.9 To Add a Part to the Library
Download 00_library_part to start with this chapter.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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30.9.1 Load the new library component
1. Erase all models from the Creo session.
2. Copy the file E1920.PRT from <install_tutorial>/models/library_prt

into an new folder<install_emx90>/components/mm/library/tutorial.
3. Open the model E1920.PRT from this directory.

30.9.2 Create an Image and Define the Component BOM Data

1. Start EMX Part Mode ▶ Administrator Tools ▶ Component Editor .

The Component Editor dialog box opens.

2. .Click Open model or *.dat file
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The File Open dialog box appears. Select e1920.prt from current working directory.
The dialog is filled with default library component information.

3. .Adjust the model orientation and click
NOTE:
It is recommended to display the assembly reference features so they can be identified in
the image. You may edit the picture with a regular image editor afterwards.

4. Define the BOM data for this component.



The Component Editor - Admin Tutorial

Page 391/448

This is the data that can be found for regular EMX components in the EMX Options ▶
Part Names sheet.

5. Enter the Part name <pre>_E1920_<id>.
6. Enter the Alternate part name <instance>.
7. Keep Part ID as 99<2id>.
8. Keep BOM Name as <instance>.
9. As target Layer enter 99_LIBRARYCOMP. The component will be place on this layer

after the assembling process.
10. Enter Group Layer -.
11. Keep Order Number as <ordnumber>.
12. Enter Customer number -.
13. Enable Add in BOM so this component will be displayed in the EMX bill-of-materials

later.

30.9.3 Define the Assembly References
1. Click the tab Assembly References.

2. Click and select the coordinate system PLACEMENT_CSYS from the model
E1920.PRT.

A new line appears in the assembly constraints.
3. Select this line (with ID1) and edit the entry for Reference Name in the edit area under

the list to CSYS.
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30.9.4 Define the Nominal Dimensions
1. Click the tab Nominal Dimensions.

2. Click .

All dimensions are displayed in the 3D model.
3. Hold down the CTRL-Key and select the dimensions: LG, LG1, LG2, H and S.Click

MMB to finish the selection.
NOTE:
The order of selection defines the order in the dialog entries.

Five new lines appear in the Nominal Dimension list.

4. Select a line to edit the entries in the edit area below the list.
5. Select the LG line and overwrite the Dimension Name (symbol LG) with LENGTH
6. Select the H line and overwrite the Dimension Name (symbol H) with HEIGHT.
7. Set the Dimension Type of LG1, LG2 and S to PULLDOWN_EDIT.

30.9.5 Define cutout UDFs
1. Click the tab UDFs .
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For library components the UDF QUILT_CUT is used by default.

2. Click the beside the Cut quilts list and select the Quilt feature CUT_QUILT in the
E1920.PRT.

NOTE:
Valid cut quilts will be automatically detected and added to the cut quilts list.

No Predefined threads should be defined for this example.

30.9.6 Define instances with Excel
1. Click the tab Instances.

In the table all instances that are defined for the library component can be seen.

Each Nominal Dimension is represented as a column.

By default only one instance with the current model values is added to the table.
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Excel can be used for additional instances.

2. Click Copy to copy the current content of the table.

3. Open an MS Excel instance and paste the content to the Excel-Sheet.

All rows will be displayed in the Excel-Sheet.
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4. Enter instances that can be found in the Meusburger Digital catalog.



30.9 To Add a Part to the Library

Page 396/448

NOTE:
The first column always contains the type of the component in the case E1920.

Make sure that the column for Instances and Order Number is correct and has a unique
name. Otherwise EMX can not added the correct ordering number to the BOM. The
entries in Instances should be proper Creo model names, so they must not contain “/” or
“,”. This names will be used as partname if the wildcard <instance> is used.

5. Copy the final instance sheet to the EMX instances list with Paste

NOTE:
In MS Excel select the exact area of cells you want to paste including the header row.

30.9.7 Save the Library Component

1. Click

EMX will create a e1920.dat file and a e1920.gif-file in the directory where the
library part is located. The model will also be saved again as e1920.prt.1. Delete the
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original file e1920.prt and rename the new file without an index. This step is not
required, but it helps you to keep the library folders clean.

NOTE:
You don’t have to create the tiny image e1920_tn.gif manually. This image is used in
the Library Component dialog box for preview. If the image does not exist, EMX will
create it use the setting of LIBRARY_THUMB_SIZE to determine the size.

The component is now fully defined.
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30.9.8 Assemble the component
1. Open the mold base TUTORIAL.ASM
2. Create a coordinate system as assembly reference for the plate as shown in the picture

below.

3. Make sure that the orientation of the coordinate system is correct. X-Vector is normal to
surface and Z-Vector points into opening direction of the mold base.
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4. Select EMX Components ▶ Library ▶ Assemble .

5. Select the directory meusburger from the directory tree.
6. Select part e1920 with Double-Click.
7. Set the Length (LG) value to 446.
8. Set the Height (H) value to 86.
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9. As assembly reference (1) CSYS select the recently created coordinate system.

10. Leave the Library Component dialog with OK .
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30.10 To Add Predefined Screws to Components
1. Erase all models from the Creo session.
2. Open part E1920.PRT from directory library/tutorial.

3. Click EMX Part Mode ▶ Components ▶ Screw .

4. Create a Datum Axis at each of the existing bores.



30.10 To Add Predefined Screws to Components

Page 402/448

5. Create a Datum Points on each of the recently created axes and the upper surface of
the plat as seen in the picture below.

6. Within the Screw dialog box select the desired screw supplier meusburger and screw
type E1200 | Socket head cap screw

7. Define the references.

a. Click (1) Point|Axis and select the recently created datum points.
b. (2) Surface - Select the top face of the E1920.PRT.
c. (3) Thread surface - Select the bottom face of the E1920.PRT.

8. Double click the Diameter Value and select 4.
9. Double click the Length Value and select 10.
10. Make sure that Counterbore is disabled.

When working in Part Mode, the Predefined Component flag is set by default.
11. Leave the Screw dialog box with OK and find the predefined component UDFs in the

model tree.
12. Save the modified library part with File > Save.

30.10.1 Assemble the Modified Library Component
1. Open the mold base TUTORIAL.ASM
2. Assemble the E1920.PRT as described in the chapter Add a Part to Library on page 388.
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3. Select EMX Components ▶ Component Handling ▶ Assemble predefined

components .
4. Select the model TUTOR_E1920008 in the graphics window.

As the result the predefined screws are assembled to the mold base.

Background Information

Set the EMX Option AUTO_ASSEMBLE_SCREWPINS to YES to assemble predefined
components directly after assembling the owner component automatically.

This way of predefining components can be used for any EMX component, even sliders or
lifters. But in most cases it is dowel pins and screws that are predefined.
If you set the EMX Option USE_41_SCREWPIN_PREDEFINE to YES, EMX will not add
REF-GROUPS on the selected references but save all component information directly to the
selected placement points..

30.11 To Add an Assembly to the Library
Download 00_library_asm to start with this chapter.

https://dl.buw-soft.de/emx/guides/EMX 12 Tutorial
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Adding assembly components to library is more complex than just adding a single part. In this
chapter we will add the adjustable transportation bar E1930 from the supplier Meusburger
which can be seen in the picture below.

30.11.1 The Assembly Structure
Before adding the assembly to the EMX Library all containing single components need to be
implemented.

The E1930 assembly contains the following parts:

E1930_1: The transportation bar

E1903_2: The t-nut
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E1270: A hoist ring

E1200: 2 x socket head cap screws

E1230: A set screw

E1300: 2 dowel pins

The components E1270, E1200, E1230 and E1300 are already available as regular EMX
Components.

The bar E1930_1and the T-Nut E1930_2 have to be created.

Go to the Meusburger catalog and extract the data sheets for the components E1930_1 and
E1930_2.

Use the regular Creo functions to create the PRT files.

30.11.2 Design the component E1930_1
All model described in this chapter can be found in folder <install_tutorial>/
models/library_asm. E1930_1 contains a couple of features:

• PLACEMENT_CSYS : Use this csys as assembly reference.
• BODYand SHAPE: This features describe the geometry.
• POINTS_FOR_E1300: points where the dowel pins E1300 will be placed in the assembly.
• POINTS_FOR_E1200: points where the screws E1200 will be placed in the assembly.
• CUT_QUILT: A quilt surface which surrounds the whole part this will be used as cut quilt

later.
NOTE:
The UDF Group features are later created during the design of the assembly.
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30.11.3 Add the component E1930_1 to the EMX Library
1. Erase all models from the Creo session.
2. Add the previously created part file E1903_1.PRT to the library folder <library_

emx90>/tutorial and open the part.
3. Add the component to the EMX library just as you have seen it the chapter

To Add a Part to the Library on page 388.
4. Use the PLACEMENT_CSYS as the assembly Reference.
5. Make sure all dimensions which need to be varied are added as Nominal Dimensions

6. Set up the Instances correctly.

7. Use the CUT_QUILT feature as Cut Quilt.

As a result you will find the E1930_1.dat file and the picture E1930_1.gif in
<library_emx90>/tutorial folder.
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30.11.4 Design the component E1930_2
These are the important features:

• PLACEMENT_CSYS : Use this csys as assembly reference.
• BODY : This features describes the geometry.
• POINTS_FOR_E1270: points where the hoist ring E1270 will be placed in the assembly.
• POINTS_FOR_E1230: points where the set screws E1230 will be placed in the assembly.
NOTE:
The UDF Group features are later created during the design of the assembly.

30.11.5 Add the component E1930_2 to the EMX Library
1. Erase all models from the Creo session.
2. Add the previously created part file E1903_2.PRT in the library folder <library_

emx90>/tutorial and open the part.
3. Add the component to the EMX library just as you have seen it the chapter

To Add a Part to the Library on page 388.

Use the PLACEMENT_CSYS as the assembly Reference.
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4. Make sure all dimension which need to be varied are added as Nominal Dimensions

5. Set up the Instances correctly.

As a result you will find the E1930_2.dat file and the picture E1930_2.gif in
<library_emx90>/tutorial folder.

30.11.6 Copy Screws and Dowel Pins to Library Folder
To design the assembly E1930.ASM copies of the template parts of dowel pin E1300, set
screw E1230, head cap screw E1200 and hoist ring E1270 are required in the library folder
<library_emx90>/tutorial.

1. Copy screw_e1200.PRT from “<install_emx90>/components/mm/screw”
to “<library_emx90>/tutorial”

2. Copy screw_e1230.PRT from “<install_emx90>/components/mm/screw”
to “<library_emx90>/tutorial”

3. Copy screw_e1270.PRT from “<install_emx90>/components/mm/screw”
to “<library_emx90>/tutorial”

4. Copy dwlpin_e1300.PRT from “<install_emx90>/components/mm/
dowel_pin” to“<library_emx90>/tutorial”
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30.11.7 Design the Assembly E1930
1. Erase all models from the Creo session.
2. Create a new assembly and assemble the previously created components as seen in the

picture below.

3. Open EMX Assembly ▶ Project ▶ Modify .

The Project dialog box appears.
4. Leave the dialog box again with OK.

The Assembly is now considered to be an EMX project.

In the next steps the screws, pins and the hoist ring will be assembled.

1. Click EMX Components ▶ Components ▶ Screw .
2. Assemble the E1200 component as seen in the picture below.
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3. Set Part Name to screw_E1200.This is essential to allow EMX to find the correct
template model.

4. Repeat the same steps for the hoist ring E1270.
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5. Set Part Name to screw_E1270.

6. Repeat the same steps for the set screw E1230.
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7. Set Part Name to screw_E1230.



The Component Editor - Admin Tutorial

Page 413/448

8. Repeat the same steps for the dowel pins E1300.
9. Set Part Name to dwlpin_E1300.

The Assembly is completed.
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30.11.8 Add the assembly E1930 to the EMX Library

1. Start EMX Assembly ▶ Administrator Tools ▶ Component Editor .

The Component Editor dialog box opens.
2. .Click Open model or *.dat file

The File Open dialog box appears. Select e1920.prt from current working directory.
The dialog is filled with default library component information.

3. Reorient the model and click to update the image for this library component. This
image will be displayed in the Library Component dialog box later.

4. Define the BOM data for this component.

5. Got to the tab Assembly references.
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6. Set up PLACEMENT_CSYS as assembly reference

7. Got to the tab UDFs.
8. Create Threads and Quilt Faces in the bottom area of the Cuts and Threads tab.
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9. Add a new Threads and Quilt Face with . You are prompted to select an Axis and
Surface.

EMX will add a Predefined Thread UDF.

10. Pattern this UDF by creating a Sketch which contains 2 datum points directly in the
center of the two bores.
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11. Create a pattern of the Predefined Thread UDF.

NOTE:
For each instance of the assembly change the dimensions of the Predefined Threads.

12. Go to the Nominal Dimensions.
13. Add the dimensions:



30.11 To Add an Assembly to the Library

Page 418/448

14. Save the assembly with .

As a result you will find the E1930.dat file and the picture E1930.gif in
<library_emx90>/tutorial folder.

30.11.9 Final Changes to the E1930.dat File
The E1930.dat file contains all information to control the component. This dat-file
can be change manually as well.

NOTE:
Be aware of what you are doing. Wrong entries in the dat file can cause trouble in EMX.

1. Open the file within a Text Editor.
2. Go to the Section EMX_NOM_VALUES.

This section contains all nominal dimension shown in the Library Component dialog box.

The only “nominal dimension” which will be set up is the component E1930_1. This is
the leading component and can later be selected as PULLDOWN in the Library
Component dialog box.

3. Comment out the dimension lines of the Predefined Thread. We do not want to change
them in the dialog box, this dimensions will be set thru the instance lines.
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4. Go ahead to the section EMX_COMPONENTS. In this section you let EMX know which
component is part of the assembly and where EMX can find the component information.

The components E1930_1 and E1930_2 can be found in the SUBFOLDER library.
The SUPPLIER is meusburger. This is exactly the folder structure that is set up.

All other components can be found in their regular components folders, e.g. E1300 in
SUBFOLDER dowel_pin and SUPPLIER meusburger.

5. Finally, go to the section EMX_INSTANCES. The instances are set up similar to a part
library component with one exception: For each sub component a valid component
instance needs to be provided.

Additionally, the dimension for the Predefined Thread features need to be listed here:

NOTE:
Write the instances one after another. In the tutorial they are simply displayed in two
separated picture because of space restrictions.

30.11.10 Assemble the New Library Assembly E1930
If everything is set up properly you can now assemble the new Library Component. Use the
already provided E1930 from the library/meusburger folder as a comparison
reference.

1. Open the mold base TUTORIAL.ASM
2. Add a coordinate system to the mold base with the appropriate orientation.

3. Select EMX Components ▶ Library ▶ Assemble .
4. Select the directory meusburger from the directory tree list.
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5. Double-click e1930 .

6. Select on of the 4 available instances and leave the dialog with OK.As a result you will
find the Assembly Component add to the mold base.
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Background Information

When working with complex library components they might have several independent cut
quilts and generate a huge amount of individual cuts in plates or other models. During the
redefine of such library components you might face problems with the cut generation. If you
set the EMX Option UPDATE_CUTS_IN_REDEFINE to YES, you force EMX to simply
remove previous cuts and generate new ones.

30.12 About Migrating comp_data.txt and udf_data.txt Files to *.dat Files

1. Click EMX ▶ Component Editor or click EMX Assembly ▶ Administrator Tools
▶ Component Editor. The Component Editor dialog box opens.

2. Select Split comp_data.txt file. The Open comp_data.txt-file to split its content into
separate *.dat-files dialog box opens.

3. Select an EMX 9 formatted comp_data.txt file.

%EMX_INSTALL%/components/mm/cooling/din/comp_data.txt

The splitting process is triggered and the progress is shown in the status bar. As a result
the new *.dat files will be written to the component data folder.

4. Erase all content from the old comp_data.txt files except the section EMX_TYPES
5. Proceed with all comp_data.txt files of the different suppliers for one component

type, such as all suppliers of type cooling.

%EMX_INSTALL%/components/mm/cooling/d-m-e/comp_data.txt

%EMX_INSTALL%/components/mm/cooling/dms/comp_data.txt

%EMX_INSTALL%/components/mm/cooling/hasco/comp_data.txt

6. To finish the migration process delete udf_data.txt file in the folder

%EMX_INSTALL%/components/mm/cooling/udf/udf_data.txt

30.13 About Creating Copies of Existing *.dat Files

1. Click EMX ▶ Administrator Tools ▶ Component Editor to open the Component
Editor dialog box.

2. On the bottom right of the dialog box, in the New name box, enter a new name for the
new component *.dat file,

3. In the box to the left of New name, select a component type.
4. Click Copy *.dat file from an existing one. A generic Component dialog box opens.

The content is populated from the archive folder. This folder contains a list of *.dat file
templates that you can use for copying *.dat files.

5. Select the *.dat file to use for copying and click OK. A new *.dat file and the
associated image and detail images are copied into the current working directory
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6. In the Component Editor dialog box, you can modify the new *.dat file.
7. Click Close to close the dialog box.
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31
Administrator Tools - Admin Tutorial

About Administrator Tools
About Verifying Unused Files
About Adding Drawing Formats
About Replacing Parameters
To Replace Parameters in existing Mold Base Assembly
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31.1 About Administrator Tools
Click EMX or EMX Assembly and then click Administrator Tools to access the tools
described below:

• —Opens the Mold Base Editor dialog box.

• —Opens the Component Editor dialog box.
• Add Drawing Formats—Adds model parameters and drawing formats.
• Verify unused models—Verifies whether models in the current working directory are in

use.

• Replace Parameters—Replaces an existing set of parameters with new parameters
defined in the file <installdir>/configuration/param_replace.cfg.

31.2 About Verifying Unused Files
Click EMX Assembly ▶ Administrator Tools ▶ Verify unused models to identify and save
unused assembly *.prt and *.asm files to the emx_unused_mdls.inf file in the
current working directory. The emx_unused_mdls.inf file appears when the verification
process is complete.

31.3 About Adding Drawing Formats
You can customize plate drawings using the following steps:

1. Click EMX Assembly ▶ Administrator Tools ▶ Add Drawing Formats and choose the
format to use with the current drawing.

2. Click OK in the Update all drawings in this directory? dialog box to apply the format to
all drawings in the current directory or click Cancel to add the format to only one
drawing.

31.4 About Replacing Parameters
1. Open an assembly to modify.
2. Enter new parameter names in the file <installdir>/configuration/param_

replace.cfg.
3. Click EMX Assembly ▶ Administrator Tools ▶ Replace Parameters.
4. The contents of the old parameters are copied to the new parameters and are removed

from all models of the current assembly.
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31.5 To Replace Parameters in existing Mold Base Assembly
EMX can change the parameter set for all models in the mold base assembly. Therefore create
a file configuration/param_replace.cfg.

This file has four columns: Original Parameter name, Owner (COMP or PART), Type
(DOUBLE, INTEGER, STRING), New Parameter name.

1. Start the function Administrator Tools ▶ Replace Parameters.

EMX reads the parameter values from all models, creates the new parameters, copies the
values and deletes the original parameters.



Notes:
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32
The Mold Base Editor - Admin Tutorial

About the Mold Base Editor
About Setting Overall Dimensions in Mold Base Editor
About Setting Pattern Dimensions in Mold Base Editor
About Setting Plate Types in Mold Base Editor
About Setting Plate Features in Mold Base Editor
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32.1 About the Mold Base Editor
Click EMX Assembly ▶ Administrator Tools ▶ Mold Base Editor to open the Mold Base
Editor dialog box. Use this dialog box to modify the mold base supplier database.

32.2 About Setting Overall Dimensions in Mold Base Editor

1. Click EMX Assembly ▶ Administrator Tools ▶ Mold Base Editor. The Mold
Base Editor dialog box opens.

2. Select the Overall Dimensions tab.
3. Select the unit of measurement as mm or inch. When the unit is selected, the list of

available suppliers is updated.
4. Select a supplier from the list of existing suppliers.
5. Select a mold base to edit from the list of existing mold base sizes. New sizes are

automatically added to the list.
6. Select the default supplier for Supplier Plates, Supplier Screws, Supplier Equipment,

Supplier Guides, Supplier Stop System, and Supplier Return Pin.
7. Select Rectangular or Round mold base type.
8. Enter a new Mold Base Size.
9. Enter a value for the Rail Width to create a new rail size.
10. Select a dimension name in the Feature Dimensions list. The name and value appear for

the selected dimension.

11. Click or to add or remove the selected dimension from the list.

12. Click to save the current settings or click Close to close the dialog box.

32.3 About Setting Pattern Dimensions in Mold Base Editor

1. Click EMX Assembly ▶ Administrator Tools ▶ Mold Base Editor. The Mold
Base Editor dialog box opens.

2. Click Pattern Dimensions.
3. Select the active pattern from the Pattern Name list.
4. Preview the active pattern.
5. View or edit the Pattern Diameter.
6. Set the pattern Quantity.
7. Set the Pattern Offset value. This is the x-offset of the first instance for a metric database

and the second instance for an imperial database.
8. In the Pattern Width box, type a value for the x-direction.
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9. In the Pattern Length box, type a value for the y-direction.

10. The new instance appears on the pattern list. A visible instance is indicated by . Click
the first column to toggle visibility on and off.

32.4 About Setting Plate Types in Mold Base Editor

1. Click EMX Assembly ▶ Administrator Tools ▶ Mold Base Editor. The Mold
Base Editor dialog box opens.

2. Select the Plate Type tab. The following plate types are available:

• plate_1—Clamping plate.
• plate_2—Ejector bottom plate.
• plate_3—Intermediate/Support plate.
• plate_4—Rails (one model).
• plate_4_left—Rails (two models).
• plate_5—Cavity plate.
• plate_6—Ejector base plate.
• plate_7—Ejector retainer plate.
• plate_8—stripper plate.

3. Click a line in the list to activate a plate instance.
4. Edit values of the activated plate instance.

5. Click to add a new plate instance to the list, or click to remove the active plate
instance from list.

32.5 About Setting Plate Features in Mold Base Editor

1. Click EMX Assembly ▶ Administrator Tools ▶ Mold Base Editor. The Mold
Base Editor dialog box opens.

2. Select the Plate Features tab.
3. To activate a feature, select a row in the list of plate features.
4. Edit the plate name and display name if required. You can also select a feature name from

the list.
5. Edit the feature dimensions.

6. Click to add a new plate feature to the list, or click to remove the active plate
feature from the list.



Notes:
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33
Additional Configuration Capabilites - Admin Tutorial

Create a Quick Selection pull down menu with sel_list.txt
Working with Standard Parts from Windchill
To Use Relation Files (*rel) to Add Relations to Components
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33.1 Create a Quick Selection pull down menu with sel_list.txt
For some parameter it is required to only allow a list of valid parameter values. This can be
achieved with the sel_list.txt files in the configuration folder.

1. To define a list of values (like for ARTICLE or LIST_EXAMPLE), edit the file
/configuration/sel_list.txt as follows:

2. Identify the Parameter with a "#"-symbol. All following lines are the values that will be
displayed. You still can manually enter any value, even a drop-down list exists.

33.2 Working with Standard Parts from Windchill
To assemble standard parts from Windchill several configuration tasks need to be done.

33.2.1 Provide a Custom Configuration using the EMX _USER_CONFIG_PATH variable
In the beginning it is necessary to provide a custom configuration.

The goal is that all users within a company are working with the same configuration.
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To fulfill this goal several tasks need to be done:

1. The standard configuration folder from the EMX installation "emx-installation-
path\configuration" needs to be copied to a server location which is visible for all
users, i.e. "<server-path>\emx-adaptions\configuration".

2. This folder should have writing restrictions for all users and should only be modified by
the administrator.

3. Finally, it is required to set the Windows variable EMX_USER_CONFIG_PATH to the
value <server-path>\emx-adaptions for all users.

EMX will then find the custom configuration at this location.

33.2.2 Set EMX Option PDM_SYSTEM

1. In the EMX Options the configuration option PDM_SYSTEM needs to be set to 2 -
Windchill.
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33.2.3 Configure Part Names in EMX Options

In the EMX Options ▶ Part Names the part name rules have to be adapted in a way
that the resulting part name is project independent.

ID (<id>) or project prefix (<pre>) have to be removed.

1. For the screw E1200 with the according template file screw_E1200.prt the part
name rule is set to <instance>.
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As a result the name will be, i.e. E1200_8_60. These instance names come from the
dimension tables in the *.dat file.

33.2.4 Reduce Variety of Selectable Components in the Screw Dialog Box
When working with standard parts from Windchill it make sense to only provide the
component types which are actually administered in Windchill.

To achieve these goal the available suppliers and screw types need to be reduced.

The supplier list can be restricted by providing a adapted supplier.txt file in the correct
location. This file needs to be placed to the following path in the custom configuration.

EMX_USER_CONFIG_PATH\components\mm\screw\supplier.txt

As template, the equivalent file from the EMX standard installation can be copied.

<emx-installation-path>\components\mm\screw\supplier.txt
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In general can be said: If a file is found in the custom configuration, it has a higher priority
compared to the equivalent file from the standard installation and will be used instead.

1. In the given example the content of the supplier.txt is therefore reduce to
meusburger only.

The restrictions for the screw types follow a similar pattern. An adapted comp_data.txt
needs to be created. The location is however inside a supplier specific folder.

EMX_USER_CONFIG_PATH\components\mm\screw\meusburger\comp_data.
txt

As template, the equivalent file from the EMX standard installation can be copied.

<emx-installation-path>\components\mm\screw\meusburger\comp_
data.txt
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In this comp_data.txt all lines except the relevant E1200 line have to be deleted.

In the screw dialog only E1200 screws from Meusburger can be assembled.

33.2.5 Create All Screw Instances
Before creating the all instances of the E1200 screw one should connect to the Windchill-
Server and login as and administrator.



33.2 Working with Standard Parts from Windchill

Page 438/448

The Workspace for the Windchill library should also be activated.

Using the Component Editor all instances of a component can be created.
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Therefore theses steps a required:

1. Open the Component Editor
2. Open the file E1200.dat from the standard installation <emx-installation-

path>\components\mm\screw\meusburger\E1200.datusing Open model
or *.dat file

3. Click the button Archive all Instances.

All Instances are saved to the current workspace.
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33.2.6 Check in all Instances to the Windchill Library
To provide the created instances to all users it is now necessary to store the models in a
structured way in the Windchill library.

It is recommended to use a folder structure which is similar to the folder structure in the EMX
standard installation.

For the example screw Meusburger E1200, the following structure is used.

buw-library > emx-components > mm > screw > meusburger > e1200

Using this structure has several advantages. The stored EMX standard parts library can be
extended easily step-by-step in the future. Furthermore, it is quite simple to find the models
even after a longer period of time.

Using the Windchill Check-In mechanism the files can be stored in the e1200 folder.

After this step EMX is fully configured and screws can now be pulled from Windchill.
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33.2.7 Assembling EMX Components from Windchill (User)
From a user perspective not much changes during the assembly procedure of components.

However, within the screw dialog box the user is now informed about the source of the
model.

In case a model is found in the common space by the part names rule, an additional icon with
a short message The model is found in common space is displayed in the bottom area of the
dialog.

In case no model was found in common space and the standard assembly procedure is used,
an alternative message The model is created from local template file appears.

Additionally, the standard part status is also visualized in the Bill of Materials. Parameters can
not be edited and are therefore disabled.
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33.3 To Use Relation Files (*rel) to Add Relations to Components

33.3.1 Using the general relation file “emx_comp.rel”
The file emx_comp.rel can be used to define a relation for all EMX components (cooling,
ejector pins etc. ). It will also be applied for components from the EMX library.
NOTE:
In the default installation you will find a file called inactive_emx_comp.rel. This is a
template file that can beused as a reference. As soon as the file is renamed to emx_comp.
rel the content will be written into relation area of the Creo part.

When adding an EMX component you will find the content in the Plate, Component or
Library Dialog on the Relation tab:
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33.3.2 Using plate relation files
In case a relations needs to be added to all plates of one specific supplier the plate.rel
files can be used.

The plate.rel file needs to be added to the location <emx_install>\mm
\components\plates\<supplier>\

This relation will be written into the Relation tab of the Plate Dialog

NOTE:
The relation from emx_comp.rel will not be overwritten, instead it will be added
underneath the existing relations.

33.3.3 Using plate type specific relation files
In case a plate type specific relation needs to be added the plate_#.rel file can be used.

In this example a relation file for the plate template plate_1.prt is used.

In case the plate type specific file plate_1.rel exists the content of plate.rel is
ignored and the content of the type specific relation is used.

The plate.rel file needs to be added to the location <emx_install>\mm
\components\plates\<supplier>\
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This relation will be written into the Relation tab of the Plate Dialog

NOTE:
In EMX eight default plate template types exist. plate_1.prt is used as default for
clamping plates. Other template types are as follow:

• plate_1: Clamping Plate
• plate_2: Core Pin Retainer Plate
• plate_3: Support Plate
• plate_4: Rail Plate
• plate_5: Cavity Plate
• plate_6: Ejector Retainer Plate
• plate_7: Ejector Base Plate
• plate_8: Stripper Plate

33.3.4 Using component relation files
Similar to plates, relations can be added to other components with the component relation
files. In this example the screw specific file is used. This can be done for other component
types as well.

In case the file screw.rel is located in the location <emx_intall>\components\mm
\screw\

This content will be display in the Relation tab of the Component Dialog
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This relation will be written into the Relation tab of the Plate Dialog
NOTE:
The relation from emx_comp.rel will not be overwritten, instead it will be added
underneath the existing relations.

33.3.5 Using specific type component relation files
In case the relation should only be applied for one specific template of one supplier you can
use type specific relation files.

In this example a screw with the template name screw_e1200.prt is used

The screw_e1200.rel file needs to be added to the location <emx_install>\mm
\components\screw\<supplier>\

This content will be display in the Relation tab of the Screw Dialog
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33.3.6 Adding relations to the Post-Regeneration-Area
In case an relation should be added to the post regeneration are of the part. a relltion file with
the post fix _post_regen needs to be added in the same way as described above.

emx_comp_post_regen.rel , plate_post_regen.rel etc,
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